non i386 dont have <machine/spkr.h>
	<net/ieee81102.h> needs <net/if.h> first
This commit is contained in:
reinoud 2004-10-21 21:25:23 +00:00
parent 91af107084
commit c90a374091
4 changed files with 68 additions and 1 deletions

View file

@ -1,4 +1,7 @@
$NetBSD: distinfo,v 1.3 2004/10/20 22:17:31 xtraeme Exp $
$NetBSD: distinfo,v 1.4 2004/10/21 21:25:23 reinoud Exp $
SHA1 (wistumbler2.00-pre9.tar.gz) = c33709bdc9ff7c7ec6bb23132f2594ec4a143a71
Size (wistumbler2.00-pre9.tar.gz) = 40641 bytes
SHA1 (patch-aa) = 26313441ad1686f42d505b5823101b51abe425be
SHA1 (patch-ab) = 6efc148573cb17d5ca149f1d5bd1265753f2ca58
SHA1 (patch-ac) = 00e6e6cd043f39265d960ef1c113dd077939813b

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1 2004/10/21 21:25:23 reinoud Exp $
--- src/stumbler.h.orig 2004-07-03 19:55:01.000000000 +0200
+++ src/stumbler.h
@@ -60,8 +60,10 @@
#include <dev/ic/if_wi_ieee.h>
#else
#if __NetBSD_Version__ > 106220000
+#include <net/if.h>
#include <net80211/ieee80211.h>
#else
+#include <net/if.h>
#include <net/if_ieee80211.h>
#include <sys/types.h>
#include <sys/socket.h>

View file

@ -0,0 +1,30 @@
$NetBSD: patch-ab,v 1.1 2004/10/21 21:25:23 reinoud Exp $
--- configure.orig 2003-11-30 00:39:01.000000000 +0100
+++ configure
@@ -95,6 +95,16 @@ if [ "${USE_GTK}" = "0" ]; then
GTK=0;
fi
+printf "[*] Checking for beeper...\t\t\t"
+if [ -f /usr/include/machine/spkr.h -o -f /usr/include/machine/speaker.h ]; then
+ SPEAKER=1
+ echo "OK"
+else
+ SPEAKER=0
+ echo "NOT PRESENT"
+fi
+
+
# Clean exit
printf "\n== Configuration done. Now type 'make' ==\n\n"
echo "PREFIX=${PREFIX}" > CONFIG
@@ -115,4 +125,8 @@ else
echo "CFLAGS+=-DUSE_PCAP" >> CONFIG
echo "LDFLAGS+=-lpcap" >> CONFIG
fi
+if [ "${SPEAKER}" = "1" ]; then
+ echo "CFLAGS+=-DSPEAKER_PRESENT" >> CONFIG
+fi
+
exit 0

View file

@ -0,0 +1,19 @@
$NetBSD: patch-ac,v 1.1 2004/10/21 21:25:23 reinoud Exp $
--- src/speaker.c.orig 2003-11-17 21:47:38.000000000 +0100
+++ src/speaker.c
@@ -32,4 +32,9 @@
*/
+#ifndef DSPEAKER_PRESENT
+ void swap_beep(void) {};
+ void do_beep(int pc) {};
+#else /* DSPEAKER_PRESENT */
+
#include <stdio.h>
#include <string.h>
@@ -101,3 +106,3 @@ void do_beep(pc)
fclose(fd);
}
-
+#endif /* DSPEAKER_PRESENT */