Update audio/{py-mutagen,mutagen-tools} to 1.37.

pkgsrc changes:
 - Update MASTER_SITES to MASTER_SITE_PYPI
 - Update HOMEPAGE
 - Clarify - a bit - comments regarding patches/patch-aa, they're needed to omit
   respectively {script,module} installations due the mutagen-tools separation

Changes (changelog regarding 1.27...1.31 was adjusted to only reflect changes
pertinent to mutagen-tools that was not previosly synced with py-mutagen):
1.37 - 2017.02.24
-----------------

* Relicense "GPLv2" → "GPLv2 or later" 🐛`291`
* DSF: add `mutagen.dsf` module for DSF (DSD Stream File) support
  :pr:`283` (Boris Pruessmann)
* MP3: Add `mp3.MPEGInfo.encoder_settings` containing a guess of the encoder
  settings used, for example ``"-V2"`` for LAME 🐛`66`
* ID3: add iTunes movement related frames `id3.MVIN` and `id3.MVNM`
* MP4: support ``©mvi``, ``©mvc``, ``shwm``, ``stik``, ``rtng``, ``tves``,
  ``tvsn``, ``plID``, ``cnID``, ``geID``, ``atID``, ``sfID``, ``cmID``,
  ``akID`` 🐛`130`


1.36.3 - 2017.02.24
-------------------

* MP3: fix error with xing frames without a frame count 🐛`292`


1.36.2 - 2017.01.25
-------------------

* ID3: Always write little endian utf-16 with BOM.
  Fixes tests on big endian machines :pr:`289`


1.36.1 - 2017.01.22
-------------------

* Support GAE runtime 🐛`286`
* FLAC: Fix crash when loading files with zero samples 🐛`287`
* MP3: Handle broken lame tags written by older lame versions


1.36 - 2016.12.22
-----------------

* ID3: Ignore trailing empty values for v2.3 text frames 🐛`276`
* ID3: Write large APIC frames last 🐛`278`
* EasyID3: support saving as v2.3 🐛`188`
* FLAC: Add StreamInfo.bitrate 🐛`279`
* mid3cp: Add ``--merge`` option 🐛`277`
* MP4: Allow loading files without audio tracks 🐛`272`


1.35.1 - 2016.11.09
-------------------

* Revert back to distutils 🐛`273`


1.35 - 2016.11.02
-----------------

* Tests: Require pytest
* Tools: Install .exe launchers on Windows
* setup.py: Require setuptools
* ID3:

  * Fix loading files with CRM frames 🐛`239`
  * Fix loading AENC, LINK, GRID frames with no payload
  * Merge duplicate text frames with same key on load 🐛`172`
  * Allow parsing of duplicate APIC frames 🐛`172`
  * Parse utf-16 text fields with missing BOM 🐛`267`
  * Increase max resyncs for the mpeg frame search 🐛`268`


1.34.1 - 2016.08.13
-------------------

* ID3: Expose some internals again to make Picard (mostly) work again.

  * http://tickets.musicbrainz.org/browse/PICARD-833
  * https://github.com/metabrainz/picard/pull/479


1.34 - 2016.07.20
-----------------

* ID3:

  * Add `CTOC <id3.CTOC>` and `CHAP <id3.CHAP>` frames. New classes:
    `ID3Tags <id3.ID3Tags>`, `CTOCFlags <id3.CTOCFlags>`. 🐛`6`
  * Add `TCAT <id3.TCAT>`, `TKWD <id3.TKWD>`, `PCST <id3.PCST>` frames.
    🐛`249`
  * Validate user provided LNK/LINK frameid. 🐛`242`
  * Add `RVAD <id3.RVAD>`, RVA frames
  * Add TST, TSA, TS2, TSP and TSC frames
  * Fix not writing optional fields when saving to v2.3
  * Add default field values for all frames

* Drop Python 2.6 support
* EasyID3: Fix TXXX frame encoding when setting a non-latin1 encodable
  value after a latin1 one. 🐛`263`


1.33.2 - 2016.07.05
-------------------

* Fix loading of small ogg/apev2 files (1.33 regression)


1.33.1 - 2016.06.29
-------------------

* Fix Overeager deprecation warnings 🐛`261`


1.33 - 2016.06.29
-----------------

* FileType, Metadata: File-like object support 🐛`1`
* mid3v2: Add APIC support. 🐛`47`
* EasyID3: Fix handling of RVA2 frames with non-lowercase description
  🐛`215`
* mid3v2: Add UFID support. 🐛`234`
* ID3: Include human-readable representation of the picture type in
  APIC._pprint() 🐛`244`
* EasyID3: make albumartist use TPE2 and move performer to TXXX. 🐛`252`
* ID3: id3.ID3TimeStamp comparator: check type :pr:`260`
  (Fabian Peter Hammerle)
* setup.py: follow PEP440 for the development version
* FileType/Metadata.load/save/delete no longer raise IOError or IOError
  subclasses. They only raise subclasses of MutagenError.


1.32 - 2016.05.02
-----------------

* Add basic SMF (Standard MIDI File) support (:mod:`mutagen.smf`)
* FLAC: add ``audio/flac`` mime type. 🐛`235`
* ASF: Fixed crash when object size is longer than the header and file length
  (Ben Ockmore)
* ID3: Validate attributes set after frame creation :bb-pr:`8`
  (Daniel Plachotich)
* MP4: validate values in ``__setitem__`` so things don't fail in save()
  🐛`236`
* tests: Fix SynchronizedTextSpec test on big-endian machines 🐛`247`
  (Daniel Plachotich)
* ID3: do type checking in ``__setitem__`` 🐛`251`
* Building the documentation now requires sphinx >= 1.3
* New :class:`mutagen.Tags` base class for tags
* Moved from Bitbucket to GitHub

1.31 - 2015.09.10
-----------------

* Tools: Support Unicode output under Windows 🐛`232`

1.30 - 2015.08.22
-----------------

* No change relevant for tools

1.29 - 2015.05.09
-----------------

* mid3v2: Fix an error under Python 3 with files without tags 🐛`219`
* mid3v2: Various Windows+Python2+Unicode fixes 🐛`214`

1.28 - 2015.03.06
-----------------

* Tools:

  * Add signal handling 🐛`170`
  * mid3cp: Make it work under Windows.
  * mutagen-inspect: Make it work under Windows+Python3 🐛`216`
  * Support unicode file paths under Windows+Python2 🐛`214`
  * Support file paths with invalid encoding under Unix+Python3.
This commit is contained in:
leot 2017-05-09 13:14:32 +00:00
parent 5fb4e861e5
commit c91ae7fc8d
7 changed files with 146 additions and 65 deletions

View file

@ -1,20 +1,25 @@
# $NetBSD: Makefile,v 1.9 2017/01/01 14:43:22 wiz Exp $
# $NetBSD: Makefile,v 1.10 2017/05/09 13:14:32 leot Exp $
DISTNAME= mutagen-1.27
PKGNAME= mutagen-tools-1.27
DISTNAME= mutagen-1.37
PKGNAME= ${DISTNAME:S/-/-tools-/}
CATEGORIES= audio
MASTER_SITES= https://bitbucket.org/lazka/mutagen/downloads/
MASTER_SITES= ${MASTER_SITE_PYPI:=m/mutagen/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://bitbucket.org/lazka/mutagen
HOMEPAGE= https://github.com/quodlibet/mutagen
COMMENT= Audio metadata handling for Python
LICENSE= gnu-gpl-v2
DEPENDS+= ${PYPKGPREFIX}-mutagen-[0-9]*:../../audio/py-mutagen
DEPENDS+= ${PYPKGPREFIX}-mutagen-[0-9]*:../../audio/py-mutagen
SUBST_CLASSES+= pkgmandir
SUBST_STAGE.pkgmandir= pre-configure
SUBST_FILES.pkgmandir= setup.py
SUBST_MESSAGE.pkgmandir= Fixing man page installation.
SUBST_SED.pkgmandir= -e 's,share/man,${PKGMANDIR},'
USE_LANGUAGES= # none
PY_NO_EGG= yes
PYTHON_VERSIONS_INCOMPATIBLE= 34 35 36 # string type problems
.include "../../lang/python/distutils.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.5 2015/11/03 01:12:43 agc Exp $
$NetBSD: distinfo,v 1.6 2017/05/09 13:14:32 leot Exp $
SHA1 (mutagen-1.27.tar.gz) = 4c9b874feb6f1e9dbf6f2c37341dad3a47135640
RMD160 (mutagen-1.27.tar.gz) = b6d4c5c880b9eba4b0377e04421c840392c20eff
SHA512 (mutagen-1.27.tar.gz) = ae15fb3f5d77025a60e25a2ed25e23f7d21160d4e63c49fe7d01508440ff1f6b673cf34d8f4facc834824825ad6f4d3ed9830133db5aba339ac1eae46f7f50d5
Size (mutagen-1.27.tar.gz) = 875720 bytes
SHA1 (patch-aa) = c1a76e5371b2fdcb3e81af58fd783048577f1f77
SHA1 (mutagen-1.37.tar.gz) = 973e29c3b27f2b99ac5b18899ef07c2c8c9b035e
RMD160 (mutagen-1.37.tar.gz) = 8a8bce64ed57d7637a590e163a7e27f329a6a297
SHA512 (mutagen-1.37.tar.gz) = f1bdd3d56526be718642d6599e7353879dc7e16f3d8758ff0221224310f5952cdc097dd70202be4b93c3a661f83b4f0d3e7730464f077d89614883571b80b180
Size (mutagen-1.37.tar.gz) = 912600 bytes
SHA1 (patch-aa) = 2c8e4fea8d9afcfca4f86ae7704b1e84df53c817

View file

@ -1,22 +1,32 @@
$NetBSD: patch-aa,v 1.4 2015/01/06 19:53:14 drochner Exp $
$NetBSD: patch-aa,v 1.5 2017/05/09 13:14:32 leot Exp $
--- setup.py.orig 2014-11-26 13:18:57.000000000 +0000
Do not install any Python packages. They are provided separatedly by the
audio/py-mutagen package.
--- setup.py.orig 2017-02-24 13:15:32.000000000 +0000
+++ setup.py
@@ -219,7 +219,7 @@ class coverage_cmd(Command):
if os.name == "posix":
- data_files = [('share/man/man1', glob.glob("man/*.1"))]
+ data_files = [(os.getenv("PKGMANDIR") + '/man1', glob.glob("man/*.1"))]
else:
data_files = []
@@ -255,7 +255,7 @@ if __name__ == "__main__":
@@ -258,15 +258,15 @@ if __name__ == "__main__":
'License :: OSI Approved :: GNU General Public License v2 (GPLv2)',
'Topic :: Multimedia :: Sound/Audio',
],
- packages=["mutagen", "mutagen.id3", "mutagen.mp4"],
+# packages=["mutagen", "mutagen.id3", "mutagen.mp4"],
- packages=[
- "mutagen",
- "mutagen.id3",
- "mutagen.mp4",
- "mutagen.asf",
- "mutagen.mp3",
- "mutagen._senf",
- "mutagen._tools",
- ],
+# packages=[
+# "mutagen",
+# "mutagen.id3",
+# "mutagen.mp4",
+# "mutagen.asf",
+# "mutagen.mp3",
+# "mutagen._senf",
+# "mutagen._tools",
+# ],
data_files=data_files,
scripts=[os.path.join("tools", name) for name in [
"mid3cp",

View file

@ -1,12 +1,12 @@
# $NetBSD: Makefile,v 1.17 2015/11/04 09:53:40 wiz Exp $
# $NetBSD: Makefile,v 1.18 2017/05/09 13:14:32 leot Exp $
DISTNAME= mutagen-1.31
DISTNAME= mutagen-1.37
PKGNAME= ${PYPKGPREFIX}-${DISTNAME}
CATEGORIES= audio
MASTER_SITES= https://bitbucket.org/lazka/mutagen/downloads/
MASTER_SITES= ${MASTER_SITE_PYPI:=m/mutagen/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://bitbucket.org/lazka/mutagen
HOMEPAGE= https://github.com/quodlibet/mutagen
COMMENT= Audio metadata handling for Python
LICENSE= gnu-gpl-v2

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.11 2015/11/04 09:53:40 wiz Exp $
@comment $NetBSD: PLIST,v 1.12 2017/05/09 13:14:32 leot Exp $
${PYSITELIB}/${EGG_FILE}
${PYSITELIB}/mutagen/__init__.py
${PYSITELIB}/mutagen/__init__.pyc
@ -12,15 +12,63 @@ ${PYSITELIB}/mutagen/_constants.pyo
${PYSITELIB}/mutagen/_file.py
${PYSITELIB}/mutagen/_file.pyc
${PYSITELIB}/mutagen/_file.pyo
${PYSITELIB}/mutagen/_mp3util.py
${PYSITELIB}/mutagen/_mp3util.pyc
${PYSITELIB}/mutagen/_mp3util.pyo
${PYSITELIB}/mutagen/_senf/__init__.py
${PYSITELIB}/mutagen/_senf/__init__.pyc
${PYSITELIB}/mutagen/_senf/__init__.pyo
${PYSITELIB}/mutagen/_senf/_argv.py
${PYSITELIB}/mutagen/_senf/_argv.pyc
${PYSITELIB}/mutagen/_senf/_argv.pyo
${PYSITELIB}/mutagen/_senf/_compat.py
${PYSITELIB}/mutagen/_senf/_compat.pyc
${PYSITELIB}/mutagen/_senf/_compat.pyo
${PYSITELIB}/mutagen/_senf/_environ.py
${PYSITELIB}/mutagen/_senf/_environ.pyc
${PYSITELIB}/mutagen/_senf/_environ.pyo
${PYSITELIB}/mutagen/_senf/_fsnative.py
${PYSITELIB}/mutagen/_senf/_fsnative.pyc
${PYSITELIB}/mutagen/_senf/_fsnative.pyo
${PYSITELIB}/mutagen/_senf/_print.py
${PYSITELIB}/mutagen/_senf/_print.pyc
${PYSITELIB}/mutagen/_senf/_print.pyo
${PYSITELIB}/mutagen/_senf/_stdlib.py
${PYSITELIB}/mutagen/_senf/_stdlib.pyc
${PYSITELIB}/mutagen/_senf/_stdlib.pyo
${PYSITELIB}/mutagen/_senf/_temp.py
${PYSITELIB}/mutagen/_senf/_temp.pyc
${PYSITELIB}/mutagen/_senf/_temp.pyo
${PYSITELIB}/mutagen/_senf/_winansi.py
${PYSITELIB}/mutagen/_senf/_winansi.pyc
${PYSITELIB}/mutagen/_senf/_winansi.pyo
${PYSITELIB}/mutagen/_senf/_winapi.py
${PYSITELIB}/mutagen/_senf/_winapi.pyc
${PYSITELIB}/mutagen/_senf/_winapi.pyo
${PYSITELIB}/mutagen/_tags.py
${PYSITELIB}/mutagen/_tags.pyc
${PYSITELIB}/mutagen/_tags.pyo
${PYSITELIB}/mutagen/_toolsutil.py
${PYSITELIB}/mutagen/_toolsutil.pyc
${PYSITELIB}/mutagen/_toolsutil.pyo
${PYSITELIB}/mutagen/_tools/__init__.py
${PYSITELIB}/mutagen/_tools/__init__.pyc
${PYSITELIB}/mutagen/_tools/__init__.pyo
${PYSITELIB}/mutagen/_tools/_util.py
${PYSITELIB}/mutagen/_tools/_util.pyc
${PYSITELIB}/mutagen/_tools/_util.pyo
${PYSITELIB}/mutagen/_tools/mid3cp.py
${PYSITELIB}/mutagen/_tools/mid3cp.pyc
${PYSITELIB}/mutagen/_tools/mid3cp.pyo
${PYSITELIB}/mutagen/_tools/mid3iconv.py
${PYSITELIB}/mutagen/_tools/mid3iconv.pyc
${PYSITELIB}/mutagen/_tools/mid3iconv.pyo
${PYSITELIB}/mutagen/_tools/mid3v2.py
${PYSITELIB}/mutagen/_tools/mid3v2.pyc
${PYSITELIB}/mutagen/_tools/mid3v2.pyo
${PYSITELIB}/mutagen/_tools/moggsplit.py
${PYSITELIB}/mutagen/_tools/moggsplit.pyc
${PYSITELIB}/mutagen/_tools/moggsplit.pyo
${PYSITELIB}/mutagen/_tools/mutagen_inspect.py
${PYSITELIB}/mutagen/_tools/mutagen_inspect.pyc
${PYSITELIB}/mutagen/_tools/mutagen_inspect.pyo
${PYSITELIB}/mutagen/_tools/mutagen_pony.py
${PYSITELIB}/mutagen/_tools/mutagen_pony.pyc
${PYSITELIB}/mutagen/_tools/mutagen_pony.pyo
${PYSITELIB}/mutagen/_util.py
${PYSITELIB}/mutagen/_util.pyc
${PYSITELIB}/mutagen/_util.pyo
@ -48,6 +96,9 @@ ${PYSITELIB}/mutagen/asf/_objects.pyo
${PYSITELIB}/mutagen/asf/_util.py
${PYSITELIB}/mutagen/asf/_util.pyc
${PYSITELIB}/mutagen/asf/_util.pyo
${PYSITELIB}/mutagen/dsf.py
${PYSITELIB}/mutagen/dsf.pyc
${PYSITELIB}/mutagen/dsf.pyo
${PYSITELIB}/mutagen/easyid3.py
${PYSITELIB}/mutagen/easyid3.pyc
${PYSITELIB}/mutagen/easyid3.pyo
@ -60,12 +111,21 @@ ${PYSITELIB}/mutagen/flac.pyo
${PYSITELIB}/mutagen/id3/__init__.py
${PYSITELIB}/mutagen/id3/__init__.pyc
${PYSITELIB}/mutagen/id3/__init__.pyo
${PYSITELIB}/mutagen/id3/_file.py
${PYSITELIB}/mutagen/id3/_file.pyc
${PYSITELIB}/mutagen/id3/_file.pyo
${PYSITELIB}/mutagen/id3/_frames.py
${PYSITELIB}/mutagen/id3/_frames.pyc
${PYSITELIB}/mutagen/id3/_frames.pyo
${PYSITELIB}/mutagen/id3/_id3v1.py
${PYSITELIB}/mutagen/id3/_id3v1.pyc
${PYSITELIB}/mutagen/id3/_id3v1.pyo
${PYSITELIB}/mutagen/id3/_specs.py
${PYSITELIB}/mutagen/id3/_specs.pyc
${PYSITELIB}/mutagen/id3/_specs.pyo
${PYSITELIB}/mutagen/id3/_tags.py
${PYSITELIB}/mutagen/id3/_tags.pyc
${PYSITELIB}/mutagen/id3/_tags.pyo
${PYSITELIB}/mutagen/id3/_util.py
${PYSITELIB}/mutagen/id3/_util.pyc
${PYSITELIB}/mutagen/id3/_util.pyo
@ -75,9 +135,12 @@ ${PYSITELIB}/mutagen/m4a.pyo
${PYSITELIB}/mutagen/monkeysaudio.py
${PYSITELIB}/mutagen/monkeysaudio.pyc
${PYSITELIB}/mutagen/monkeysaudio.pyo
${PYSITELIB}/mutagen/mp3.py
${PYSITELIB}/mutagen/mp3.pyc
${PYSITELIB}/mutagen/mp3.pyo
${PYSITELIB}/mutagen/mp3/__init__.py
${PYSITELIB}/mutagen/mp3/__init__.pyc
${PYSITELIB}/mutagen/mp3/__init__.pyo
${PYSITELIB}/mutagen/mp3/_util.py
${PYSITELIB}/mutagen/mp3/_util.pyc
${PYSITELIB}/mutagen/mp3/_util.pyo
${PYSITELIB}/mutagen/mp4/__init__.py
${PYSITELIB}/mutagen/mp4/__init__.pyc
${PYSITELIB}/mutagen/mp4/__init__.pyo
@ -114,6 +177,9 @@ ${PYSITELIB}/mutagen/oggvorbis.pyo
${PYSITELIB}/mutagen/optimfrog.py
${PYSITELIB}/mutagen/optimfrog.pyc
${PYSITELIB}/mutagen/optimfrog.pyo
${PYSITELIB}/mutagen/smf.py
${PYSITELIB}/mutagen/smf.pyc
${PYSITELIB}/mutagen/smf.pyo
${PYSITELIB}/mutagen/trueaudio.py
${PYSITELIB}/mutagen/trueaudio.pyc
${PYSITELIB}/mutagen/trueaudio.pyo

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.11 2015/11/04 09:53:40 wiz Exp $
$NetBSD: distinfo,v 1.12 2017/05/09 13:14:32 leot Exp $
SHA1 (mutagen-1.31.tar.gz) = 09721ea47b9ebdf0c76a7b2e07cdd50c23993e10
RMD160 (mutagen-1.31.tar.gz) = 3573207b601a31e0dcdb9440c59fbec21e2b5417
SHA512 (mutagen-1.31.tar.gz) = d603afa049e2223dc1050ee26101add4150f8ca57fcee1bbbfd1233276b15fda5972d58e8472135396e54f2778219462619fbec8dddb97c35a7fb7638fec0c23
Size (mutagen-1.31.tar.gz) = 897785 bytes
SHA1 (patch-aa) = 05453c544b1d242000b1c897c9a42450d86ca4cb
SHA1 (mutagen-1.37.tar.gz) = 973e29c3b27f2b99ac5b18899ef07c2c8c9b035e
RMD160 (mutagen-1.37.tar.gz) = 8a8bce64ed57d7637a590e163a7e27f329a6a297
SHA512 (mutagen-1.37.tar.gz) = f1bdd3d56526be718642d6599e7353879dc7e16f3d8758ff0221224310f5952cdc097dd70202be4b93c3a661f83b4f0d3e7730464f077d89614883571b80b180
Size (mutagen-1.37.tar.gz) = 912600 bytes
SHA1 (patch-aa) = a43b06c204080283674a4afacafbc356fbaab021

View file

@ -1,13 +1,14 @@
$NetBSD: patch-aa,v 1.7 2015/11/04 09:53:40 wiz Exp $
$NetBSD: patch-aa,v 1.8 2017/05/09 13:14:32 leot Exp $
Do not install the command line tools. -- drochner, 2009
Do not install the command line tools. The tools are provided separately by
mutagen-tools package.
--- setup.py.orig 2014-11-26 13:18:57.000000000 +0000
--- setup.py.orig 2017-02-24 13:15:32.000000000 +0000
+++ setup.py
@@ -256,15 +256,15 @@ if __name__ == "__main__":
'Topic :: Multimedia :: Sound/Audio',
@@ -267,14 +267,14 @@ if __name__ == "__main__":
"mutagen._senf",
"mutagen._tools",
],
packages=["mutagen", "mutagen.id3", "mutagen.mp4", "mutagen.asf"],
- data_files=data_files,
- scripts=[os.path.join("tools", name) for name in [
- "mid3cp",
@ -17,15 +18,14 @@ Do not install the command line tools. -- drochner, 2009
- "mutagen-inspect",
- "mutagen-pony",
- ]],
+# data_files=data_files,
+# scripts=[os.path.join("tools", name) for name in [
+# "mid3cp",
+# "mid3iconv",
+# "mid3v2",
+# "moggsplit",
+# "mutagen-inspect",
+# "mutagen-pony",
+# ]],
long_description="""\
Mutagen is a Python module to handle audio metadata. It supports ASF,
FLAC, M4A, Monkey's Audio, MP3, Musepack, Ogg FLAC, Ogg Speex, Ogg
+# data_files=data_files,
+# scripts=[os.path.join("tools", name) for name in [
+# "mid3cp",
+# "mid3iconv",
+# "mid3v2",
+# "moggsplit",
+# "mutagen-inspect",
+# "mutagen-pony",
+# ]],
long_description=long_description,
)