Update to 4.16:

Version 4.16
============

  - From Windows version of 7-zip 4.16 :
    - Speed optimization (5%) for 7z / LZMA
    - 7za now supports .Z archives
    - -r- switch in command line now is default for all commands
    - Some bugs were fixed

  - From Windows version of 7-zip 4.15 :
    - Z format supporting (extracting only)
    - 7-Zip now can extract ZIP archives compressed with "Shrink" method
    - 7-Zip now doesn't interrupt the compressing when it can not open file.
      7-Zip just skips that file and shows warning.
    - Some bugs were fixed

  - man pages added (thanks to Mohammed Adnene Trojette)
  - bug #1112167 fixed (Temporary directory must be on same partition as target)
    p7zip failed moving the temporary file at the end of
    compressing to target file if the directories don't reside
    on the same partition (or network path).
  - bug #1164659 fixed (Invalid file date for "big endian" machine)
  - p7zip now uses ".so" instead of ".dll"
  - p7zip now handles "ctrl-c" and "kill" to cleanup temporary files before exiting
  - p7zip now runs on BeOS.
  - better support of filenames with spaces.
  - some code cleanup
    - "myWindows/myFiles.cpp" is now in "Windows/FileIO.cpp"
    - "myWindows/myFindFile.cpp" is now in "Windows/FileFind.cpp"
    - "myWindows/myDirectoryAndPath.cpp" is now in "Windows/FileDir.cpp"
    - "myWindows/myEvents.cpp" is now in "Windows/Synchronization.cpp"
    - "myWindows/wine_strings.cpp" is now in "Windows/String.cpp"
This commit is contained in:
wiz 2005-04-15 14:16:08 +00:00
parent 5f15591de2
commit c9217486c4
5 changed files with 34 additions and 33 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.9 2005/04/11 21:44:49 tv Exp $
# $NetBSD: Makefile,v 1.10 2005/04/15 14:16:08 wiz Exp $
#
DISTNAME= p7zip_4.14.01_src
PKGNAME= p7zip-4.14.01
DISTNAME= p7zip_4.16_src
PKGNAME= p7zip-4.16
CATEGORIES= archivers
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=p7zip/}
EXTRACT_SUFX= .tar.bz2
@ -62,6 +62,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/DOCS/MANUAL/*.* ${PREFIX}/share/doc/p7zip
${INSTALL_DATA} ${WRKSRC}/DOCS/MANUAL/commands/*.* ${PREFIX}/share/doc/p7zip/commands
${INSTALL_DATA} ${WRKSRC}/DOCS/MANUAL/switches/*.* ${PREFIX}/share/doc/p7zip/switches
${INSTALL_MAN} ${WRKSRC}/man1/7z.1 ${PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man1/7za.1 ${PREFIX}/man/man1
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.4 2005/02/07 14:13:28 wiz Exp $
@comment $NetBSD: PLIST,v 1.5 2005/04/15 14:16:08 wiz Exp $
bin/7z
bin/7za
${DYNAMIC_7Z}lib/7z/7z
@ -24,6 +24,8 @@ ${DYNAMIC_7Z}lib/7z/Formats/deb.dll
${DYNAMIC_7Z}lib/7z/Formats/gz.dll
${DYNAMIC_7Z}lib/7z/Formats/rpm.dll
${DYNAMIC_7Z}lib/7z/Formats/split.dll
man/man1/7z.1
man/man1/7za.1
share/doc/p7zip/README
share/doc/p7zip/commands/add.htm
share/doc/p7zip/commands/delete.htm

View file

@ -1,8 +1,8 @@
$NetBSD: distinfo,v 1.8 2005/02/23 14:45:25 agc Exp $
$NetBSD: distinfo,v 1.9 2005/04/15 14:16:08 wiz Exp $
SHA1 (p7zip_4.14.01_src.tar.bz2) = c8df9c08844c4cff559abc0b5cc915867fcb8390
RMD160 (p7zip_4.14.01_src.tar.bz2) = eab2f47847ab9f6f54e348ef375f6d5671f8c0b8
Size (p7zip_4.14.01_src.tar.bz2) = 457428 bytes
SHA1 (patch-aa) = 7affd2f921d5041ad55243d495005f5b37a56334
SHA1 (patch-ab) = 9a6c7dcd97f585bf7b322e6815cdf3de6e0b0c38
SHA1 (p7zip_4.16_src.tar.bz2) = 4c248c362c720c30a72ded4277642a13aa8fb73c
RMD160 (p7zip_4.16_src.tar.bz2) = fbb78fbfb4d173086a7d810bfe4521329c4b1ee7
Size (p7zip_4.16_src.tar.bz2) = 456065 bytes
SHA1 (patch-aa) = d92632b2c20dee606bf7612c5c66b8d034b8a310
SHA1 (patch-ab) = abf051b0dfee1e49e1519aa54301d348791b4090
SHA1 (patch-ac) = cb1dad78148e0356c7c63eaee01e7de21b0bde88

View file

@ -1,23 +1,20 @@
$NetBSD: patch-aa,v 1.5 2005/02/07 14:13:29 wiz Exp $
$NetBSD: patch-aa,v 1.6 2005/04/15 14:16:08 wiz Exp $
--- makefile.machine.orig 2005-01-23 16:18:54.000000000 +0100
--- makefile.machine.orig 2005-03-05 16:37:15.000000000 +0100
+++ makefile.machine
@@ -1,8 +1,7 @@
-ALLFLAGS=-Wall -O2 -s -fPIC \
+ALLFLAGS=-Wall -s -fPIC \
@@ -2,7 +2,7 @@
# makefile for Linux (x86, PPC, alpha ...)
# LITTLE_ENDIAN and BIG_ENDIAN are already defined by the system headers
#
-ALLFLAGS=-Wall -O2 -s \
+ALLFLAGS=-Wall -s \
-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE \
-DNDEBUG -D_REENTRANT -DENV_UNIX \
- -DLITTLE_ENDIAN \
$(LOCAL_FLAGS)
CXX=g++ $(ALLFLAGS)
@@ -10,7 +9,7 @@ CC=gcc $(ALLFLAGS)
@@ -12,5 +12,5 @@ CC=gcc $(ALLFLAGS)
LINK_SHARED=-shared
LOCAL_LIBS=-lpthread
-LOCAL_LIBS_DLL=$(LOCAL_LIBS) -ldl
+LOCAL_LIBS_DLL=$(LOCAL_LIBS)
# static linkage
# LOCAL_LIBS=-static -lpthread

View file

@ -1,14 +1,14 @@
$NetBSD: patch-ab,v 1.3 2005/02/07 14:13:29 wiz Exp $
$NetBSD: patch-ab,v 1.4 2005/04/15 14:16:08 wiz Exp $
--- myWindows/myFindFile.cpp.orig 2005-01-17 00:16:56.000000000 +0100
+++ myWindows/myFindFile.cpp
@@ -197,7 +197,8 @@ extern "C" HANDLE WINAPI FindFirstFileA(
}
--- Windows/FileFind.cpp.orig 2005-04-01 18:16:52.000000000 +0200
+++ Windows/FileFind.cpp
@@ -169,7 +169,8 @@ bool CFindFile::FindFirst(LPCTSTR wildca
}
TRACEN((printf("FindFirstFileA : closedir-2(dirp=%p)\n",retour->dirp)))
- closedir(retour->dirp);
+ if (retour->dirp)
+ closedir(retour->dirp);
delete retour;
TRACEN((printf("CFindFile::FindFirst : closedir-2(dirp=%p)\n",_dirp)))
- closedir(_dirp);
+ if (_dirp)
+ closedir(_dirp);
_dirp = 0;
SetLastError( ERROR_NO_MORE_FILES );
return INVALID_HANDLE_VALUE;
return false;