fix function prototype to match body in order to avoid:
>xfce-taskmanager-linux.c:33:6: error: conflicting types for 'get_task_details' > void get_task_details(pid_t pid,struct task *task) > ^ >In file included from xfce-taskmanager-linux.c:30:0: >xfce-taskmanager-linux.h:41:6: note: previous declaration of 'get_task_details' was here > void get_task_details(gint pid,struct task *task); > ^
This commit is contained in:
parent
d25c488a3d
commit
c933b65636
2 changed files with 16 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.1 2016/05/23 10:50:35 youri Exp $
|
||||
$NetBSD: distinfo,v 1.2 2016/08/17 15:19:42 richard Exp $
|
||||
|
||||
SHA1 (lxtask-0.1.7.tar.xz) = 05a44a6bdd52674d5a465e50eacf71f217d1e66b
|
||||
RMD160 (lxtask-0.1.7.tar.xz) = 020ed18849ca4fb719a2cfa538c5086d74d0c902
|
||||
SHA512 (lxtask-0.1.7.tar.xz) = eb5c6af2d0953d09d62b53efda1f88140cc6d5734ef98effd9a72b896e397d0c29ff4263b93c12fd23fcb0ec129b31eb769b0a8c769ae92ed9fc1d2f2689a4ef
|
||||
Size (lxtask-0.1.7.tar.xz) = 137152 bytes
|
||||
SHA1 (patch-src_xfce-taskmanager-linux.h) = 2f8c07e09af1a0d066d7306f6ac6ec67de94a7d6
|
||||
|
|
14
sysutils/lxtask/patches/patch-src_xfce-taskmanager-linux.h
Normal file
14
sysutils/lxtask/patches/patch-src_xfce-taskmanager-linux.h
Normal file
|
@ -0,0 +1,14 @@
|
|||
$NetBSD: patch-src_xfce-taskmanager-linux.h,v 1.1 2016/08/17 15:19:42 richard Exp $
|
||||
fix declaration to be the same as the implementation.
|
||||
|
||||
--- src/xfce-taskmanager-linux.h.orig 2014-09-16 12:27:52.000000000 +0000
|
||||
+++ src/xfce-taskmanager-linux.h
|
||||
@@ -38,7 +38,7 @@
|
||||
#define SIGNAL_CONT SIGCONT
|
||||
#define SIGNAL_STOP SIGSTOP
|
||||
|
||||
-void get_task_details(gint pid,struct task *task);
|
||||
+void get_task_details(pid_t pid,struct task *task);
|
||||
GArray *get_task_list(void);
|
||||
gboolean get_system_status(system_status *sys_stat);
|
||||
gboolean get_cpu_usage_from_proc(system_status *sys_stat);
|
Loading…
Reference in a new issue