with is a keyword starting with Python 2.6 by default, so don't use it

as parameter name.
This commit is contained in:
joerg 2009-11-30 19:24:06 +00:00
parent a544e5dfe6
commit c965aa41c2
2 changed files with 17 additions and 1 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.3 2006/02/20 23:16:00 wiz Exp $
$NetBSD: distinfo,v 1.4 2009/11/30 19:24:06 joerg Exp $
SHA1 (Gnosis_Utils-1.1.1.tar.gz) = 7e4477d5133656949550c3dfaef5406a601700c5
RMD160 (Gnosis_Utils-1.1.1.tar.gz) = 44c98cd6a8365439f94e77ab42c60e3a09e23163
Size (Gnosis_Utils-1.1.1.tar.gz) = 224646 bytes
SHA1 (patch-aa) = 1162bd97f4c811a8ca16a43a7778fefb449d0912
SHA1 (patch-ab) = 9a70e0b7ad1ca2b5cffe20fb8307c9ee2b4f17c8

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ab,v 1.1 2009/11/30 19:24:06 joerg Exp $
--- gnosis/util/convert/pyfontify.py.orig 2009-11-30 20:12:42.000000000 +0100
+++ gnosis/util/convert/pyfontify.py
@@ -31,8 +31,8 @@ import string, regex
# First a little helper, since I don't like to repeat things. (Tismer speaking)
import string
-def replace(where, what, with):
- return string.join(string.split(where, what), with)
+def replace(where, what, with_):
+ return string.join(string.split(where, what), with_)
# This list of keywords is taken from ref/node13.html of the
# Python 1.3 HTML documentation. ("access" is intentionally omitted.)