audio/din: Update to 58.1

Changes since 57:

DIN Is Noise 58:
  /*
    position affects velocity and acceleration vectors
      instead of just velocity vectors
        Menu > Drone Tools > Position affects Vectors
  *\
  /* rotate acceleration *\
  /* rotation direction switch on velocity, accelerations *\
  /* reverse orbital direction *\
  * drone & voice volume displayed on microtonal keyboard is absolute not %
  * improved documentation, see https://dinisnoise.org/docs/
  :( fixed visual modulation behaviour on drones :)
  - removed Boost library requirement to build DIN Is Noise from source code.
This commit is contained in:
fox 2024-02-18 01:00:04 +00:00
parent b677d3cd5c
commit c96d59c9a5
4 changed files with 12 additions and 33 deletions

View File

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.49 2023/12/29 18:24:34 adam Exp $
# $NetBSD: Makefile,v 1.50 2024/02/18 01:00:04 fox Exp $
DISTNAME= din-57
PKGREVISION= 1
DISTNAME= din-58.1
CATEGORIES= audio
MASTER_SITES= https://archive.org/download/dinisnoise_source_code/

View File

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.33 2023/11/08 16:49:02 bacon Exp $
$NetBSD: distinfo,v 1.34 2024/02/18 01:00:04 fox Exp $
BLAKE2s (din-57.tar.gz) = 22e6611ca0c80ff57133997b4c9a77ce02c1bd31a878597192dcad8e895e124a
SHA512 (din-57.tar.gz) = 03dfa45fb8c58f3f8dc739ec3c4c31029c544d9f0b1cf3dbae61643e5accd951ad65ebf19c078bfb1d30d3a8ccea7ffec2f1cb44f38bab1b07cfd2071361590c
Size (din-57.tar.gz) = 3693381 bytes
SHA1 (patch-src_Makefile.am) = 5fd638028053e70b29874fd588b0d66d4417b40e
BLAKE2s (din-58.1.tar.gz) = 1776667a034fb175228b6e45c1381963f0e763fa8409572698cbef8574a38bf8
SHA512 (din-58.1.tar.gz) = ee2d63309347167af3b4e41a0ad3ce1faad727a4e079cd9e63d402b680144aed81dbee9d38bc517acbb30a1c9af18b726841d0c94d96cbfb2b1581da98af21c1
Size (din-58.1.tar.gz) = 3689591 bytes
SHA1 (patch-src_Makefile.am) = 81bc3100ab2de28185f6232735b7f088598cb58f
SHA1 (patch-src_Makefile.in) = 3135bd8315cfdd65e7d885fc80f4baa89b7d94dc
SHA1 (patch-src_RtMidi.cpp) = 5c919adff2d5adb2683cfa5890748396a1918a3d

View File

@ -1,17 +1,17 @@
$NetBSD: patch-src_Makefile.am,v 1.15 2023/11/08 16:49:02 bacon Exp $
$NetBSD: patch-src_Makefile.am,v 1.16 2024/02/18 01:00:05 fox Exp $
Removed tcl8.6, asound and jack flags, this is now handled in the pkgsrc
script.
--- src/Makefile.am.orig 2022-09-22 14:07:29.000000000 +0000
--- src/Makefile.am.orig 2024-01-12 06:34:36.000000000 +0000
+++ src/Makefile.am
@@ -1,7 +1,7 @@
#dinincludedir = $(pkgsrcdir)
-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
-AM_CXXFLAGS = -I /usr/include/tcl8.6 -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -DPREFIX=\"@prefix@\"
-LIBS += -ltcl8.6 -lSDL -lGL -lpthread -lasound
+AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -D__BOOST_TIME__ -DPREFIX=\"@prefix@\"
+LIBS += @LIBS@
+AM_CXXFLAGS = -Wall -D_THREAD_SAFE -DHAVE_OPENGL -D__LICENSED__ -D__SVG__ -D__GPL20__ -DPREFIX=\"@prefix@\"
+LIBS += @LIBS@
bin_PROGRAMS = din

View File

@ -1,19 +0,0 @@
$NetBSD: patch-src_RtMidi.cpp,v 1.2 2023/11/08 16:49:02 bacon Exp $
Use process scheduling from NetBSD instead of pthread.
--- src/RtMidi.cpp.orig 2023-09-12 07:28:28.679052163 +0000
+++ src/RtMidi.cpp
@@ -3608,8 +3608,11 @@ void MidiOutJack :: sendMessage( const u
return;
while ( jack_ringbuffer_write_space(data->buff) < sizeof(nBytes) + size )
+#if defined(__NetBSD__) || defined(__APPLE__)
+ sched_yield();
+#else
pthread_yield();
-
+#endif
// Write full message to buffer
jack_ringbuffer_write( data->buff, ( char * ) &nBytes, sizeof( nBytes ) );
jack_ringbuffer_write( data->buff, ( const char * ) message, nBytes );