Imported x11/clipit from wip.

ClipIt is a lightweight, fully featured GTK+ clipboard manager.

Tested on NetBSD 6.0 and MacOS X 10.7 (Lion, 64 bits)
This commit is contained in:
khorben 2012-12-07 01:41:58 +00:00
parent 138c22cfeb
commit c977d6371a
5 changed files with 81 additions and 0 deletions

3
x11/clipit/DESCR Normal file
View file

@ -0,0 +1,3 @@
ClipIt is a lightweight, fully featured GTK+ clipboard manager. It was forked
from Parcellite (http://parcellite.sourceforge.net), adding additional features
and bugfixes to the project.

33
x11/clipit/Makefile Normal file
View file

@ -0,0 +1,33 @@
# $NetBSD: Makefile,v 1.1 2012/12/07 01:41:58 khorben Exp $
#
DISTNAME= clipit-1.4.2
CATEGORIES= x11
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gtkclipit/}
PKGREVISION= 1
MAINTAINER= khorben@defora.org
HOMEPAGE= http://clipit.rspwn.com/
COMMENT= Lightweight, fully featured GTK+ clipboard manager
LICENSE= gnu-gpl-v3
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFDIR}
USE_TOOLS+= gmake
USE_TOOLS+= intltool
BUILD_DEFS+= PKG_SYSCONFBASE
EGDIR= ${PREFIX}/share/examples/clipit
CONF_FILES= ${EGDIR}/xdg/autostart/clipit-startup.desktop \
${PKG_SYSCONFBASE}/xdg/autostart/clipit-startup.desktop
MAKE_DIRS= ${PKG_SYSCONFBASE}/xdg/autostart
INSTALL_MAKE_FLAGS= ${MAKE_FLAGS} sysconfdir=${EGDIR}
.include "../../x11/gtk2/buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/bsd.pkg.mk"

24
x11/clipit/PLIST Normal file
View file

@ -0,0 +1,24 @@
@comment $NetBSD: PLIST,v 1.1 2012/12/07 01:41:58 khorben Exp $
bin/clipit
man/man1/clipit.1
share/applications/clipit.desktop
share/examples/clipit/xdg/autostart/clipit-startup.desktop
share/icons/hicolor/scalable/apps/clipit-trayicon.svg
share/locale/cs/LC_MESSAGES/clipit.mo
share/locale/da/LC_MESSAGES/clipit.mo
share/locale/de/LC_MESSAGES/clipit.mo
share/locale/es/LC_MESSAGES/clipit.mo
share/locale/es_ES/LC_MESSAGES/clipit.mo
share/locale/et/LC_MESSAGES/clipit.mo
share/locale/fr/LC_MESSAGES/clipit.mo
share/locale/hu/LC_MESSAGES/clipit.mo
share/locale/it/LC_MESSAGES/clipit.mo
share/locale/ja/LC_MESSAGES/clipit.mo
share/locale/nb/LC_MESSAGES/clipit.mo
share/locale/pl/LC_MESSAGES/clipit.mo
share/locale/pt_BR/LC_MESSAGES/clipit.mo
share/locale/ro/LC_MESSAGES/clipit.mo
share/locale/ru/LC_MESSAGES/clipit.mo
share/locale/sv/LC_MESSAGES/clipit.mo
share/locale/tr/LC_MESSAGES/clipit.mo
share/locale/zh_CN/LC_MESSAGES/clipit.mo

6
x11/clipit/distinfo Normal file
View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2012/12/07 01:41:58 khorben Exp $
SHA1 (clipit-1.4.2.tar.gz) = e01d02a60efdac575f8c0f84ceef210be1466d1a
RMD160 (clipit-1.4.2.tar.gz) = 3ef589b5eab4bb2cb65b220d82d3ba06881dba84
Size (clipit-1.4.2.tar.gz) = 284614 bytes
SHA1 (patch-src_Makefile.in) = 8aac206ff8a32044fd926d8808399fe70b863b92

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_Makefile.in,v 1.1 2012/12/07 01:41:58 khorben Exp $
Fixes build on MacOS X
--- src/Makefile.in.orig 2012-04-04 07:53:01.000000000 +0000
+++ src/Makefile.in
@@ -226,7 +226,7 @@ AM_CPPFLAGS = -I$(top_srcdir)
AM_CFLAGS = -Wall -g -DCLIPITLOCALEDIR=\""$(clipitlocaledir)"\"
INCLUDES = $(GTK_CFLAGS) $(APPINDICATOR_CFLAGS) -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include
LDADD = $(GTK_LIBS) $(APPINDICATOR_LIBS) $(X11_LIBS)
-AM_LDFLAGS = -Wl,--as-needed
+#AM_LDFLAGS = -Wl,--as-needed
DISTCLEANFILES = *.bak *.log *~ .deps/*.P
clipit_SOURCES = main.c main.h \
utils.c utils.h \