games/simgear: Update to simgear-2018.2.2.

This commit is contained in:
nia 2018-08-04 04:04:28 +00:00
parent c2b660246e
commit c9831d8295
7 changed files with 205 additions and 77 deletions

View file

@ -1,14 +1,12 @@
# $NetBSD: Makefile,v 1.70 2018/04/29 21:31:41 adam Exp $
# $NetBSD: Makefile,v 1.71 2018/08/04 04:04:28 nia Exp $
DISTNAME= simgear-2.8.0
PKGREVISION= 41
DISTNAME= simgear-2018.2.2
CATEGORIES= games devel
MASTER_SITES= ftp://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/
MASTER_SITES+= ftp://ftp.goflyflightgear.com/simgear/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=flightgear/release-2018.2/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://simgear.sourceforge.net/
HOMEPAGE= http://home.flightgear.org/
COMMENT= Simulator Construction Tools
LICENSE= gnu-lgpl-v2
@ -16,18 +14,13 @@ USE_LANGUAGES= c c++
USE_PKGLOCALEDIR= yes
USE_CMAKE= yes
CMAKE_ARGS+= -DENABLE_LIBSVN:BOOL=OFF
LDFLAGS.SunOS+= -lsocket -lnsl
BUILDLINK_API_DEPENDS.plib+= plib>=1.8.5
.include "../../audio/freealut/buildlink3.mk"
.include "../../audio/openal-soft/buildlink3.mk"
.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../games/plib/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.include "../../graphics/MesaLib/buildlink3.mk"
.include "../../graphics/osg/buildlink3.mk"
.include "../../www/curl/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,9 +1,65 @@
@comment $NetBSD: PLIST,v 1.5 2012/09/30 01:50:15 dholland Exp $
@comment $NetBSD: PLIST,v 1.6 2018/08/04 04:04:28 nia Exp $
include/simgear/bucket/newbucket.hxx
include/simgear/bvh/BVHBoundingBoxVisitor.hxx
include/simgear/bvh/BVHGroup.hxx
include/simgear/bvh/BVHLineGeometry.hxx
include/simgear/bvh/BVHLineSegmentVisitor.hxx
include/simgear/bvh/BVHMaterial.hxx
include/simgear/bvh/BVHMotionTransform.hxx
include/simgear/bvh/BVHNearestPointVisitor.hxx
include/simgear/bvh/BVHNode.hxx
include/simgear/bvh/BVHPageNode.hxx
include/simgear/bvh/BVHPageRequest.hxx
include/simgear/bvh/BVHPager.hxx
include/simgear/bvh/BVHStaticBinary.hxx
include/simgear/bvh/BVHStaticData.hxx
include/simgear/bvh/BVHStaticGeometry.hxx
include/simgear/bvh/BVHStaticGeometryBuilder.hxx
include/simgear/bvh/BVHStaticLeaf.hxx
include/simgear/bvh/BVHStaticNode.hxx
include/simgear/bvh/BVHStaticTriangle.hxx
include/simgear/bvh/BVHSubTreeCollector.hxx
include/simgear/bvh/BVHTransform.hxx
include/simgear/bvh/BVHVisitor.hxx
include/simgear/canvas/Canvas.hxx
include/simgear/canvas/CanvasEvent.hxx
include/simgear/canvas/CanvasEventManager.hxx
include/simgear/canvas/CanvasEventTypes.hxx
include/simgear/canvas/CanvasEventVisitor.hxx
include/simgear/canvas/CanvasMgr.hxx
include/simgear/canvas/CanvasObjectPlacement.hxx
include/simgear/canvas/CanvasPlacement.hxx
include/simgear/canvas/CanvasSystemAdapter.hxx
include/simgear/canvas/CanvasWindow.hxx
include/simgear/canvas/ODGauge.hxx
include/simgear/canvas/ShivaVG/openvg.h
include/simgear/canvas/ShivaVG/vgu.h
include/simgear/canvas/VGInitOperation.hxx
include/simgear/canvas/canvas_fwd.hxx
include/simgear/canvas/elements/CanvasElement.hxx
include/simgear/canvas/elements/CanvasGroup.hxx
include/simgear/canvas/elements/CanvasImage.hxx
include/simgear/canvas/elements/CanvasMap.hxx
include/simgear/canvas/elements/CanvasPath.hxx
include/simgear/canvas/elements/CanvasText.hxx
include/simgear/canvas/events/CustomEvent.hxx
include/simgear/canvas/events/DeviceEvent.hxx
include/simgear/canvas/events/KeyboardEvent.hxx
include/simgear/canvas/events/MouseEvent.hxx
include/simgear/canvas/layout/AlignFlag_values.hxx
include/simgear/canvas/layout/BoxLayout.hxx
include/simgear/canvas/layout/Layout.hxx
include/simgear/canvas/layout/LayoutItem.hxx
include/simgear/canvas/layout/NasalWidget.hxx
include/simgear/canvas/layout/SpacerItem.hxx
include/simgear/compiler.h
include/simgear/constants.h
include/simgear/debug/BufferedLogCallback.hxx
include/simgear/debug/debug_types.h
include/simgear/debug/logstream.hxx
include/simgear/embedded_resources/EmbeddedResource.hxx
include/simgear/embedded_resources/EmbeddedResourceManager.hxx
include/simgear/embedded_resources/EmbeddedResourceProxy.hxx
include/simgear/environment/metar.hxx
include/simgear/environment/precipitation.hxx
include/simgear/ephemeris/celestialBody.hxx
@ -19,9 +75,18 @@ include/simgear/ephemeris/star.hxx
include/simgear/ephemeris/stardata.hxx
include/simgear/ephemeris/uranus.hxx
include/simgear/ephemeris/venus.hxx
include/simgear/io/DNSClient.hxx
include/simgear/io/HTTPClient.hxx
include/simgear/io/HTTPFileRequest.hxx
include/simgear/io/HTTPMemoryRequest.hxx
include/simgear/io/HTTPRepository.hxx
include/simgear/io/HTTPRequest.hxx
include/simgear/io/iochannel.hxx
include/simgear/io/iostreams/CharArrayStream.hxx
include/simgear/io/iostreams/gzcontainerfile.hxx
include/simgear/io/iostreams/gzfstream.hxx
include/simgear/io/iostreams/sgstream.hxx
include/simgear/io/iostreams/zlibstream.hxx
include/simgear/io/lowlevel.hxx
include/simgear/io/raw_socket.hxx
include/simgear/io/sg_binobj.hxx
@ -32,6 +97,7 @@ include/simgear/io/sg_netChat.hxx
include/simgear/io/sg_serial.hxx
include/simgear/io/sg_socket.hxx
include/simgear/io/sg_socket_udp.hxx
include/simgear/io/untar.hxx
include/simgear/magvar/coremag.hxx
include/simgear/magvar/magvar.hxx
include/simgear/math/SGBox.hxx
@ -44,6 +110,7 @@ include/simgear/math/SGGeometryFwd.hxx
include/simgear/math/SGIntersect.hxx
include/simgear/math/SGLimits.hxx
include/simgear/math/SGLineSegment.hxx
include/simgear/math/SGLocation.hxx
include/simgear/math/SGMath.hxx
include/simgear/math/SGMathFwd.hxx
include/simgear/math/SGMatrix.hxx
@ -51,6 +118,7 @@ include/simgear/math/SGMisc.hxx
include/simgear/math/SGPlane.hxx
include/simgear/math/SGQuat.hxx
include/simgear/math/SGRay.hxx
include/simgear/math/SGRect.hxx
include/simgear/math/SGSphere.hxx
include/simgear/math/SGTriangle.hxx
include/simgear/math/SGVec2.hxx
@ -62,51 +130,66 @@ include/simgear/math/leastsqs.hxx
include/simgear/math/sg_geodesy.hxx
include/simgear/math/sg_random.h
include/simgear/math/sg_types.hxx
include/simgear/math/simd.hxx
include/simgear/math/simd4x4.hxx
include/simgear/misc/CSSBorder.hxx
include/simgear/misc/ListDiff.hxx
include/simgear/misc/ResourceManager.hxx
include/simgear/misc/SVGpreserveAspectRatio.hxx
include/simgear/misc/SimpleMarkdown.hxx
include/simgear/misc/argparse.hxx
include/simgear/misc/interpolator.hxx
include/simgear/misc/make_new.hxx
include/simgear/misc/sg_dir.hxx
include/simgear/misc/sg_hash.hxx
include/simgear/misc/sg_path.hxx
include/simgear/misc/sgstream.hxx
include/simgear/misc/stdint.hxx
include/simgear/misc/stopwatch.hxx
include/simgear/misc/strutils.hxx
include/simgear/misc/tabbed_values.hxx
include/simgear/misc/test_macros.hxx
include/simgear/misc/texcoord.hxx
include/simgear/misc/zfstream.hxx
include/simgear/nasal/cppbind/Ghost.hxx
include/simgear/nasal/cppbind/NasalCallContext.hxx
include/simgear/nasal/cppbind/NasalContext.hxx
include/simgear/nasal/cppbind/NasalHash.hxx
include/simgear/nasal/cppbind/NasalMe.hxx
include/simgear/nasal/cppbind/NasalMethodHolder.hxx
include/simgear/nasal/cppbind/NasalObject.hxx
include/simgear/nasal/cppbind/NasalObjectHolder.hxx
include/simgear/nasal/cppbind/NasalString.hxx
include/simgear/nasal/cppbind/cppbind_fwd.hxx
include/simgear/nasal/cppbind/detail/from_nasal_helper.hxx
include/simgear/nasal/cppbind/detail/nasal_traits.hxx
include/simgear/nasal/cppbind/detail/to_nasal_helper.hxx
include/simgear/nasal/cppbind/from_nasal.hxx
include/simgear/nasal/cppbind/to_nasal.hxx
include/simgear/nasal/iolib.h
include/simgear/nasal/naref.h
include/simgear/nasal/nasal.h
include/simgear/package/Catalog.hxx
include/simgear/package/Delegate.hxx
include/simgear/package/Install.hxx
include/simgear/package/Package.hxx
include/simgear/package/Root.hxx
include/simgear/props/AtomicChangeListener.hxx
include/simgear/props/ExtendedPropertyAdapter.hxx
include/simgear/props/PropertyBasedElement.hxx
include/simgear/props/PropertyBasedMgr.hxx
include/simgear/props/PropertyInterpolationMgr.hxx
include/simgear/props/PropertyInterpolator.hxx
include/simgear/props/condition.hxx
include/simgear/props/easing_functions.hxx
include/simgear/props/propertyObject.hxx
include/simgear/props/props.hxx
include/simgear/props/props_io.hxx
include/simgear/props/propsfwd.hxx
include/simgear/props/tiedpropertylist.hxx
include/simgear/props/vectorPropTemplates.hxx
include/simgear/scene/bvh/BVHBoundingBoxVisitor.hxx
include/simgear/scene/bvh/BVHDebugCollectVisitor.hxx
include/simgear/scene/bvh/BVHGroup.hxx
include/simgear/scene/bvh/BVHLineGeometry.hxx
include/simgear/scene/bvh/BVHLineSegmentVisitor.hxx
include/simgear/scene/bvh/BVHMotionTransform.hxx
include/simgear/scene/bvh/BVHNearestPointVisitor.hxx
include/simgear/scene/bvh/BVHNode.hxx
include/simgear/scene/bvh/BVHStaticBinary.hxx
include/simgear/scene/bvh/BVHStaticData.hxx
include/simgear/scene/bvh/BVHStaticGeometry.hxx
include/simgear/scene/bvh/BVHStaticGeometryBuilder.hxx
include/simgear/scene/bvh/BVHStaticLeaf.hxx
include/simgear/scene/bvh/BVHStaticNode.hxx
include/simgear/scene/bvh/BVHStaticTriangle.hxx
include/simgear/scene/bvh/BVHSubTreeCollector.hxx
include/simgear/scene/bvh/BVHTransform.hxx
include/simgear/scene/bvh/BVHVisitor.hxx
include/simgear/scene/material/Effect.hxx
include/simgear/scene/material/EffectBuilder.hxx
include/simgear/scene/material/EffectCullVisitor.hxx
include/simgear/scene/material/EffectGeode.hxx
include/simgear/scene/material/GLPredicate.hxx
include/simgear/scene/material/Pass.hxx
include/simgear/scene/material/Technique.hxx
include/simgear/scene/material/TextureBuilder.hxx
@ -114,18 +197,24 @@ include/simgear/scene/material/mat.hxx
include/simgear/scene/material/matlib.hxx
include/simgear/scene/material/matmodel.hxx
include/simgear/scene/material/mipmap.hxx
include/simgear/scene/material/parseBlendFunc.hxx
include/simgear/scene/model/BVHDebugCollectVisitor.hxx
include/simgear/scene/model/BVHPageNodeOSG.hxx
include/simgear/scene/model/BoundingVolumeBuildVisitor.hxx
include/simgear/scene/model/CheckSceneryVisitor.hxx
include/simgear/scene/model/ConditionNode.hxx
include/simgear/scene/model/ModelRegistry.hxx
include/simgear/scene/model/PrimitiveCollector.hxx
include/simgear/scene/model/SGClipGroup.hxx
include/simgear/scene/model/SGInteractionAnimation.hxx
include/simgear/scene/model/SGMaterialAnimation.hxx
include/simgear/scene/model/SGOffsetTransform.hxx
include/simgear/scene/model/SGPickAnimation.hxx
include/simgear/scene/model/SGReaderWriterXML.hxx
include/simgear/scene/model/SGRotateTransform.hxx
include/simgear/scene/model/SGScaleTransform.hxx
include/simgear/scene/model/SGText.hxx
include/simgear/scene/model/SGTrackToAnimation.hxx
include/simgear/scene/model/SGTranslateTransform.hxx
include/simgear/scene/model/animation.hxx
include/simgear/scene/model/model.hxx
@ -150,9 +239,12 @@ include/simgear/scene/tgdb/SGBuildingBin.hxx
include/simgear/scene/tgdb/SGDirectionalLightBin.hxx
include/simgear/scene/tgdb/SGLightBin.hxx
include/simgear/scene/tgdb/SGModelBin.hxx
include/simgear/scene/tgdb/SGNodeTriangles.hxx
include/simgear/scene/tgdb/SGOceanTile.hxx
include/simgear/scene/tgdb/SGReaderWriterBTG.hxx
include/simgear/scene/tgdb/SGTexturedTriangleBin.hxx
include/simgear/scene/tgdb/SGTileDetailsCallback.hxx
include/simgear/scene/tgdb/SGTileGeometryBin.hxx
include/simgear/scene/tgdb/SGTriangleBin.hxx
include/simgear/scene/tgdb/SGVasiDrawable.hxx
include/simgear/scene/tgdb/SGVertexArrayBin.hxx
@ -163,9 +255,13 @@ include/simgear/scene/tgdb/obj.hxx
include/simgear/scene/tgdb/pt_lights.hxx
include/simgear/scene/tgdb/userdata.hxx
include/simgear/scene/tsync/terrasync.hxx
include/simgear/scene/util/ColorInterpolator.hxx
include/simgear/scene/util/CopyOp.hxx
include/simgear/scene/util/DeletionManager.hxx
include/simgear/scene/util/NodeAndDrawableVisitor.hxx
include/simgear/scene/util/Noise.hxx
include/simgear/scene/util/OptionsReadFileCallback.hxx
include/simgear/scene/util/OsgDebug.hxx
include/simgear/scene/util/OsgMath.hxx
include/simgear/scene/util/OsgSingleton.hxx
include/simgear/scene/util/PrimitiveUtils.hxx
@ -180,11 +276,13 @@ include/simgear/scene/util/SGSceneFeatures.hxx
include/simgear/scene/util/SGSceneUserData.hxx
include/simgear/scene/util/SGStateAttributeVisitor.hxx
include/simgear/scene/util/SGTextureStateAttributeVisitor.hxx
include/simgear/scene/util/SGTransientModelData.hxx
include/simgear/scene/util/SGUpdateVisitor.hxx
include/simgear/scene/util/SplicingVisitor.hxx
include/simgear/scene/util/StateAttributeFactory.hxx
include/simgear/scene/util/UpdateOnceCallback.hxx
include/simgear/scene/util/VectorArrayAdapter.hxx
include/simgear/scene/util/parse_color.hxx
include/simgear/scene/util/project.hxx
include/simgear/screen/colors.hxx
include/simgear/screen/extensions.hxx
@ -193,11 +291,14 @@ include/simgear/screen/tr.h
include/simgear/serial/serial.hxx
include/simgear/sg_inlines.h
include/simgear/simgear_config.h
include/simgear/sound/filters.hxx
include/simgear/sound/readwav.hxx
include/simgear/sound/sample.hxx
include/simgear/sound/sample_group.hxx
include/simgear/sound/sample_openal.hxx
include/simgear/sound/sample_queue.hxx
include/simgear/sound/soundmgr_openal.hxx
include/simgear/sound/soundmgr.hxx
include/simgear/sound/xmlsound.hxx
include/simgear/std/integer_sequence.hxx
include/simgear/std/type_traits.hxx
include/simgear/structure/OSGUtils.hxx
include/simgear/structure/OSGVersion.hxx
include/simgear/structure/SGAtomic.hxx
@ -211,12 +312,15 @@ include/simgear/structure/SGSmplstat.hxx
include/simgear/structure/SGWeakPtr.hxx
include/simgear/structure/SGWeakReferenced.hxx
include/simgear/structure/Singleton.hxx
include/simgear/structure/StateMachine.hxx
include/simgear/structure/StringTable.hxx
include/simgear/structure/callback.hxx
include/simgear/structure/commands.hxx
include/simgear/structure/event_mgr.hxx
include/simgear/structure/exception.hxx
include/simgear/structure/function_list.hxx
include/simgear/structure/intern.hxx
include/simgear/structure/map.hxx
include/simgear/structure/singleton.hpp
include/simgear/structure/subsystem_mgr.hxx
include/simgear/threads/SGGuard.hxx
@ -228,27 +332,9 @@ include/simgear/timing/timestamp.hxx
include/simgear/timing/timezone.h
include/simgear/version.h
include/simgear/xml/easyxml.hxx
lib/libsgbucket.a
lib/libsgbvh.a
lib/libsgdebug.a
lib/libsgenvironment.a
lib/libsgephem.a
lib/libsgio.a
lib/libsgmagvar.a
lib/libsgmaterial.a
lib/libsgmath.a
lib/libsgmisc.a
lib/libsgmodel.a
lib/libsgnasal.a
lib/libsgprops.a
lib/libsgscreen.a
lib/libsgserial.a
lib/libsgsky.a
lib/libsgsound.a
lib/libsgstructure.a
lib/libsgtgdb.a
lib/libsgthreads.a
lib/libsgtiming.a
lib/libsgtsync.a
lib/libsgutil.a
lib/libsgxml.a
lib/cmake/SimGear/SimGearConfig.cmake
lib/cmake/SimGear/SimGearConfigVersion.cmake
lib/cmake/SimGear/SimGearTargets-debug.cmake
lib/cmake/SimGear/SimGearTargets.cmake
lib/libSimGearCored.a
lib/libSimGearScened.a

View file

@ -1,18 +1,18 @@
# $NetBSD: buildlink3.mk,v 1.12 2015/04/25 14:23:03 tnn Exp $
# $NetBSD: buildlink3.mk,v 1.13 2018/08/04 04:04:28 nia Exp $
BUILDLINK_TREE+= simgear
.if !defined(SIMGEAR_BUILDLINK3_MK)
SIMGEAR_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.simgear+= simgear>=2.0.0nb6
BUILDLINK_ABI_DEPENDS.simgear+= simgear>=2.8.0nb23
BUILDLINK_API_DEPENDS.simgear+= simgear>=2018.2.2
BUILDLINK_PKGSRCDIR.simgear?= ../../games/simgear
BUILDLINK_DEPMETHOD.simgear?= build
.include "../../audio/openal-soft/buildlink3.mk"
.include "../../devel/boost-headers/buildlink3.mk"
.include "../../devel/zlib/buildlink3.mk"
.include "../../games/plib/buildlink3.mk"
.include "../../mk/jpeg.buildlink3.mk"
.endif # SIMGEAR_BUILDLINK3_MK
.include "../../graphics/MesaLib/buildlink3.mk"
.include "../../graphics/osg/buildlink3.mk"
.endif # SIMGEAR_BUILDLINK3_MK
BUILDLINK_TREE+= -simgear

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.6 2015/11/03 20:57:04 agc Exp $
$NetBSD: distinfo,v 1.7 2018/08/04 04:04:28 nia Exp $
SHA1 (simgear-2.8.0.tar.bz2) = 63f030e4969a014326eb9835d33e3da6b26d2900
RMD160 (simgear-2.8.0.tar.bz2) = 1d3f832d88abc85e2e253ba99fc1946e1a5ff746
SHA512 (simgear-2.8.0.tar.bz2) = ead06fd394b10a7ae3c98422cc469b3c97450162f6994c40c7cb4818f88e0d25cf0b5dc9c39a10e2b9c0fd849dd322451df93e4febcbacf2fc23fe1860917064
Size (simgear-2.8.0.tar.bz2) = 766340 bytes
SHA1 (patch-simgear_scene_sky_cloud_cxx) = 670c1b2470c449545382040ccba75365d642f72a
SHA1 (patch-simgear_sound_sample__group_cxx) = ef4dd3534aa902ed1d3945f5879bfe3ef20d31ca
SHA1 (patch-simgear_timing_timestamp_cxx) = 20101dd1802c9d18a6680c9b4868efd5c937f973
SHA1 (simgear-2018.2.2.tar.bz2) = ba24275236aa461c4b0fee3e37e4fb6877734a1c
RMD160 (simgear-2018.2.2.tar.bz2) = ecb7005d1fcae8b76cb1d18df7924fe89a594152
SHA512 (simgear-2018.2.2.tar.bz2) = 2052c8e42bda751bc7c9429525b7acb733d5c0dd32dd4adea078718f89296c635abc956b464887fe67202dcc07a81fbade443a84fe8206648e473fd0f64d9365
Size (simgear-2018.2.2.tar.bz2) = 1313890 bytes
SHA1 (patch-simgear_canvas_ShivaVG_src_shConfig.h) = f38988911197efc56cb6eb170274a04961aa198d
SHA1 (patch-simgear_canvas_ShivaVG_src_shDefs.h) = 0da1544fecec002fb874fcb7df1155ad2889ba4d
SHA1 (patch-simgear_misc_strutils.cxx) = a72f601803ca285c778ccf12bfe25ff886a182cb

View file

@ -0,0 +1,18 @@
$NetBSD: patch-simgear_canvas_ShivaVG_src_shConfig.h,v 1.1 2018/08/04 04:04:28 nia Exp $
Support NetBSD.
--- simgear/canvas/ShivaVG/src/shConfig.h.orig 2018-06-03 18:56:36.000000000 +0000
+++ simgear/canvas/ShivaVG/src/shConfig.h
@@ -31,6 +31,11 @@
// FreeBSD
#define VG_API_FREEBSD
+#elif defined(__NetBSD__)
+
+ // NetBSD
+ #define VG_API_NETBSD
+
#else
// Unsupported system

View file

@ -0,0 +1,15 @@
$NetBSD: patch-simgear_canvas_ShivaVG_src_shDefs.h,v 1.1 2018/08/04 04:04:28 nia Exp $
Support NetBSD.
--- simgear/canvas/ShivaVG/src/shDefs.h.orig 2018-06-03 18:56:36.000000000 +0000
+++ simgear/canvas/ShivaVG/src/shDefs.h
@@ -161,7 +161,7 @@ SHfloat getMaxFloat();
/* OpenGL headers */
-#if defined(VG_API_LINUX) || defined(VG_API_FREEBSD)
+#if defined(VG_API_LINUX) || defined(VG_API_FREEBSD) || defined(VG_API_NETBSD)
#include <GL/gl.h>
#include <GL/glx.h>
#elif defined(VG_API_MACOSX)

View file

@ -0,0 +1,16 @@
$NetBSD: patch-simgear_misc_strutils.cxx,v 1.1 2018/08/04 04:04:28 nia Exp $
Support NetBSD.
--- simgear/misc/strutils.cxx.orig 2018-06-03 18:56:36.000000000 +0000
+++ simgear/misc/strutils.cxx
@@ -1017,7 +1017,8 @@ std::string error_string(int errnum)
retcode = strerror_s(buf, sizeof(buf), errnum);
#elif defined(_GNU_SOURCE)
return std::string(strerror_r(errnum, buf, sizeof(buf)));
-#elif (_POSIX_C_SOURCE >= 200112L) || defined(SG_MAC) || defined(__FreeBSD__)
+#elif (_POSIX_C_SOURCE >= 200112L) || defined(SG_MAC) || \
+ defined(__FreeBSD__) || defined(__NetBSD__)
int retcode;
// POSIX.1-2001 and POSIX.1-2008
retcode = strerror_r(errnum, buf, sizeof(buf));