salt-docs: added patches
This commit is contained in:
parent
837934119f
commit
c99ad997ad
2 changed files with 17 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.19 2018/10/25 09:08:37 adam Exp $
|
||||
# $NetBSD: Makefile,v 1.20 2018/10/25 09:09:35 adam Exp $
|
||||
|
||||
DISTNAME= salt-2018.3.3
|
||||
PKGNAME= ${DISTNAME:S/-/-docs-/}
|
||||
|
@ -28,7 +28,7 @@ INSTALLATION_DIRS= ${HTMLDIR}
|
|||
PYTHON_VERSIONS_ACCEPTED= 27
|
||||
|
||||
do-install:
|
||||
cd ${WRKSRC}/doc/_build/html && pax -rw -pe . ${DESTDIR}${PREFIX}/${HTMLDIR}
|
||||
cd ${WRKSRC}/doc/_build/html && pax -rw -pp . ${DESTDIR}${PREFIX}/${HTMLDIR}
|
||||
cd ${DESTDIR}${PREFIX} && ${FIND} ${HTMLDIR} -type f -print >>${PLIST_SRC}
|
||||
|
||||
.include "../../lang/python/pyversion.mk"
|
||||
|
|
15
sysutils/salt-docs/patches/patch-doc___ext_saltdomain.py
Normal file
15
sysutils/salt-docs/patches/patch-doc___ext_saltdomain.py
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-doc___ext_saltdomain.py,v 1.1 2018/10/25 09:09:35 adam Exp $
|
||||
|
||||
Do not import Directive twice.
|
||||
|
||||
--- doc/_ext/saltdomain.py.orig 2018-10-25 07:52:41.000000000 +0000
|
||||
+++ doc/_ext/saltdomain.py
|
||||
@@ -7,7 +7,7 @@ from docutils.parsers.rst import Directi
|
||||
|
||||
from docutils.statemachine import ViewList
|
||||
from sphinx import addnodes
|
||||
-from sphinx.directives import ObjectDescription, Directive
|
||||
+from sphinx.directives import ObjectDescription
|
||||
from sphinx.domains import Domain, ObjType
|
||||
from sphinx.domains.python import PyObject
|
||||
from sphinx.locale import l_, _
|
Loading…
Reference in a new issue