fix some format string bugs on 64 bit systems.

This commit is contained in:
dmcmahill 2002-12-30 02:09:25 +00:00
parent b87b25bde6
commit c9c2283065
3 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,6 @@
$NetBSD: distinfo,v 1.18 2002/12/23 22:46:55 tron Exp $
$NetBSD: distinfo,v 1.19 2002/12/30 02:09:25 dmcmahill Exp $
SHA1 (bidwatcher-1.3.7.tar.gz) = 92d30c14c7df96307fb99052f22661281c774dba
Size (bidwatcher-1.3.7.tar.gz) = 145540 bytes
SHA1 (patch-aa) = 57cc45107a53f54aae6b8fa22e2283fbeebd0516
SHA1 (patch-ab) = 85052062bd165ba0ae3de05c887e3236c5ae7da7

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.14 2002/12/30 02:09:26 dmcmahill Exp $
--- bidwatcher.cpp.orig Mon Dec 23 02:49:08 2002
+++ bidwatcher.cpp
@@ -4093,7 +4093,7 @@ void TimeSync()
if (strlen(HtmlBuff) < 1000) {
#ifdef DEBUG_NETWORK
- fprintf(stderr, "Short web page (%d bytes) from ebay's time web page, retrying... (%d)\n", strlen(HtmlBuff), i);
+ fprintf(stderr, "Short web page (%ld bytes) from ebay's time web page, retrying... (%d)\n", (long int)strlen(HtmlBuff), i);
#endif
continue;
}

View file

@ -0,0 +1,13 @@
$NetBSD: patch-ab,v 1.5 2002/12/30 02:09:27 dmcmahill Exp $
--- netstuff.cpp.orig Sat Oct 19 14:40:15 2002
+++ netstuff.cpp
@@ -353,7 +353,7 @@ int fetchURL(URL *url, int Post, char **
if (*Args != '\0')
Args++;
- sprintf(lineBuff, "POST %.*s HTTP/1.1\r\nConnection: close\r\nHost: %s\r\nContent-Length: %d\r\n%s\r\n%s", URLLen, url->url, url->hoststring, strlen(Args), UserAgent, Args);
+ sprintf(lineBuff, "POST %.*s HTTP/1.1\r\nConnection: close\r\nHost: %s\r\nContent-Length: %ld\r\n%s\r\n%s", URLLen, url->url, url->hoststring, (long int) strlen(Args), UserAgent, Args);
} else {
sprintf(lineBuff, "GET %s HTTP/1.1\r\nConnection: close\r\nHost: %s\r\n%s\r\n", url->url, url->hoststring, UserAgent);
}