Fix build problem under NetBSD/amd64 (Squid bug 2716).
This commit is contained in:
parent
f15349c1e7
commit
c9cf9010f5
2 changed files with 17 additions and 1 deletions
|
@ -1,8 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.9 2009/06/30 17:17:39 taca Exp $
|
||||
$NetBSD: distinfo,v 1.10 2009/07/19 23:27:51 tron Exp $
|
||||
|
||||
SHA1 (squid-3.0.STABLE16.tar.bz2) = d4438516e63a8ef232eac8526b7b4be27fdeca1f
|
||||
RMD160 (squid-3.0.STABLE16.tar.bz2) = 0f99505962a8ea2cedca57b134828b94ba8b7426
|
||||
Size (squid-3.0.STABLE16.tar.bz2) = 1796458 bytes
|
||||
SHA1 (patch-aa) = 6168bc18a339b02711163c3b84336b3f40eecad0
|
||||
SHA1 (patch-ad) = 5e126ffb1427f986484c3c32baf5ae3da409262d
|
||||
SHA1 (patch-ae) = bc38307f8039a7bc63f1e1572df30d20ee161b8a
|
||||
SHA1 (patch-ah) = ab3b9add2a8836a5d5307645eb547d732e6496d0
|
||||
|
|
15
www/squid30/patches/patch-aa
Normal file
15
www/squid30/patches/patch-aa
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-aa,v 1.5 2009/07/19 23:27:51 tron Exp $
|
||||
|
||||
http://www.squid-cache.org/bugs/show_bug.cgi?id=2716
|
||||
|
||||
--- src/client_side.cc.orig 2009-06-15 08:31:30.000000000 +0100
|
||||
+++ src/client_side.cc 2009-07-20 00:18:41.000000000 +0100
|
||||
@@ -2141,7 +2141,7 @@
|
||||
// when we read chunked requests, the entire body is buffered
|
||||
// XXX: this check ignores header size and its limits.
|
||||
if (conn->in.dechunkingState == ConnStateData::chunkParsing)
|
||||
- return conn->in.notYetUsed < Config.maxChunkedRequestBodySize;
|
||||
+ return (ssize_t)conn->in.notYetUsed < Config.maxChunkedRequestBodySize;
|
||||
|
||||
return conn->in.notYetUsed >= Config.maxRequestHeaderSize ? 0 : 1;
|
||||
}
|
Loading…
Reference in a new issue