Fix build with new libxml2 API.

This commit is contained in:
joerg 2012-11-19 03:01:44 +00:00
parent 776f791116
commit c9e4445cd2
2 changed files with 15 additions and 1 deletions

View file

@ -1,7 +1,8 @@
$NetBSD: distinfo,v 1.4 2006/02/10 12:09:24 adam Exp $
$NetBSD: distinfo,v 1.5 2012/11/19 03:01:44 joerg Exp $
SHA1 (gdome2-0.8.1.tar.gz) = e9a3e4140c873d8232635ad10bb135ef7803c408
RMD160 (gdome2-0.8.1.tar.gz) = 5cc3ff29e0ed040e3bbd02cba4d95b9b634c4072
Size (gdome2-0.8.1.tar.gz) = 518965 bytes
SHA1 (patch-aa) = 7e194447d1b4cf4a0799aef6c211e724e577c33c
SHA1 (patch-ab) = 642f5e5319bdebf3fab8b346d68558e117cb5d26
SHA1 (patch-libgdome_gdomecore_gdome-xml-documentt.c) = fb032a0f47d26d4f36cc9e3c720370fb227b14dc

View file

@ -0,0 +1,13 @@
$NetBSD: patch-libgdome_gdomecore_gdome-xml-documentt.c,v 1.1 2012/11/19 03:01:44 joerg Exp $
--- libgdome/gdomecore/gdome-xml-documentt.c.orig 2012-11-19 01:08:40.000000000 +0000
+++ libgdome/gdomecore/gdome-xml-documentt.c
@@ -342,7 +342,7 @@ gdome_xml_dt_internalSubset (GdomeDocume
}
xmlNodeDumpOutput (out_buff, NULL, (xmlNode *)is, 0, 0, NULL);
xmlOutputBufferFlush(out_buff);
- ret = g_strndup (out_buff->buffer->content, out_buff->buffer->use);
+ ret = g_strndup (xmlBufferContent(out_buff->buffer), xmlBufferLength(out_buff->buffer));
(void)xmlOutputBufferClose(out_buff);
return gdome_xml_str_mkref_own (ret);