Update to 2.01.01alpha64:
All: - The schily makefilesystem now by default sets all locale related envronment variables to "C" in order to avoid problems. - Make the makefile emulation mode for "non-automake aware" make programs like SunPro Make and GNU make more immune against oddities in the tr(1) program that are seen with a locale that differs from LC_ALL=C Another step to prevent some tr(1) oddities was to replace the call to tr(1) by a call to sed(1). - Added GMAKE_NOWARN=true to allow to disable the gmake warning - Enhanced include/schily/priv.h to distinct Solaris and AIX process privileges - New include file include/schily/math.h - Try to workaound a problem with GCC on newer AIX versions. It seems that e.g. gcc on AIX is not C99 compliant and does not support isnan(). Note that the current solution may compile and run on newer AIX versions but does not seem to be the optimal solution as it cannot check whether a float is a number or not. It is unfortunate, that we do not have an AIX login that would allow to implement better AIX support. Libscg: - The low level SCSI transport code for Mac OS X has been reworked. The code now supports cdrecord -scanbus The code now supports cdrecord's autotarget mode The code now supports to communicate with BluRay drives The code now prints a longer help text that instructs what to do in order to work against the "diskarbitrationd" program on Mac OS that tries to steal us our hardware. If someone is able and willing to help, please send mail! I like to be able to tell "diskarbitrationd" to give up specific drives and to set up shared access. Cdrecord: - The cdrecord man page now mentions that the -clone mode is a bad idea to copy audio CDs. Readcd: - The readcd man page now mentions that the -clone mode is a bad idea to copy audio CDs.
This commit is contained in:
parent
0d3ba87daa
commit
c9e66108fd
3 changed files with 38 additions and 8 deletions
|
@ -1,8 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.59 2009/09/05 10:05:19 joerg Exp $
|
||||
# $NetBSD: Makefile,v 1.60 2009/09/09 13:45:13 wiz Exp $
|
||||
|
||||
DISTNAME= cdrtools-2.01.01a63
|
||||
DISTNAME= cdrtools-2.01.01a64
|
||||
PKGNAME= ${DISTNAME:S/a/alpha/:S/-pre/pre/}
|
||||
PKGREVISION= 1
|
||||
CATEGORIES= sysutils
|
||||
MASTER_SITES= ftp://ftp.berlios.de/pub/cdrecord/alpha/ \
|
||||
http://ftp.berlios.de/pub/cdrecord/alpha/
|
||||
|
@ -63,7 +62,7 @@ SUBST_CLASSES+= fix
|
|||
SUBST_STAGE.fix= post-patch
|
||||
SUBST_FILES.fix= btcflash/btcflash.1
|
||||
SUBST_FILES.fix+= cdrecord/cdrecord.1
|
||||
SUBST_FILES.fix+= cdrecord/defaults.c
|
||||
SUBST_FILES.fix+= libcdrdeflt/cdrdeflt.c
|
||||
SUBST_FILES.fix+= mkisofs/diag/isoinfo.8
|
||||
SUBST_FILES.fix+= readcd/readcd.1
|
||||
SUBST_FILES.fix+= scgcheck/scgcheck.1
|
||||
|
|
|
@ -1,10 +1,11 @@
|
|||
$NetBSD: distinfo,v 1.37 2009/08/15 21:03:25 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.38 2009/09/09 13:45:13 wiz Exp $
|
||||
|
||||
SHA1 (cdrtools-2.01.01a63.tar.bz2) = 06506aa6a4f0bd730adb4e2dc7353ebbd2fe5839
|
||||
RMD160 (cdrtools-2.01.01a63.tar.bz2) = d368a5eac15684edbd53b5f5053cd397bb4193ea
|
||||
Size (cdrtools-2.01.01a63.tar.bz2) = 1828967 bytes
|
||||
SHA1 (cdrtools-2.01.01a64.tar.bz2) = 2e4af9079527bd5683dc778d1400ef68b595fd36
|
||||
RMD160 (cdrtools-2.01.01a64.tar.bz2) = d609abe707c41d1a66bec7bb1ff4ae7967e5b355
|
||||
Size (cdrtools-2.01.01a64.tar.bz2) = 1836328 bytes
|
||||
SHA1 (patch-aa) = 1f3461ae34071c20672025575bbb0abe7b128ef8
|
||||
SHA1 (patch-ab) = bc6e2ccd371dcd2ae9c8d7caee89b937c9e36893
|
||||
SHA1 (patch-ac) = eedad8bd2a3705c33dd6640ba0556f5dd3927739
|
||||
SHA1 (patch-ad) = 08230fc203325916d4604576401da048dc108637
|
||||
SHA1 (patch-ai) = a65625831d88a97547c4e0a03075711bee0dc373
|
||||
SHA1 (patch-ch) = 65397614fe196709b26a789bdd34ed6776b4ef46
|
||||
|
|
30
sysutils/cdrtools/patches/patch-ac
Normal file
30
sysutils/cdrtools/patches/patch-ac
Normal file
|
@ -0,0 +1,30 @@
|
|||
$NetBSD: patch-ac,v 1.6 2009/09/09 13:45:13 wiz Exp $
|
||||
|
||||
--- RULES/mk-gmake.id.orig 2009-08-29 12:17:45.000000000 +0000
|
||||
+++ RULES/mk-gmake.id
|
||||
@@ -55,9 +55,9 @@ endif
|
||||
_MACHCMD= (mach || uname -p || true) 2> /dev/null
|
||||
_ARCHCMD= (arch || /usr/ucb/arch || true) 2> /dev/null
|
||||
|
||||
-XP_ARCH:= $(shell $(_MACHCMD) | sed 'y%ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"%abcdefghijklmnopqrstuvwxyz,------%')
|
||||
-XK_ARCH:= $(shell uname -m | sed 'y%ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"%abcdefghijklmnopqrstuvwxyz,------%')
|
||||
-XM_ARCH:= $(shell $(_ARCHCMD) | sed 'y%ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"%abcdefghijklmnopqrstuvwxyz,------%')
|
||||
+XP_ARCH:= $(shell $(_MACHCMD) | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"' 'abcdefghijklmnopqrstuvwxyz,//////' | tr ',/' ',\-')
|
||||
+XK_ARCH:= $(shell uname -m | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"' 'abcdefghijklmnopqrstuvwxyz,//////' | tr ',/' ',\-')
|
||||
+XM_ARCH:= $(shell $(_ARCHCMD) | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"' 'abcdefghijklmnopqrstuvwxyz,//////' | tr ',/' ',\-')
|
||||
|
||||
P_ARCH= $(XP_ARCH)
|
||||
K_ARCH= $(XK_ARCH)
|
||||
@@ -73,9 +73,9 @@ _M_ARCH= $(_UNIQ)$(XM_ARCH)
|
||||
__M_ARCH= $(_M_ARCH:$(_UNIQ)=$(K_ARCH))
|
||||
M_ARCH= $(__M_ARCH:$(_UNIQ)%=%)
|
||||
|
||||
-OSNAME:= $(shell uname -s | sed 'y%ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"%abcdefghijklmnopqrstuvwxyz,------%')
|
||||
-OSREL:= $(shell uname -r | sed 'y%ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"%abcdefghijklmnopqrstuvwxyz,------%')
|
||||
-OSVERSION:= $(shell uname -v | sed 'y%ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"%abcdefghijklmnopqrstuvwxyz,------%')
|
||||
+OSNAME:= $(shell uname -s | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"' 'abcdefghijklmnopqrstuvwxyz,//////' | tr ',/' ',\-')
|
||||
+OSREL:= $(shell uname -r | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"' 'abcdefghijklmnopqrstuvwxyz,//////' | tr ',/' ',\-')
|
||||
+OSVERSION:= $(shell uname -v | tr 'ABCDEFGHIJKLMNOPQRSTUVWXYZ, /\\()"' 'abcdefghijklmnopqrstuvwxyz,//////' | tr ',/' ',\-')
|
||||
|
||||
ARCH_DONE= TRUE
|
||||
|
Loading…
Reference in a new issue