Make ocalm build with tk-8.4.
This commit is contained in:
parent
09b8335d5c
commit
c9eae9cc89
3 changed files with 37 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
||||||
$NetBSD: distinfo,v 1.13 2003/07/11 08:24:41 jtb Exp $
|
$NetBSD: distinfo,v 1.14 2004/03/04 06:27:45 minskim Exp $
|
||||||
|
|
||||||
SHA1 (ocaml-3.06.tar.gz) = cf1b053bf751ad566e445ca13c620ffef3a1b863
|
SHA1 (ocaml-3.06.tar.gz) = cf1b053bf751ad566e445ca13c620ffef3a1b863
|
||||||
Size (ocaml-3.06.tar.gz) = 2436887 bytes
|
Size (ocaml-3.06.tar.gz) = 2436887 bytes
|
||||||
|
@ -14,3 +14,5 @@ SHA1 (patch-ai) = 5b3a27cbe5c7dcebc6899859b24ebe2bd0248862
|
||||||
SHA1 (patch-aj) = 5a9365b0ee1153cfddb7780422f5ba451a85ae9a
|
SHA1 (patch-aj) = 5a9365b0ee1153cfddb7780422f5ba451a85ae9a
|
||||||
SHA1 (patch-ak) = cd5a93e7530f6864ee6f591f9f7ba5722428408c
|
SHA1 (patch-ak) = cd5a93e7530f6864ee6f591f9f7ba5722428408c
|
||||||
SHA1 (patch-al) = 9c3d37b4d849fb8de033bf927c8d3f7a3aaee4de
|
SHA1 (patch-al) = 9c3d37b4d849fb8de033bf927c8d3f7a3aaee4de
|
||||||
|
SHA1 (patch-am) = 00df5c9e56f25f61b9349846bc339cb2922ab278
|
||||||
|
SHA1 (patch-ao) = 5f7b05cb1bfb811ecf85b22eefe8c707b8e27068
|
||||||
|
|
17
lang/ocaml/patches/patch-am
Normal file
17
lang/ocaml/patches/patch-am
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
$NetBSD: patch-am,v 1.1 2004/03/04 06:27:45 minskim Exp $
|
||||||
|
|
||||||
|
--- otherlibs/labltk/support/cltkImg.c.orig 2002-07-23 09:11:59.000000000 -0500
|
||||||
|
+++ otherlibs/labltk/support/cltkImg.c
|
||||||
|
@@ -99,7 +99,11 @@ camltk_setimgdata_native (value imgname,
|
||||||
|
pib.offset[0] = 0;
|
||||||
|
pib.offset[1] = 1;
|
||||||
|
pib.offset[2] = 2;
|
||||||
|
- Tk_PhotoPutBlock(ph,&pib,Int_val(x),Int_val(y),Int_val(w),Int_val(h));
|
||||||
|
+ Tk_PhotoPutBlock(ph,&pib,Int_val(x),Int_val(y),Int_val(w),Int_val(h)
|
||||||
|
+#if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 4 || TK_MAJOR_VERSION > 8)
|
||||||
|
+ , TK_PHOTO_COMPOSITE_SET
|
||||||
|
+#endif
|
||||||
|
+ );
|
||||||
|
}
|
||||||
|
|
||||||
|
CAMLprim void camltk_setimgdata_bytecode(argv,argn)
|
17
lang/ocaml/patches/patch-ao
Normal file
17
lang/ocaml/patches/patch-ao
Normal file
|
@ -0,0 +1,17 @@
|
||||||
|
$NetBSD: patch-ao,v 1.1 2004/03/04 06:27:45 minskim Exp $
|
||||||
|
|
||||||
|
--- otherlibs/labltk/tkanim/tkAnimGIF.c.orig 2002-07-23 09:12:00.000000000 -0500
|
||||||
|
+++ otherlibs/labltk/tkanim/tkAnimGIF.c
|
||||||
|
@@ -336,7 +336,11 @@ FileReadGIF(interp, f, fileName, formatS
|
||||||
|
}
|
||||||
|
}
|
||||||
|
Tk_PhotoPutBlock(photoHandle, &block, 0, 0,
|
||||||
|
- imageWidth, imageHeight);
|
||||||
|
+ imageWidth, imageHeight
|
||||||
|
+#if (TK_MAJOR_VERSION == 8 && TK_MINOR_VERSION >= 4 || TK_MAJOR_VERSION > 8)
|
||||||
|
+ , TK_PHOTO_COMPOSITE_SET
|
||||||
|
+#endif
|
||||||
|
+ );
|
||||||
|
#ifdef TKANIM_DEBUG
|
||||||
|
fprintf(stderr, " Retrieving result\n");
|
||||||
|
#endif
|
Loading…
Reference in a new issue