Changes 1.4.4:

* fixes so that it works again on FreeBSD again
* added IPv6 support
This commit is contained in:
adam 2011-07-09 07:45:08 +00:00
parent c1923acec8
commit ca00f2be25
5 changed files with 39 additions and 41 deletions

View file

@ -1,9 +1,7 @@
# $NetBSD: Makefile,v 1.13 2010/01/17 12:02:32 wiz Exp $
#
# $NetBSD: Makefile,v 1.14 2011/07/09 07:45:08 adam Exp $
DISTNAME= httping-1.3.0
PKGREVISION= 1
CATEGORIES= net
DISTNAME= httping-1.4.4
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/
EXTRACT_SUFX= .tgz
@ -14,6 +12,8 @@ LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir
USE_TOOLS+= gmake
.include "../../mk/bsd.prefs.mk"
LDFLAGS.SunOS= -lnsl -lsocket
@ -24,7 +24,7 @@ LDFLAGS.SunOS= -lnsl -lsocket
CFLAGS+= -DHAVE_STRNDUP
.endif
INSTALLATION_DIRS= ${PKGMANDIR}/man1 bin
INSTALLATION_DIRS= ${PKGMANDIR}/man1 bin
do-install:
${INSTALL_MAN} ${WRKSRC}/httping.1 ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.7 2009/07/19 11:54:51 zafer Exp $
$NetBSD: distinfo,v 1.8 2011/07/09 07:45:08 adam Exp $
SHA1 (httping-1.3.0.tgz) = be259962d2be9eac70cd62f86e0345e21f85076b
RMD160 (httping-1.3.0.tgz) = 11caace757279349db8448fa1789122776e47dee
Size (httping-1.3.0.tgz) = 13433 bytes
SHA1 (patch-aa) = 398c2b9a4152f2b4aaad85fc5829ae3b8f85d7fa
SHA1 (patch-ab) = 28f13ce32299c6dab791ae411e58567500834c04
SHA1 (patch-ac) = 8840c6d810d6b6ed299d5ea09fc9ca5874ab0e26
SHA1 (httping-1.4.4.tgz) = f74604d3ad5a1f1a68a483ccb40bd5bb0b280262
RMD160 (httping-1.4.4.tgz) = 8ac17577a43f01f2ca97728452eef74eaeb0428a
Size (httping-1.4.4.tgz) = 14372 bytes
SHA1 (patch-aa) = fc8f8fa30f7928689dad2b6b44255c3babcdf342
SHA1 (patch-ab) = e1bd44e049073224fdc96a98333a09f1fac52ff0
SHA1 (patch-ac) = 3f3c9a31a985c3b000bdce7acc5380da8a7af0dc
SHA1 (patch-ad) = a25b3cbb8b6833a059d3ce0cf2b5c738e2cef1c9

View file

@ -1,24 +1,12 @@
$NetBSD: patch-aa,v 1.1 2007/09/18 20:30:00 adrianp Exp $
$NetBSD: patch-aa,v 1.2 2011/07/09 07:45:09 adam Exp $
--- Makefile.orig 2007-07-26 09:00:31.000000000 +0100
--- Makefile.orig 2010-07-24 10:32:07.000000000 +0000
+++ Makefile
@@ -14,16 +14,15 @@
@@ -17,7 +17,6 @@ include version
TARGET=httping
include version
-DEBUG=-g # -D_DEBUG
-LDFLAGS+=-lssl -lcrypto $(DEBUG)
-CFLAGS+=-O2 -Wall -DVERSION=\"$(VERSION)\" $(DEBUG)
+LDFLAGS+=-lssl -lcrypto
+CFLAGS+=-DVERSION=\"$(VERSION)\"
OBJS=mem.o http.o io.o str.o error.o utils.o main.o tcp.o mssl.o res.o
all: httping
httping: $(OBJS)
- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o httping
+ $(CC) -W $(OBJS) $(LDFLAGS) -o httping
#
# Oh, blatant plug: http://keetweej.vanheusden.com/wishlist.html
WFLAGS=-Wall -W
-OFLAGS=-O2
CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
PACKAGE=$(TARGET)-$(VERSION)

View file

@ -1,13 +1,21 @@
$NetBSD: patch-ab,v 1.1 2007/09/18 20:30:01 adrianp Exp $
$NetBSD: patch-ab,v 1.2 2011/07/09 07:45:09 adam Exp $
--- str.c.orig 2007-07-26 09:00:31.000000000 +0100
--- str.c.orig 2010-07-24 10:32:07.000000000 +0000
+++ str.c
@@ -18,7 +18,7 @@
@@ -18,10 +18,8 @@
#include "mem.h"
#include "utils.h"
-#ifndef strndup
-/*
-Most unixes have this function already.
-#ifndef _GNU_SOURCE
+#ifndef HAVE_STRNDUP
char *strndup(char *in, int size)
{
char *out = mymalloc(size + 1, "strndup");
@@ -32,4 +30,3 @@ char *strndup(char *in, int size)
return out;
}
#endif
-*/

View file

@ -1,12 +1,14 @@
$NetBSD: patch-ac,v 1.1 2007/09/18 20:30:01 adrianp Exp $
$NetBSD: patch-ac,v 1.2 2011/07/09 07:45:09 adam Exp $
--- str.h.orig 2007-07-26 09:00:31.000000000 +0100
--- str.h.orig 2010-07-24 10:32:07.000000000 +0000
+++ str.h
@@ -15,6 +15,6 @@
@@ -15,8 +15,6 @@
#include <string.h>
-#ifndef strndup
-/*
-#ifndef _GNU_SOURCE
+#ifndef HAVE_STRNDUP
char *strndup(char *in, int size);
#endif
-*/