Update to 1.16:

New in ver 1.16
 ===============

New features

  two different types of black preservation on CMYK-> CMYK transforms
  Ability to set adaptation state of observer on absolute colorimetric transforms.
  A rather advanced feature. Actually it only allows No adaptation (d=0) and observer fully adapted (d=1)
  lcms can now "fix" some broken 8-bit profiles that have gray axes misplaced.
  icctrans can now read CGATS/IT8 files.
  improved tifficc with tiff Lab8 support
  icclink now supports colorant table tag.


 New functions

double        cmsSetAdaptationState(cmsHTRANSFORM hTransform, double d);

void           cmsSetHeaderAttributes(cmsHPROFILE hProfile, DWORD Flags);
DWORD          cmsTakeHeaderAttributes(cmsHPROFILE hProfile);

icInt32Number  cmsGetTagCount(cmsHPROFILE hProfile);
icTagSignature cmsGetTagSignature(cmsHPROFILE hProfile, icInt32Number n);

int            cmsSetCMYKPreservationStrategy(int n)

BOOL           cmsIT8SaveToMem(LCMSHANDLE hIT8, void *MemPtr, size_t* BytesNeeded);

BOOL          _cmsIsMatrixShaper(cmsHPROFILE hProfile);
BOOL          _cmsAddDateTimeTag(cmsHPROFILE hProfile, icTagSignature sig, struct tm *DateTime);
BOOL          _cmsAddColorantTableTag(cmsHPROFILE hProfile, icTagSignature sig, LPcmsNAMEDCOLORLIST nc);

double       cmsEvalLUTreverse(LPLUT Lut, WORD Target[], WORD Result[], LPWORD Hint);

LPcmsNAMEDCOLORLIST  cmsReadColorantTable(cmsHPROFILE hProfile, icTagSignature sig)

LPcmsGAMUTEX cmsReadExtendedGamut(cmsHPROFILE hProfile, int index);
void         cmsFreeExtendedGamut(LPcmsGAMUTEX gex);


New tags supported

       icSigColorantTableTag		    LPcmsNAMEDCOLORLIST
       icSigColorantTableOutTag         LPcmsNAMEDCOLORLIST
       icSigCalibrationDateTimeTag	    const struct tm*


New flags:

cmsFLAGS_PRESERVEBLACK
cmsFLAGS_GRIDPOINTS(n)


And of course some bug fixing.
This commit is contained in:
wiz 2007-01-06 21:52:14 +00:00
parent a770f7df2c
commit ca0fb05796
3 changed files with 6 additions and 21 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.22 2006/11/05 17:23:44 joerg Exp $
# $NetBSD: Makefile,v 1.23 2007/01/06 21:52:14 wiz Exp $
DISTNAME= lcms-1.15
PKGREVISION= 2
DISTNAME= lcms-1.16
CATEGORIES= graphics
MASTER_SITES= http://www.littlecms.com/ \
http://www.abaforum.es/martim/

View file

@ -1,6 +1,5 @@
$NetBSD: distinfo,v 1.15 2005/12/07 17:47:06 wiz Exp $
$NetBSD: distinfo,v 1.16 2007/01/06 21:52:14 wiz Exp $
SHA1 (lcms-1.15.tar.gz) = 45cabf4d251c031b13fc56239a06f00992320a2e
RMD160 (lcms-1.15.tar.gz) = 2cdb38039931cd35f550eabaa3421df6b9bfd0e4
Size (lcms-1.15.tar.gz) = 777834 bytes
SHA1 (patch-ab) = dd31ef24b98ead954945bda66d800dd5882c81e0
SHA1 (lcms-1.16.tar.gz) = faa1f50967e83304955e517e6908cf7d192b49e9
RMD160 (lcms-1.16.tar.gz) = b77805855be5e3fc083b1064c1104d7e070cc1ce
Size (lcms-1.16.tar.gz) = 911546 bytes

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ab,v 1.10 2005/12/07 17:47:06 wiz Exp $
--- include/lcms.h.orig 2005-11-26 15:23:47.000000000 +0100
+++ include/lcms.h
@@ -134,7 +134,7 @@
#if defined(__OpenBSD__) || defined(__NetBSD__) || defined(__FreeBSD__)
# include <sys/types.h>
# define USE_INT64 1
-# define LCMSSLONGLONG int_64_t
+# define LCMSSLONGLONG int64_t
# define LCMSULONGLONG u_int64_t
#endif