Update to 2.4.1, based on work done by xtraeme@ and Min Sik Kim.

gnome-vfs-2.4.1
	* Bugs fixed
		+ Allow to create symlinks to huge files on
                  nearly full file systems (James M. Cape)
		+ Fix compilation on HP/UX
	* Translations
		+ he (Gil "Dolfin" Osher), it (Luca Ferretti),
	          lv (Peteris Krisjanis), mr (Jitendra Shah),
                  nl (Vincent van Adrighem), pt_BR (Augusta Marques da Silva),
 	          ro (Mi?u Moldovan), ta (Dinesh)

gnome-vfs 2.4.0
	* Featurelets:
		Updated translations

gnome-vfs 2.3.90
	* Bugs fixed:
	       + Just emit one mime db changed signal per change

gnome-vfs 2.3.8
	* Bugs fixed:
	        + CDE menu fixes
		+ IPV6 build fixes for non-linux
		+ removed usage of ngettext (for now)
		+ fix fam crash
	* Featurelets:
		+ add dav schema for webdav usage
		+ Make gnome_vfs_make_uri_from_input be smarter about
		  when to make http: uris

gnome-vfs 2.3.7
	* Bugs fixed:
	        + Test fixes
		+ translation fixes
	* Featurelets:
		+ ignore_hosts gconf key for proxies

gnome-vfs 2.3.6
	* Bugs fixed:
		+ Fixes in CDE menu handling
		+ Shrink default gnome-vfs stack size
		+ Small API doc updates
		+ Properly read .mime and .keys file not ending with \n
		+ Compilation fixes when using gcc 3.3
		+ Compilation fixes for Solaris
		+ Leak fixes in URI and mime-type handling
		+ When an unknown app is added to a mime-type short list,
		  also add it to this mime-type global list
	* Featurelets:
		+ Added an Accessibility submenu in the Applications menu
		+ Improve parsing of URIs (wrongly) containing UTF-8 chars
		+ Translation updates

gnome-vfs 2.3.5:
	* Features:
		+ added a startup notification application registry key
	* Bugs fixed:
		+ Fix memory handling in mime handlers.
		+ Make job_private static in gnome-vfs-job.c
		+ Fixed CDE menu crash

gnome-vfs 2.3.4:
	* Bugs fixed:
	       + Get Names of vfolder directories right

gnome-vfs 2.3.3:
	* Bugs fixed:
	       + Fix potential crashes for uris with %2F in them
	       + solaris libnsl/libsocket build fixes
	       + Fix fam threadsafe issue
	       + Handle fam connection going away better
	       + Fixed doc building

gnome-vfs 2.3.2
        * Features:
	       + ipv6 uris supported
	       + add some command line applications for gnome-vfs

	* Bugs fixed:
	       + mp3 mimetype is audio/mpeg, not audio/x-mp3
	       + build issues fixed
	       + fix ncpfs filesystem

gnome-vfs 2.3.1
        * Features:
	       + New API gnome_vfs_url_show() and related calls
	       + New function gnome_vfs_make_uri_from_input_with_dirs
	       + Cygwin port
	       + IPV6 support

	* Bugs fixed:
	       + Some mime fixes
	       + Correctly handle symlinks to symlinks
	       + hpux fixes
	       + CDE menu translation fixes
	       + Webdav PROPFIND details
	       + Fixed locale aliases handling
	       + call bindtextlocale to get translation working
	       + Fixes to mtab handling
This commit is contained in:
jmmv 2003-12-14 19:47:26 +00:00
parent 38613678dd
commit ca27f417a8
9 changed files with 93 additions and 212 deletions

View file

@ -1,11 +1,10 @@
# $NetBSD: Makefile,v 1.18 2003/12/04 19:48:25 xtraeme Exp $
# $NetBSD: Makefile,v 1.19 2003/12/14 19:47:26 jmmv Exp $
#
DISTNAME= gnome-vfs-2.2.4
DISTNAME= gnome-vfs-2.4.1
PKGNAME= ${DISTNAME:S/vfs/vfs2/}
PKGREVISION= 6
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-vfs/2.2/}
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/gnome-vfs/2.4/}
EXTRACT_SUFX= .tar.bz2
MAINTAINER= jmmv@NetBSD.org
@ -30,6 +29,8 @@ CONFIGURE_ARGS+= --enable-platform-gnome-2
CONFIGURE_ARGS+= --sysconfdir=${PKG_SYSCONFBASE}
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc/html
CPPFLAGS+= -I${BUILDLINK_PREFIX.cdparanoia}/include/cdparanoia
PKG_SYSCONFSUBDIR= gnome-vfs-2.0
OWN_DIRS= ${PKG_SYSCONFDIR}/modules ${PKG_SYSCONFDIR}/vfolders
@ -56,9 +57,8 @@ GCONF2_SCHEMAS= system_http_proxy.schemas
.include "../../devel/GConf2/schemas.mk"
.include "../../devel/glib2/buildlink2.mk"
.include "../../devel/libbonobo/buildlink2.mk"
.include "../../devel/bonobo-activation/buildlink2.mk"
.include "../../devel/pkgconfig/buildlink2.mk"
.include "../../devel/popt/buildlink2.mk"
.include "../../devel/zlib/buildlink2.mk"
.include "../../net/ORBit2/buildlink2.mk"
.include "../../textproc/libxml2/buildlink2.mk"
.include "../../security/openssl/buildlink2.mk"

View file

@ -1,4 +1,9 @@
@comment $NetBSD: PLIST,v 1.5 2003/04/27 02:03:01 rh Exp $
@comment $NetBSD: PLIST,v 1.6 2003/12/14 19:47:26 jmmv Exp $
bin/gnomevfs-cat
bin/gnomevfs-copy
bin/gnomevfs-info
bin/gnomevfs-ls
bin/gnomevfs-mkdir
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-application-registry.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-async-ops.h
include/gnome-vfs-2.0/libgnomevfs/gnome-vfs-cancellation.h
@ -44,6 +49,9 @@ lib/gnome-vfs-2.0/include/gnome-vfs-file-size.h
lib/gnome-vfs-2.0/modules/libbzip2.a
lib/gnome-vfs-2.0/modules/libbzip2.la
lib/gnome-vfs-2.0/modules/libbzip2.so
lib/gnome-vfs-2.0/modules/libcdda.a
lib/gnome-vfs-2.0/modules/libcdda.la
lib/gnome-vfs-2.0/modules/libcdda.so
lib/gnome-vfs-2.0/modules/libextfs.a
lib/gnome-vfs-2.0/modules/libextfs.la
lib/gnome-vfs-2.0/modules/libextfs.so
@ -83,8 +91,8 @@ lib/gnome-vfs-2.0/modules/libvfs-translate.so
lib/libgnomevfs-2.a
lib/libgnomevfs-2.la
lib/libgnomevfs-2.so
lib/libgnomevfs-2.so.0
lib/libgnomevfs-2.so.0.0
lib/libgnomevfs-2.so.400
lib/libgnomevfs-2.so.400.1
lib/pkgconfig/gnome-vfs-2.0.pc
lib/pkgconfig/gnome-vfs-module-2.0.pc
lib/vfs/2.0/extfs/README
@ -106,96 +114,52 @@ lib/vfs/2.0/extfs/zip
lib/vfs/2.0/extfs/zoo
share/doc/html/gnome-vfs-2.0/about.html
share/doc/html/gnome-vfs-2.0/advanced-operations.html
share/doc/html/gnome-vfs-2.0/c9456.html
share/doc/html/gnome-vfs-2.0/c9466.html
share/doc/html/gnome-vfs-2.0/ch08.html
share/doc/html/gnome-vfs-2.0/data-types.html
share/doc/html/gnome-vfs-2.0/directory-operations.html
share/doc/html/gnome-vfs-2.0/everything-else.html
share/doc/html/gnome-vfs-2.0/file-operations.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-application-registry.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-asynchronous-operations.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-cancellation.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-configuration.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-context.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-application-registry.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-async-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-cancellation.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-context.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-basic-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-find-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-directory-list-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-advanced-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-basic-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-info-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-info.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-rw-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-size.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-file-trunc-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-inet-connection.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-init.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-method.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime-database.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime-monitor.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-mime.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-callback-module-api.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-callback.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module-shared.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-module.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-monitor.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-parse-ls.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-result.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-socket-buffer.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-socket.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-ssl.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-standard-callbacks.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-transform.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-uri.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-utils.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-20-gnome-vfs-xfer.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-directory-operations.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-directory.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-file-info.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-file-operations.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-file-size.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-finding-special-directories.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-first-steps.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-application-registry.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-async-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-cancellation.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-context.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-directory-basic-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-directory-find-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-directory-list-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-directory.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-file-advanced-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-file-basic-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-file-info-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-file-info.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-file-rw-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-file-size.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-file-trunc-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-find-directory.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-inet-connection.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-init.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-method.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-mime-database.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-mime-monitor.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-mime.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-module-callback-module-api.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-module-callback.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-module-shared.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-module.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-monitor.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-parse-ls.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-result.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-socket-buffer.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-socket.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-ssl.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-standard-callbacks.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-transform.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-uri.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-utils.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnome-vfs-xfer.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnomevfsmetadata.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-gnomevfsmimemonitor.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-inet-connection.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-initialization.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-iobuf.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-method.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-mime-handlers.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-mime-info.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-mime-magic.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-mime-monitor.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-mime-sniff-buffer.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-mime.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-module-callback-module-api.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-module-callbacks.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-module-shared.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-module.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-ops.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-parse-ls.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-process.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-result.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-ssl.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-standard-callbacks.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-types.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-uri.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-utils.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-writing-modules.html
share/doc/html/gnome-vfs-2.0/gnome-vfs-xfer.html
share/doc/html/gnome-vfs-2.0/index.html
share/doc/html/gnome-vfs-2.0/index.sgml
share/doc/html/gnome-vfs-2.0/mime-registry.html
share/doc/html/gnome-vfs-2.0/modules.html
share/doc/html/gnome-vfs-2.0/writing-modules.html
share/doc/html/gnome-vfs-2.0/x27.html
share/examples/gnome-vfs-2.0/modules/cdda-module.conf
share/examples/gnome-vfs-2.0/modules/default-modules.conf
share/examples/gnome-vfs-2.0/vfolders/applications-all-users.vfolder-info
share/examples/gnome-vfs-2.0/vfolders/favorites.vfolder-info
@ -204,6 +168,7 @@ share/examples/gnome-vfs-2.0/vfolders/preferences-all-users.vfolder-info
share/examples/gnome-vfs-2.0/vfolders/server-settings.vfolder-info
share/examples/gnome-vfs-2.0/vfolders/start-here.vfolder-info
share/examples/gnome-vfs-2.0/vfolders/system-settings.vfolder-info
share/gconf/schemas/desktop_default_applications.schemas
share/gconf/schemas/system_http_proxy.schemas
${PKGLOCALEDIR}/locale/am/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ar/LC_MESSAGES/gnome-vfs-2.0.mo
@ -214,6 +179,7 @@ ${PKGLOCALEDIR}/locale/bn/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/bs/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ca/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/cs/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/cy/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/da/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/de/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/el/LC_MESSAGES/gnome-vfs-2.0.mo
@ -230,15 +196,19 @@ ${PKGLOCALEDIR}/locale/he/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/hi/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/hu/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/id/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/is/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/it/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ja/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ko/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/li/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/lt/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/lv/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/mk/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ml/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/mn/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/mr/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ms/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ne/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/nl/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/nn/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/no/LC_MESSAGES/gnome-vfs-2.0.mo
@ -250,7 +220,10 @@ ${PKGLOCALEDIR}/locale/ru/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/sk/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/sl/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/sq/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/sr/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/sr@Latn/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/sv/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/ta/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/tr/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/uk/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/vi/LC_MESSAGES/gnome-vfs-2.0.mo
@ -259,7 +232,6 @@ ${PKGLOCALEDIR}/locale/yi/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/zh_CN/LC_MESSAGES/gnome-vfs-2.0.mo
${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/gnome-vfs-2.0.mo
@comment in GConf2: @dirrm share/gconf/schemas
@comment in GConf2: @dirrm share/gconf
@dirrm share/examples/gnome-vfs-2.0/vfolders
@dirrm share/examples/gnome-vfs-2.0/modules
@dirrm share/examples/gnome-vfs-2.0
@ -270,8 +242,8 @@ ${PKGLOCALEDIR}/locale/zh_TW/LC_MESSAGES/gnome-vfs-2.0.mo
@dirrm lib/gnome-vfs-2.0/modules
@dirrm lib/gnome-vfs-2.0/include
@dirrm lib/gnome-vfs-2.0
@comment in bonobo-activation: @dirrm lib/bonobo/servers
@comment in bonobo-activation: @dirrm lib/bonobo/monikers
@comment in libbonobo: @dirrm lib/bonobo/servers
@comment in libbonobo: @dirrm lib/bonobo/monikers
@dirrm include/gnome-vfs-module-2.0/libgnomevfs
@dirrm include/gnome-vfs-module-2.0
@dirrm include/gnome-vfs-2.0/libgnomevfs

View file

@ -1,18 +1,22 @@
# $NetBSD: buildlink2.mk,v 1.11 2003/11/12 01:31:51 salo Exp $
# $NetBSD: buildlink2.mk,v 1.12 2003/12/14 19:47:26 jmmv Exp $
#
# This Makefile fragment is included by packages that use gnome-vfs2.
#
# This file was created automatically using createbuildlink 2.8.
#
.if !defined(GNOME_VFS2_BUILDLINK2_MK)
GNOME_VFS2_BUILDLINK2_MK= # defined
BUILDLINK_PACKAGES+= gnome-vfs2
BUILDLINK_DEPENDS.gnome-vfs2?= gnome-vfs2>=2.2.4nb4
BUILDLINK_PACKAGES+= gnome-vfs2
BUILDLINK_DEPENDS.gnome-vfs2?= gnome-vfs2>=2.4.1
BUILDLINK_PKGSRCDIR.gnome-vfs2?= ../../sysutils/gnome-vfs2
EVAL_PREFIX+= BUILDLINK_PREFIX.gnome-vfs2=gnome-vfs2
BUILDLINK_PREFIX.gnome-vfs2_DEFAULT= ${LOCALBASE}
BUILDLINK_FILES.gnome-vfs2= include/gnome-vfs-2.0/libgnomevfs/*
BUILDLINK_FILES.gnome-vfs2+= include/gnome-vfs-2.0/libgnomevfs/*
BUILDLINK_FILES.gnome-vfs2+= include/gnome-vfs-module-2.0/libgnomevfs/*
BUILDLINK_FILES.gnome-vfs2+= lib/gnome-vfs-2.0/include/gnome-vfs-file-size.h
BUILDLINK_FILES.gnome-vfs2+= lib/gnome-vfs-2.0/modules/*
BUILDLINK_FILES.gnome-vfs2+= lib/gnome-vfs-2.0/include/*
BUILDLINK_FILES.gnome-vfs2+= lib/libgnomevfs-2.*
.include "../../archivers/bzip2/buildlink2.mk"
@ -22,9 +26,7 @@ BUILDLINK_FILES.gnome-vfs2+= lib/libgnomevfs-2.*
.include "../../devel/GConf2/buildlink2.mk"
.include "../../devel/glib2/buildlink2.mk"
.include "../../devel/libbonobo/buildlink2.mk"
.include "../../devel/bonobo-activation/buildlink2.mk"
.include "../../devel/popt/buildlink2.mk"
.include "../../devel/zlib/buildlink2.mk"
.include "../../net/ORBit2/buildlink2.mk"
.include "../../textproc/libxml2/buildlink2.mk"
.include "../../security/openssl/buildlink2.mk"

View file

@ -1,9 +1,6 @@
$NetBSD: distinfo,v 1.9 2003/09/27 21:10:08 danw Exp $
$NetBSD: distinfo,v 1.10 2003/12/14 19:47:26 jmmv Exp $
SHA1 (gnome-vfs-2.2.4.tar.bz2) = 40518be379250cb8b6c611c2d585ea35403b3f53
Size (gnome-vfs-2.2.4.tar.bz2) = 999711 bytes
SHA1 (patch-aa) = 33a61974bc6c5b8c933ccdfeffd30e17292064d2
SHA1 (patch-ae) = fbe0fa8e2def2fec2cc55317a35638d8314287d2
SHA1 (patch-ag) = 48a1a7e7b780bcf25f311abe0c48524c8fe9eaa4
SHA1 (patch-ai) = b1d2f5dd9c7b2e337b2f7e1608b521d695b71d72
SHA1 (patch-al) = f6e0f6b68e078e7a115871bb8cb4ea72bef7eab4
SHA1 (gnome-vfs-2.4.1.tar.bz2) = ab045dea3fc4a85a204d69ea24e50c54cb06746d
Size (gnome-vfs-2.4.1.tar.bz2) = 1060029 bytes
SHA1 (patch-ag) = 8dda137fe56462ee2336678a872a43611b11984f
SHA1 (patch-ai) = d89edb0dc089818191c12360ae542c0edc9fe414

View file

@ -1,33 +0,0 @@
$NetBSD: patch-aa,v 1.4 2003/09/27 21:10:08 danw Exp $
--- libgnomevfs/gnome-vfs-mime-magic.c.orig Wed Feb 19 04:31:23 2003
+++ libgnomevfs/gnome-vfs-mime-magic.c Sat Aug 30 23:14:05 2003
@@ -29,8 +29,10 @@
#include <sys/types.h>
#include <sys/stat.h>
#include <stdlib.h>
+#ifndef __APPLE__
#include <wctype.h>
#include <wchar.h>
+#endif
#include <glib/garray.h>
#include <glib/gmessages.h>
@@ -759,6 +761,7 @@
if (g_utf8_get_char_validated(end, remaining_bytes) == -2)
return TRUE;
+#ifndef __APPLE__
else {
size_t wlen;
wchar_t wc;
@@ -802,6 +805,9 @@
}
return TRUE;
}
+#else
+ return FALSE;
+#endif
}
}

View file

@ -1,12 +0,0 @@
$NetBSD: patch-ae,v 1.1 2002/09/11 23:07:51 rh Exp $
--- Makefile.in.orig Sat Sep 7 17:52:45 2002
+++ Makefile.in Sat Sep 7 17:53:24 2002
@@ -183,7 +183,6 @@
schemas \
devel-docs \
doc \
- test \
monikers \
po

View file

@ -1,13 +1,13 @@
$NetBSD: patch-ag,v 1.3 2003/02/15 16:29:32 jmmv Exp $
$NetBSD: patch-ag,v 1.4 2003/12/14 19:47:26 jmmv Exp $
--- modules/Makefile.in.orig Mon Jan 20 20:46:17 2003
+++ modules/Makefile.in
@@ -232,7 +232,7 @@ modules_LTLIBRARIES = \
--- modules/Makefile.in.orig 2003-10-26 01:28:22.000000000 +0000
+++ modules/Makefile.in 2003-10-26 01:28:46.000000000 +0000
@@ -208,7 +208,7 @@
# Not currently supported
# libnfs.la
-modulesconfdir = $(sysconfdir)/gnome-vfs-2.0/modules
+modulesconfdir = $(datadir)/examples/gnome-vfs-2.0/modules
@HAVE_CDDA_TRUE@CDDA_CONF = @HAVE_CDDA_TRUE@cdda-module.conf
@HAVE_SSL_TRUE@SSL_CONF = @HAVE_SSL_TRUE@ssl-modules.conf
@BUILD_CDEMENU_MODULE_TRUE@CDE_CONF = @BUILD_CDEMENU_MODULE_TRUE@cdemenu-module.conf
@HAVE_CDDA_TRUE@CDDA_CONF = cdda-module.conf
@HAVE_SSL_TRUE@SSL_CONF = ssl-modules.conf
@BUILD_CDEMENU_MODULE_TRUE@CDE_CONF = cdemenu-module.conf

View file

@ -1,22 +1,13 @@
$NetBSD: patch-ai,v 1.4 2003/09/27 21:10:08 danw Exp $
$NetBSD: patch-ai,v 1.5 2003/12/14 19:47:26 jmmv Exp $
--- modules/vfolder/Makefile.in.orig Mon Mar 31 06:23:06 2003
+++ modules/vfolder/Makefile.in Sun Aug 31 11:35:23 2003
@@ -210,7 +210,7 @@
### Module setup
-module_flags = -export_dynamic -avoid-version
+module_flags = -export_dynamic -avoid-version -module
modulesdir = $(libdir)/gnome-vfs-2.0/modules
modules_LTLIBRARIES = libvfolder-desktop.la
@@ -230,7 +230,7 @@
--- modules/vfolder/Makefile.in.orig 2003-10-26 01:29:34.000000000 +0000
+++ modules/vfolder/Makefile.in 2003-10-26 01:30:11.000000000 +0000
@@ -211,7 +211,7 @@
### Default .vfolder-info files
-vfolderdir = $(sysconfdir)/gnome-vfs-2.0/vfolders
+vfolderdir = $(datadir)/examples/gnome-vfs-2.0/vfolders
vfolder_DATA = \
applications-all-users.vfolder-info \
network.vfolder-info \
vfolder_DATA = applications-all-users.vfolder-info network.vfolder-info preferences-all-users.vfolder-info favorites.vfolder-info start-here.vfolder-info server-settings.vfolder-info system-settings.vfolder-info

View file

@ -1,36 +0,0 @@
$NetBSD: patch-al,v 1.4 2003/04/27 14:44:34 jmmv Exp $
--- modules/file-method.c.orig 2003-02-24 13:18:31.000000000 +0100
+++ modules/file-method.c
@@ -806,6 +806,7 @@ do_read_directory (GnomeVFSMethod *metho
result = readdir (handle->dir);
if (result == NULL && errno != 0) {
+ G_UNLOCK (readdir);
return gnome_vfs_result_from_errno ();
}
if (result != NULL) {
@@ -1113,9 +1114,23 @@ find_trash_in_one_hierarchy_level (const
item_buffer = g_malloc (sizeof (struct dirent) + GET_PATH_MAX() + 1);
for (;;) {
+#ifdef HAVE_READDIR_R
if (readdir_r (directory, item_buffer, &item) != 0 || item == NULL) {
break;
}
+#else
+ G_LOCK (readdir);
+ errno = 0;
+ item = readdir (directory);
+ if (item == NULL || errno != 0) {
+ G_UNLOCK (readdir);
+ break;
+ }
+ if (item != NULL) {
+ memcpy (item_buffer, item, sizeof (struct dirent));
+ }
+ G_UNLOCK (readdir);
+#endif
if (gnome_vfs_context_check_cancellation (context))
break;