Update to 2.61
Update DEPENDS Upstream changes: 2.61 2016-01-31 - Specify minimum Math::Trig version to avoid some cpantesters fails on pre5.8.9 perls on Cygwin.
This commit is contained in:
parent
25f265e1a9
commit
ca66e9da1b
3 changed files with 29 additions and 9 deletions
|
@ -1,17 +1,19 @@
|
|||
# $NetBSD: Makefile,v 1.10 2016/06/08 19:23:52 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2016/07/25 09:18:55 wen Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Geo-ShapeFile-2.60
|
||||
DISTNAME= Geo-ShapeFile-2.61
|
||||
PKGNAME= p5-${DISTNAME}
|
||||
PKGREVISION= 2
|
||||
CATEGORIES= geography perl5
|
||||
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Geo/}
|
||||
|
||||
MAINTAINER= wen@NetBSD.org
|
||||
HOMEPAGE= http://search.cpan.org/~jasonk/Geo-ShapeFile-2.52/lib/Geo/ShapeFile.pm
|
||||
HOMEPAGE= http://search.cpan.org/dist/Geo-ShapeFile/
|
||||
COMMENT= Perl extension for handling ESRI GIS Shapefiles
|
||||
LICENSE= ${PERL5_LICENSE}
|
||||
|
||||
DEPENDS+= p5-Tree-R>=0:../../devel/p5-Tree-R
|
||||
DEPENDS+= p5-autovivification>=0:../../devel/p5-autovivification
|
||||
|
||||
PERL5_PACKLIST= auto/Geo/ShapeFile/.packlist
|
||||
|
||||
.include "../../lang/perl5/module.mk"
|
||||
|
|
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.3 2015/11/03 00:08:44 agc Exp $
|
||||
$NetBSD: distinfo,v 1.4 2016/07/25 09:18:55 wen Exp $
|
||||
|
||||
SHA1 (Geo-ShapeFile-2.60.tar.gz) = 7b46492fc6318079d819ef7c36aceb6a65927135
|
||||
RMD160 (Geo-ShapeFile-2.60.tar.gz) = 1280ad08cfd91d3b52265156bae7e20a498afcee
|
||||
SHA512 (Geo-ShapeFile-2.60.tar.gz) = d9fbe383ab8b300a5bdb2f66806e6adfe41f9785c0185b68b252178381833779bbdff050332ee933caf878f44a14596dbad694bc702e51ce7345b278a8c6fa3d
|
||||
Size (Geo-ShapeFile-2.60.tar.gz) = 331941 bytes
|
||||
SHA1 (Geo-ShapeFile-2.61.tar.gz) = cb1c705cc498ab256b2672e424a4f83d8d3aae57
|
||||
RMD160 (Geo-ShapeFile-2.61.tar.gz) = adf5b8246c77c8dad33e2db3f952bd5e54c31e01
|
||||
SHA512 (Geo-ShapeFile-2.61.tar.gz) = f2923eac8b566a8e95b3706c88074191ee9d5a97f2706940fba6ba663277134888381b25fa8d42d5ee9f48c6ce1aab9d0411b7d652cef6033803b659d3e3b5b9
|
||||
Size (Geo-ShapeFile-2.61.tar.gz) = 332726 bytes
|
||||
SHA1 (patch-t_main__tests.t) = a750d7cad89c1f4100ed83219e956b1b81787e9f
|
||||
|
|
17
geography/p5-Geo-ShapeFile/patches/patch-t_main__tests.t
Normal file
17
geography/p5-Geo-ShapeFile/patches/patch-t_main__tests.t
Normal file
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-t_main__tests.t,v 1.1 2016/07/25 09:18:55 wen Exp $
|
||||
Add patch to be able to run tests without the need to install rlib,
|
||||
which is not in ports and which can easily be replaced by the FindBin
|
||||
The patch come from FreeBSD ports.
|
||||
--- t/main_tests.t.orig 2016-07-25 08:39:51.000000000 +0000
|
||||
+++ t/main_tests.t
|
||||
@@ -3,7 +3,9 @@
|
||||
use Test::More;
|
||||
use strict;
|
||||
use warnings;
|
||||
-use rlib '../lib', './lib';
|
||||
+use FindBin;
|
||||
+use lib "$FindBin::Bin/lib";
|
||||
+use lib "$FindBin::Bin/../lib";
|
||||
|
||||
use Geo::ShapeFile;
|
||||
use Geo::ShapeFile::Shape;
|
Loading…
Reference in a new issue