*** empty log message ***

This commit is contained in:
ryoon 2011-10-14 09:30:02 +00:00
parent b4a03ee15f
commit ca67a857a0
4 changed files with 30 additions and 5 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.18 2011/10/13 10:42:01 ryoon Exp $
# $NetBSD: Makefile,v 1.19 2011/10/14 09:30:02 ryoon Exp $
#
DISTNAME= Sigil-0.4.2-Code
@ -21,6 +21,13 @@ WRKSRC= ${WRKDIR}
USE_LANGUAGES= c c++
USE_CMAKE= yes
SUBST_CLASSES+= d2u
SUBST_STAGE.d2u= post-extract
SUBST_MESSAGE.d2u= Removing CR end-of-line markers.
SUBST_FILES.d2u= *txt
SUBST_FILES.d2u+= src/ZipArchive/*cpp
SUBST_FILTER_CMD.d2u= ${TR} -d '\r'
BUILDLINK_TRANSFORM+= l:BoostParts:boost_date_time:boost_filesystem:boost_regex:boost_system:boost_thread:boost_program_options
BUILDLINK_TRANSFORM+= l:Xerces:xerces-c
BUILDLINK_TRANSFORM+= l:zlib:z

View file

@ -1,6 +1,9 @@
$NetBSD: distinfo,v 1.11 2011/10/13 19:42:20 ryoon Exp $
$NetBSD: distinfo,v 1.12 2011/10/14 09:30:02 ryoon Exp $
SHA1 (Sigil-0.4.2-Code.zip) = 67464f521c1b11641812b6959549a842546b4f8d
RMD160 (Sigil-0.4.2-Code.zip) = c0834a04cdc67f8d066e4a66c43973a6013866e0
Size (Sigil-0.4.2-Code.zip) = 10104606 bytes
SHA1 (patch-CMakeLists.txt) = 2c4a6296f112b88998e8538b0fbc992e8178560d
SHA1 (patch-CMakeLists.txt) = c57d48941f51a017ef66994cbb78f0cff3c658b3
SHA1 (patch-src_ZipArchive_DirEnumerator.cpp) = b17df2f298ee1fa440442b49f31446060edb09be
SHA1 (patch-src_ZipArchive_ZipFile__stl.cpp) = 0e2067bee84e61ae49976d8d19932dd6d582c2ee
SHA1 (patch-src_ZipArchive_ZipPlatform__lnx.cpp) = ef15938e97859df8fd05f5d6aa89236a12f702c3

View file

@ -1,8 +1,8 @@
$NetBSD: patch-CMakeLists.txt,v 1.1 2011/10/13 10:42:01 ryoon Exp $
$NetBSD: patch-CMakeLists.txt,v 1.2 2011/10/14 09:30:02 ryoon Exp $
* Use external libraries.
--- CMakeLists.txt.orig 2011-08-14 05:09:54.000000000 +0000
--- CMakeLists.txt.orig 2011-10-14 14:56:42 +0000
+++ CMakeLists.txt
@@ -55,10 +55,10 @@ set( NO_TEST_EXE 1 )

View file

@ -0,0 +1,15 @@
$NetBSD: patch-src_ZipArchive_DirEnumerator.cpp,v 1.1 2011/10/14 09:30:02 ryoon Exp $
Add DragonFly support.
--- src/ZipArchive/DirEnumerator.cpp.orig 2011-10-14 14:56:42 +0000
+++ src/ZipArchive/DirEnumerator.cpp
@@ -73,7 +73,7 @@ bool CDirEnumerator::Start(CFileFilter&
if (!entry)
break;
CZipString path(m_szCurrentDirectory + entry->d_name);
- #if !defined __APPLE__ && !defined __CYGWIN__ && !defined __NetBSD__
+ #if !defined __APPLE__ && !defined __CYGWIN__ && !defined __NetBSD__ && !defined __DragonFly__
struct stat64 sStats;
if (stat64(path, &sStats) == -1)
#else