www/py-FxA: import py-FxA-0.7.7

This is python library for interacting with the Firefox Accounts
ecosystem.

Eventually, it is planned to provide easy support for the following
features:

- being a direct firefox accounts authentication client
- being an FxA OAuth Service Provider
- accessing attached services
- helps interactions with Firefox Account servers wiht requests
  Authentication plugins.
This commit is contained in:
wiz 2023-06-11 08:19:27 +00:00
parent 7b7e85176a
commit ca79701927
5 changed files with 167 additions and 0 deletions

11
www/py-FxA/DESCR Normal file
View File

@ -0,0 +1,11 @@
This is python library for interacting with the Firefox Accounts
ecosystem.
Eventually, it is planned to provide easy support for the following
features:
- being a direct firefox accounts authentication client
- being an FxA OAuth Service Provider
- accessing attached services
- helps interactions with Firefox Account servers wiht requests
Authentication plugins.

43
www/py-FxA/Makefile Normal file
View File

@ -0,0 +1,43 @@
# $NetBSD: Makefile,v 1.1 2023/06/11 08:19:27 wiz Exp $
DISTNAME= PyFxA-0.7.7
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:S/Py//}
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_PYPI:=P/PyFxA/}
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/mozilla/PyFxA
COMMENT= Firefox Accounts client library for Python
LICENSE= mpl-2.0
DEPENDS+= ${PYPKGPREFIX}-requests>=2.4.2:../../devel/py-requests
DEPENDS+= ${PYPKGPREFIX}-cryptography>=0:../../security/py-cryptography
DEPENDS+= ${PYPKGPREFIX}-BrowserID>=0:../../www/py-BrowserID
DEPENDS+= ${PYPKGPREFIX}-JWT>=0:../../textproc/py-JWT
DEPENDS+= ${PYPKGPREFIX}-hawkauthlib>=0:../../security/py-hawkauthlib
DEPENDS+= ${PYPKGPREFIX}-six>=1.14:../../lang/py-six
TEST_DEPENDS+= ${PYPKGPREFIX}-grequests>=0:../../net/py-grequests
TEST_DEPENDS+= ${PYPKGPREFIX}-responses>=0:../../net/py-responses
TEST_DEPENDS+= ${PYPKGPREFIX}-test>=4.6.4:../../devel/py-test
TEST_DEPENDS+= ${PYPKGPREFIX}-test-runner>=4.5.1:../../devel/py-test-runner
TEST_DEPENDS+= ${PYPKGPREFIX}-test-cov>=0:../../devel/py-test-cov
TEST_DEPENDS+= ${PYPKGPREFIX}-test-flake8>=0:../../devel/py-test-flake8
TEST_DEPENDS+= ${PYPKGPREFIX}-otp>=0:../../security/py-otp
USE_LANGUAGES= # none
USE_TOOLS+= ftp:test
PYTHON_VERSIONS_INCOMPATIBLE= 27
# test status as of 0.7.7
# 18 failed, 97 passed, 1 skipped, 1 warning
# https://github.com/mozilla/PyFxA/issues/95
# missing files in distfile
pre-test:
cd ${WRKSRC}/fxa/tests && ftp https://raw.githubusercontent.com/mozilla/PyFxA/main/fxa/tests/bad-key.json
cd ${WRKSRC}/fxa/tests && ftp https://raw.githubusercontent.com/mozilla/PyFxA/main/fxa/tests/jwks.json
cd ${WRKSRC}/fxa/tests && ftp https://raw.githubusercontent.com/mozilla/PyFxA/main/fxa/tests/private-key.json
.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"

90
www/py-FxA/PLIST Normal file
View File

@ -0,0 +1,90 @@
@comment $NetBSD: PLIST,v 1.1 2023/06/11 08:19:27 wiz Exp $
bin/fxa-client
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/entry_points.txt
${PYSITELIB}/${EGG_INFODIR}/not-zip-safe
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/fxa/__init__.py
${PYSITELIB}/fxa/__init__.pyc
${PYSITELIB}/fxa/__init__.pyo
${PYSITELIB}/fxa/__main__.py
${PYSITELIB}/fxa/__main__.pyc
${PYSITELIB}/fxa/__main__.pyo
${PYSITELIB}/fxa/_utils.py
${PYSITELIB}/fxa/_utils.pyc
${PYSITELIB}/fxa/_utils.pyo
${PYSITELIB}/fxa/cache.py
${PYSITELIB}/fxa/cache.pyc
${PYSITELIB}/fxa/cache.pyo
${PYSITELIB}/fxa/constants.py
${PYSITELIB}/fxa/constants.pyc
${PYSITELIB}/fxa/constants.pyo
${PYSITELIB}/fxa/core.py
${PYSITELIB}/fxa/core.pyc
${PYSITELIB}/fxa/core.pyo
${PYSITELIB}/fxa/crypto.py
${PYSITELIB}/fxa/crypto.pyc
${PYSITELIB}/fxa/crypto.pyo
${PYSITELIB}/fxa/errors.py
${PYSITELIB}/fxa/errors.pyc
${PYSITELIB}/fxa/errors.pyo
${PYSITELIB}/fxa/oauth.py
${PYSITELIB}/fxa/oauth.pyc
${PYSITELIB}/fxa/oauth.pyo
${PYSITELIB}/fxa/plugins/__init__.py
${PYSITELIB}/fxa/plugins/__init__.pyc
${PYSITELIB}/fxa/plugins/__init__.pyo
${PYSITELIB}/fxa/plugins/requests.py
${PYSITELIB}/fxa/plugins/requests.pyc
${PYSITELIB}/fxa/plugins/requests.pyo
${PYSITELIB}/fxa/profile.py
${PYSITELIB}/fxa/profile.pyc
${PYSITELIB}/fxa/profile.pyo
${PYSITELIB}/fxa/tests/__init__.py
${PYSITELIB}/fxa/tests/__init__.pyc
${PYSITELIB}/fxa/tests/__init__.pyo
${PYSITELIB}/fxa/tests/mock_utilities.py
${PYSITELIB}/fxa/tests/mock_utilities.pyc
${PYSITELIB}/fxa/tests/mock_utilities.pyo
${PYSITELIB}/fxa/tests/test_cache.py
${PYSITELIB}/fxa/tests/test_cache.pyc
${PYSITELIB}/fxa/tests/test_cache.pyo
${PYSITELIB}/fxa/tests/test_core.py
${PYSITELIB}/fxa/tests/test_core.pyc
${PYSITELIB}/fxa/tests/test_core.pyo
${PYSITELIB}/fxa/tests/test_crypto.py
${PYSITELIB}/fxa/tests/test_crypto.pyc
${PYSITELIB}/fxa/tests/test_crypto.pyo
${PYSITELIB}/fxa/tests/test_oauth.py
${PYSITELIB}/fxa/tests/test_oauth.pyc
${PYSITELIB}/fxa/tests/test_oauth.pyo
${PYSITELIB}/fxa/tests/test_profile.py
${PYSITELIB}/fxa/tests/test_profile.pyc
${PYSITELIB}/fxa/tests/test_profile.pyo
${PYSITELIB}/fxa/tests/test_requests_auth_plugin.py
${PYSITELIB}/fxa/tests/test_requests_auth_plugin.pyc
${PYSITELIB}/fxa/tests/test_requests_auth_plugin.pyo
${PYSITELIB}/fxa/tests/test_tools.py
${PYSITELIB}/fxa/tests/test_tools.pyc
${PYSITELIB}/fxa/tests/test_tools.pyo
${PYSITELIB}/fxa/tests/utils.py
${PYSITELIB}/fxa/tests/utils.pyc
${PYSITELIB}/fxa/tests/utils.pyo
${PYSITELIB}/fxa/tools/__init__.py
${PYSITELIB}/fxa/tools/__init__.pyc
${PYSITELIB}/fxa/tools/__init__.pyo
${PYSITELIB}/fxa/tools/bearer.py
${PYSITELIB}/fxa/tools/bearer.pyc
${PYSITELIB}/fxa/tools/bearer.pyo
${PYSITELIB}/fxa/tools/browserid.py
${PYSITELIB}/fxa/tools/browserid.pyc
${PYSITELIB}/fxa/tools/browserid.pyo
${PYSITELIB}/fxa/tools/create_user.py
${PYSITELIB}/fxa/tools/create_user.pyc
${PYSITELIB}/fxa/tools/create_user.pyo
${PYSITELIB}/fxa/tools/unblock.py
${PYSITELIB}/fxa/tools/unblock.pyc
${PYSITELIB}/fxa/tools/unblock.pyo

6
www/py-FxA/distinfo Normal file
View File

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1 2023/06/11 08:19:27 wiz Exp $
BLAKE2s (PyFxA-0.7.7.tar.gz) = 8528d4b5c72e725748556ec33f17ac3cecea97a486c168d88fa8e0d1a34b6b9e
SHA512 (PyFxA-0.7.7.tar.gz) = add697d8132d565a00edb28d4fcdc73a244a8484b3b93c21bf5c06a8dda5990b6c394ab14f5bae2e4fcc23549699640bbe629bdaa8c5411d5e9c98b181cba661
Size (PyFxA-0.7.7.tar.gz) = 39053 bytes
SHA1 (patch-dev-requirements.txt) = 24ce678cfaa2aa24f5087e429a03b38551661e87

View File

@ -0,0 +1,17 @@
$NetBSD: patch-dev-requirements.txt,v 1.1 2023/06/11 08:19:27 wiz Exp $
Relax requirements.
--- dev-requirements.txt.orig 2020-06-09 23:55:57.000000000 +0000
+++ dev-requirements.txt
@@ -1,8 +1,8 @@
grequests
mock;python_version<"3.3"
responses
-pytest==4.6.4
-pytest-runner==4.5.1
+pytest
+pytest-runner
pytest-cov
pytest-flake8
pyotp