Update 0.4.2
Many bug fix and performance improvements. Fix GCC 4.6 compile failure
This commit is contained in:
parent
d6038d1b6c
commit
caa385ab7e
4 changed files with 50 additions and 8 deletions
|
@ -1,9 +1,8 @@
|
|||
# $NetBSD: Makefile,v 1.17 2011/04/22 13:43:27 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.18 2011/10/13 10:42:01 ryoon Exp $
|
||||
#
|
||||
|
||||
DISTNAME= Sigil-0.2.4-Code
|
||||
DISTNAME= Sigil-0.4.2-Code
|
||||
PKGNAME= ${DISTNAME:S/-Code//}
|
||||
PKGREVISION= 4
|
||||
CATEGORIES= editors
|
||||
MASTER_SITES= http://sigil.googlecode.com/files/
|
||||
EXTRACT_SUFX= .zip
|
||||
|
@ -13,11 +12,29 @@ HOMEPAGE= http://code.google.com/p/sigil/
|
|||
COMMENT= Multi-platform WYSIWYG ebook editor (for the ePub format)
|
||||
LICENSE= gnu-gpl-v3
|
||||
|
||||
MAKE_JOBS_SAFE= NO
|
||||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
WRKSRC= ${WRKDIR}
|
||||
|
||||
USE_LANGUAGES= c c++
|
||||
USE_CMAKE= yes
|
||||
|
||||
BUILDLINK_TRANSFORM+= l:BoostParts:boost_date_time:boost_filesystem:boost_regex:boost_system:boost_thread:boost_program_options
|
||||
BUILDLINK_TRANSFORM+= l:Xerces:xerces-c
|
||||
BUILDLINK_TRANSFORM+= l:zlib:z
|
||||
|
||||
.include "../../mk/compiler.mk"
|
||||
# GCC 4.4 and above needs this
|
||||
.if !empty(PKGSRC_COMPILER:Mgcc) && !empty(CC_VERSION:Mgcc-4.[4-9]*)
|
||||
_WRAP_EXTRA_ARGS.CXX+= -std=c++0x
|
||||
.endif
|
||||
|
||||
.include "../../textproc/xerces-c/buildlink3.mk"
|
||||
.include "../../devel/zlib/buildlink3.mk"
|
||||
.include "../../devel/boost-libs/buildlink3.mk"
|
||||
.include "../../x11/qt4-libs/buildlink3.mk"
|
||||
.include "../../x11/qt4-tools/buildlink3.mk"
|
||||
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,2 +1,4 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2009/08/19 14:43:36 wiz Exp $
|
||||
@comment $NetBSD: PLIST,v 1.3 2011/10/13 10:42:01 ryoon Exp $
|
||||
bin/sigil
|
||||
share/applications/sigil.desktop
|
||||
share/pixmaps/sigil.png
|
||||
|
|
|
@ -1,5 +1,8 @@
|
|||
$NetBSD: distinfo,v 1.9 2010/08/16 11:26:12 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.10 2011/10/13 10:42:01 ryoon Exp $
|
||||
|
||||
SHA1 (Sigil-0.2.4-Code.zip) = b8fa0280e621166ec31b6c85a476fb01fd5fadc2
|
||||
RMD160 (Sigil-0.2.4-Code.zip) = e134a12b9453113332fbaad5a7214fe39160f464
|
||||
Size (Sigil-0.2.4-Code.zip) = 9299387 bytes
|
||||
SHA1 (Sigil-0.4.2-Code.zip) = 67464f521c1b11641812b6959549a842546b4f8d
|
||||
RMD160 (Sigil-0.4.2-Code.zip) = c0834a04cdc67f8d066e4a66c43973a6013866e0
|
||||
Size (Sigil-0.4.2-Code.zip) = 10104606 bytes
|
||||
SHA1 (patch-CMakeLists.txt) = 2c4a6296f112b88998e8538b0fbc992e8178560d
|
||||
SHA1 (patch-src_ZipArchive_CMakeLists.txt) = 6a999cadd4a83b57a08b3e6ecb042a3d6534d454
|
||||
SHA1 (patch-src_zipios_CMakeLists.txt) = 76da1d6d2a405ee3295b7aba35a19d3971fe44bf
|
||||
|
|
20
editors/Sigil/patches/patch-CMakeLists.txt
Normal file
20
editors/Sigil/patches/patch-CMakeLists.txt
Normal file
|
@ -0,0 +1,20 @@
|
|||
$NetBSD: patch-CMakeLists.txt,v 1.1 2011/10/13 10:42:01 ryoon Exp $
|
||||
|
||||
* Use external libraries.
|
||||
|
||||
--- CMakeLists.txt.orig 2011-08-14 05:09:54.000000000 +0000
|
||||
+++ CMakeLists.txt
|
||||
@@ -55,10 +55,10 @@ set( NO_TEST_EXE 1 )
|
||||
|
||||
add_subdirectory( src/tidyLib )
|
||||
add_subdirectory( src/ZipArchive )
|
||||
-add_subdirectory( src/BoostParts )
|
||||
-add_subdirectory( src/Xerces )
|
||||
+#add_subdirectory( src/BoostParts )
|
||||
+#add_subdirectory( src/Xerces )
|
||||
add_subdirectory( src/XercesExtensions )
|
||||
-add_subdirectory( src/zlib )
|
||||
+#add_subdirectory( src/zlib )
|
||||
add_subdirectory( src/zipios )
|
||||
add_subdirectory( src/FlightCrew )
|
||||
add_subdirectory( src/Sigil )
|
Loading…
Reference in a new issue