www/squid-current has long since been obsoleted by www/squid.

This commit is contained in:
soren 2000-09-26 08:54:45 +00:00
parent ea18d8969e
commit cab414acf0
18 changed files with 1 additions and 438 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.99 2000/09/11 15:41:40 jwise Exp $
# $NetBSD: Makefile,v 1.100 2000/09/26 08:54:45 soren Exp $
# FreeBSD Id: Makefile,v 1.65 1997/11/17 06:31:39 fenner Exp
#
@ -73,7 +73,6 @@
SUBDIR += py-zpublisher
SUBDIR += spfc
SUBDIR += squid
SUBDIR += squid-current
SUBDIR += surfraw
SUBDIR += swish-e
SUBDIR += tcl-cgi

View file

@ -1,65 +0,0 @@
# $NetBSD: Makefile,v 1.11 1999/09/28 20:40:05 soren Exp $
#
DISTNAME= squid-2.1.PATCH2
CATEGORIES= www
MASTER_SITES= \
ftp://squid.nlanr.net/pub/squid-2/STABLE/ \
ftp://ftp.gw.com/pub/unix/squid/squid-2/STABLE/ \
ftp://ftp.funet.fi/pub/mirrors/squid.nlanr.net/pub/squid-2/STABLE/ \
ftp://www.unimelb.edu.au/pub/cwis/servers/unix/squid/squid-2/STABLE/ \
ftp://sunsite.auc.dk/pub/infosystems/squid/squid-2/STABLE/ \
ftp://ftp.net.lut.ac.uk/squid/squid-2/STABLE/
EXTRACT_SUFX= -src.tar.gz
PATCH_SITES= \
http://squid.nlanr.net/Squid/v2/2.1/ \
http://mirror.aarnet.edu.au/squid/v2/2.1/
PATCHFILES=squid-2.1.PATCH2-clientHandleIMSReply-leak.patch
MAINTAINER= bad@netbsd.org
HOMEPAGE= http://squid.nlanr.net/Squid/
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=/etc \
--localstatedir=/var/squid
# Options you might want to enable
CONFIGURE_ARGS+= --enable-cachemgr-hostname=localhost
CONFIGURE_ARGS+= --enable-icmp
#CONFIGURE_ARGS+= --enable-snmp
CONFIGURE_ARGS+= --enable-cache-digests
MAKEFILE= makefile
MAKE_ENV+= INSTALL_SCRIPT="${INSTALL_SCRIPT}" PKG_PREFIX="${PREFIX}"
post-build:
${SED} s#@PREFIX@#${PREFIX}#g <${FILESDIR}/squid.sh >${WRKDIR}/squid.sh
PLIST_SRC= ${PKGDIR}/PLIST ${WRKDIR}/PLIST.share
pre-install:
@-rm -f ${WRKDIR}/PLIST.share
@${MKDIR} ${PREFIX}/share/squid
@${MKDIR} ${PREFIX}/share/squid/errors
@${MKDIR} ${PREFIX}/share/squid/icons
@( \
cd ${WRKSRC}/errors/English; \
ls ERR_* | ${SED} -e 's@^@share/squid/errors/@'; \
${ECHO} "@dirrm share/squid/errors"; \
cd ${WRKSRC}/icons; \
ls anthony-*.gif | ${SED} -e 's@^@share/squid/icons/@'; \
${ECHO} "@dirrm share/squid/icons"; \
${ECHO} "share/squid/mib.txt"; \
${ECHO} "share/squid/mime.conf"; \
${ECHO} "share/squid/mime.conf.default"; \
${ECHO} "share/squid/squid.conf.default"; \
${ECHO} "@dirrm share/squid"; \
) > ${WRKDIR}/PLIST.share
post-install:
cd ${WRKSRC}/src; ${MAKE} install-pinger
${INSTALL_SCRIPT} ${WRKDIR}/squid.sh ${PREFIX}/etc/rc.d/squid.sh
@${SETENV} ${MAKE_ENV} ${SH} ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
.include "../../mk/bsd.pkg.mk"

View file

@ -1,4 +0,0 @@
$NetBSD: md5,v 1.4 1999/01/08 15:29:47 bad Exp $
MD5 (squid-2.1.PATCH2-src.tar.gz) = 71c6b2437e562224d43dcde5765001f8
MD5 (squid-2.1.PATCH2-clientHandleIMSReply-leak.patch) = c5416dc4a2c0fa09a27790b575a19d9c

View file

@ -1,11 +0,0 @@
$NetBSD: patch-sum,v 1.1 1999/07/09 14:23:18 agc Exp $
MD5 (patch-aa) = 6befb071002fb7ced0fb9f388d039cd9
MD5 (patch-ab) = 05ef29847c539ee53d056061ab21ebcf
MD5 (patch-ac) = 56918eb46d3502fd320c19da8215e30d
MD5 (patch-ad) = e29e0dbd58b2838964d4135d730dfc5b
MD5 (patch-ae) = 8cdbc3f03e0b9db7560f47c5aa7ea2f0
MD5 (patch-af) = ec14792120b479d910a2a9f2f183564c
MD5 (patch-ag) = 08ec14bd8e64e0e1dc085bff808ff238
MD5 (patch-ah) = 971f5268e79bd6a7b266baa3e5b87ca0
MD5 (patch-ai) = 86b201973b3a588aa708df3be8d52c29

View file

@ -1,10 +0,0 @@
#!/bin/sh
#
# $NetBSD: squid.sh,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
#
if [ -x @PREFIX@/sbin/RunCache -a -f /etc/squid.conf ];
then
@PREFIX@/sbin/RunCache >/dev/null 2>&1 &
echo -n ' squid'
fi
exit 0

View file

@ -1,129 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
--- src/Makefile.in.orig Mon Aug 17 19:27:15 1998
+++ src/Makefile.in Thu Oct 1 17:00:53 1998
@@ -12,6 +12,8 @@
cgi_suffix = @cgi_suffix@
top_srcdir = @top_srcdir@
bindir = @bindir@
+sbindir = @sbindir@
+datadir = @datadir@
libexecdir = @libexecdir@
sysconfdir = @sysconfdir@
localstatedir = @localstatedir@
@@ -29,18 +31,18 @@
DEFAULT_PREFIX = $(prefix)
DEFAULT_CONFIG_FILE = $(sysconfdir)/squid.conf
-DEFAULT_MIME_TABLE = $(sysconfdir)/mime.conf
+DEFAULT_MIME_TABLE = $(datadir)/squid/mime.conf
DEFAULT_DNSSERVER = $(libexecdir)/$(DNSSERVER_EXE)
DEFAULT_CACHE_LOG = $(localstatedir)/logs/cache.log
DEFAULT_ACCESS_LOG = $(localstatedir)/logs/access.log
DEFAULT_STORE_LOG = $(localstatedir)/logs/store.log
-DEFAULT_PID_FILE = $(localstatedir)/logs/squid.pid
+DEFAULT_PID_FILE = /var/run/squid.pid
DEFAULT_SWAP_DIR = $(localstatedir)/cache
DEFAULT_PINGER = $(libexecdir)/$(PINGER_EXE)
DEFAULT_UNLINKD = $(libexecdir)/$(UNLINKD_EXE)
-DEFAULT_ICON_DIR = $(sysconfdir)/icons
-DEFAULT_ERROR_DIR = $(sysconfdir)/errors
-DEFAULT_MIB_PATH = $(sysconfdir)/mib.txt
+DEFAULT_ICON_DIR = $(datadir)/squid/icons
+DEFAULT_ERROR_DIR = $(datadir)/squid/errors
+DEFAULT_MIB_PATH = $(datadir)/squid/mib.txt
CC = @CC@
MAKEDEPEND = @MAKEDEPEND@
@@ -264,9 +266,9 @@
echo "mkdir $(exec_prefix)"; \
mkdir $(exec_prefix); \
fi
- -@if test ! -d $(bindir); then \
- echo "mkdir $(bindir)"; \
- mkdir $(bindir); \
+ -@if test ! -d $(sbindir); then \
+ echo "mkdir $(sbindir)"; \
+ mkdir $(sbindir); \
fi
-@if test ! -d $(libexecdir); then \
echo "mkdir $(libexecdir)"; \
@@ -276,28 +278,28 @@
echo "mkdir $(sysconfdir)"; \
mkdir $(sysconfdir); \
fi
- -@if test ! -d $(localstatedir); then \
- echo "mkdir $(localstatedir)"; \
- mkdir $(localstatedir); \
- fi
- -@if test ! -d $(localstatedir)/logs; then \
- echo "mkdir $(localstatedir)/logs"; \
- mkdir $(localstatedir)/logs; \
- fi
+# -@if test ! -d $(localstatedir); then \
+# echo "mkdir $(localstatedir)"; \
+# mkdir $(localstatedir); \
+# fi
+# -@if test ! -d $(localstatedir)/logs; then \
+# echo "mkdir $(localstatedir)/logs"; \
+# mkdir $(localstatedir)/logs; \
+# fi
# Michael Lupp <mike@nemesis.saar.de> wants to know about additions
# to the install target.
install: all install-mkdirs
@for f in $(PROGS); do \
- if test -f $(bindir)/$$f; then \
- echo $(MV) $(bindir)/$$f $(bindir)/-$$f; \
- $(MV) $(bindir)/$$f $(bindir)/-$$f; \
+ if test -f $(sbindir)/$$f; then \
+ echo $(MV) $(sbindir)/$$f $(sbindir)/-$$f; \
+ $(MV) $(sbindir)/$$f $(sbindir)/-$$f; \
fi; \
- echo $(INSTALL_BIN) $$f $(bindir); \
- $(INSTALL_BIN) $$f $(bindir); \
- if test -f $(bindir)/-$$f; then \
- echo $(RM) -f $(bindir)/-$$f; \
- $(RM) -f $(bindir)/-$$f; \
+ echo $(INSTALL_BIN) $$f $(sbindir); \
+ $(INSTALL_BIN) $$f $(sbindir); \
+ if test -f $(sbindir)/-$$f; then \
+ echo $(RM) -f $(sbindir)/-$$f; \
+ $(RM) -f $(sbindir)/-$$f; \
fi; \
done
@for f in $(UTILS); do \
@@ -325,20 +327,20 @@
fi; \
done
$(INSTALL_FILE) $(srcdir)/mib.txt $(DEFAULT_MIB_PATH)
- $(INSTALL_FILE) squid.conf $(sysconfdir)/squid.conf.default
- @if test -f $(sysconfdir)/squid.conf ; then \
- echo "$@ will not overwrite existing $(sysconfdir)/squid.conf" ; \
- else \
- echo "$(INSTALL_FILE) squid.conf $(sysconfdir)"; \
- $(INSTALL_FILE) squid.conf $(sysconfdir); \
- fi
-
- $(INSTALL_FILE) $(srcdir)/mime.conf $(sysconfdir)/mime.conf.default
- @if test -f $(sysconfdir)/mime.conf ; then \
- echo "$@ will not overwrite existing $(sysconfdir)/mime.conf" ; \
+ $(INSTALL_FILE) squid.conf $(datadir)/squid/squid.conf.default
+# @if test -f $(DEFAULT_CONFIG_FILE) ; then \
+# echo "$@ will not overwrite existing $(DEFAULT_CONFIG_FILE)" ; \
+# else \
+# echo "$(INSTALL_FILE) squid.conf $(DEFAULT_CONFIG_FILE)"; \
+# $(INSTALL_FILE) squid.conf $(DEFAULT_CONFIG_FILE); \
+# fi
+
+ $(INSTALL_FILE) $(srcdir)/mime.conf $(DEFAULT_MIME_TABLE).default
+ @if test -f $(DEFAULT_MIME_TABLE) ; then \
+ echo "$@ will not overwrite existing $(DEFAULT_MIME_TABLE)" ; \
else \
- echo "$(INSTALL_FILE) $(srcdir)/mime.conf $(sysconfdir)"; \
- $(INSTALL_FILE) $(srcdir)/mime.conf $(sysconfdir); \
+ echo "$(INSTALL_FILE) $(srcdir)/mime.conf $(DEFAULT_MIME_TABLE)"; \
+ $(INSTALL_FILE) $(srcdir)/mime.conf $(DEFAULT_MIME_TABLE); \
fi
install-pinger:

View file

@ -1,15 +0,0 @@
$NetBSD: patch-ab,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
--- scripts/Makefile.in.orig Sat May 4 00:56:18 1996
+++ scripts/Makefile.in Sat May 23 21:36:03 1998
@@ -29,8 +29,8 @@
echo "mkdir $(bindir)"; \
mkdir $(bindir); \
fi
- $(INSTALL_BIN) RunCache $(bindir)
- $(INSTALL_BIN) RunAccel $(bindir)
+ $(INSTALL_SCRIPT) RunCache $(bindir)
+ $(INSTALL_SCRIPT) RunAccel $(bindir)
clean:

View file

@ -1,26 +0,0 @@
$NetBSD: patch-ac,v 1.2 1998/10/16 16:24:04 bad Exp $
--- scripts/RunCache.in.orig Tue Aug 4 22:59:32 1998
+++ scripts/RunCache.in Fri Oct 16 17:57:43 1998
@@ -5,7 +5,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
logdir=@localstatedir@
-PATH=@bindir@:/bin:/usr/bin
+PATH=@sbindir@:/bin:/usr/bin
export PATH
conf=""
@@ -16,10 +16,10 @@
failcount=0
while : ; do
- echo "Running: squid -sY $conf >> $logdir/squid.out 2>&1"
+ echo "Running: squid -Y $conf >> $logdir/squid.out 2>&1"
echo "Startup: `date`" >> $logdir/squid.out
start=`date '+%d%H%M%S'`
- squid -sY $conf >> $logdir/squid.out 2>&1
+ squid -Y $conf >> $logdir/squid.out 2>&1
stop=`date '+%d%H%M%S'`
t=`expr $stop - $start`
if test 0 -le $t -a $t -lt 5 ; then

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ad,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
--- errors/Makefile.in.orig Fri Apr 24 01:26:39 1998
+++ errors/Makefile.in Thu Oct 1 16:25:32 1998
@@ -4,6 +4,7 @@
exec_prefix = @exec_prefix@
top_srcdir = @top_srcdir@
bindir = @bindir@
+datadir = @datadir@
libexecdir = @libexecdir@
sysconfdir = @sysconfdir@
localstatedir = @localstatedir@
@@ -15,7 +16,7 @@
INSTALL = @INSTALL@
INSTALL_FILE = @INSTALL_DATA@
-DEFAULT_ERROR_DIR = $(sysconfdir)/errors
+DEFAULT_ERROR_DIR = $(datadir)/squid/errors
LANGUAGE = @ERR_LANGUAGE@

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ae,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
--- icons/Makefile.in.orig Mon Feb 2 14:39:25 1998
+++ icons/Makefile.in Thu Oct 1 16:26:08 1998
@@ -4,6 +4,7 @@
exec_prefix = @exec_prefix@
top_srcdir = @top_srcdir@
bindir = @bindir@
+datadir = @datadir@
libexecdir = @libexecdir@
sysconfdir = @sysconfdir@
localstatedir = @localstatedir@
@@ -15,7 +16,7 @@
INSTALL = @INSTALL@
INSTALL_FILE = @INSTALL_DATA@
-DEFAULT_ICON_DIR = $(sysconfdir)/icons
+DEFAULT_ICON_DIR = $(datadir)/squid/icons
SHARFILE = $(srcdir)/icons.shar
ICONS = anthony-binhex.gif \

View file

@ -1,30 +0,0 @@
$NetBSD: patch-af,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
--- scripts/Makefile.in.orig Thu Oct 1 16:06:14 1998
+++ scripts/Makefile.in Thu Oct 1 16:29:14 1998
@@ -7,6 +7,7 @@
exec_prefix = @exec_prefix@
top_srcdir = @top_srcdir@
bindir = @bindir@
+sbindir = @sbindir@
sysconfdir = @sysconfdir@
srcdir = @srcdir@
VPATH = @srcdir@
@@ -25,12 +26,12 @@
echo "mkdir $(exec_prefix)"; \
mkdir $(exec_prefix); \
fi
- @if test ! -d $(bindir); then \
- echo "mkdir $(bindir)"; \
- mkdir $(bindir); \
+ @if test ! -d $(sbindir); then \
+ echo "mkdir $(sbindir)"; \
+ mkdir $(sbindir); \
fi
- $(INSTALL_SCRIPT) RunCache $(bindir)
- $(INSTALL_SCRIPT) RunAccel $(bindir)
+ $(INSTALL_SCRIPT) RunCache $(sbindir)
+ $(INSTALL_SCRIPT) RunAccel $(sbindir)
clean:

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ag,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
--- configure.orig Tue Sep 22 19:46:09 1998
+++ configure Thu Oct 1 17:39:47 1998
@@ -636,11 +636,11 @@
REGEXLIB='' # -lregex
LIBREGEX='' # libregex.a
-if test "$libexecdir" = '${exec_prefix}/libexec'; then
- libexecdir='${bindir}'
- localstatedir='${prefix}'
-
-fi
+#if test "$libexecdir" = '${exec_prefix}/libexec'; then
+# libexecdir='${bindir}'
+# localstatedir='${prefix}'
+#
+#fi
case "$host_os" in
cygwin32)

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ah,v 1.2 1998/11/13 00:01:49 frueauf Exp $
--- scripts/RunAccel.in.orig Tue Jul 9 05:41:15 1996
+++ scripts/RunAccel.in Fri Oct 16 17:59:52 1998
@@ -8,7 +8,7 @@
prefix=@prefix@
exec_prefix=@exec_prefix@
logdir=@localstatedir@
-PATH=@bindir@:/bin:/usr/bin
+PATH=@sbindir@:/bin:/usr/bin
export PATH
if test $# = 1 ; then

View file

@ -1,13 +0,0 @@
$NetBSD: patch-ai,v 1.1 1999/01/31 18:54:24 bad Exp $
--- src/neighbors.c.orig Fri Dec 4 18:17:12 1998
+++ src/neighbors.c Sun Jan 31 18:58:40 1999
@@ -915,7 +915,7 @@
{
peer *p = NULL;
if (eventFind(peerRefreshDNS, NULL))
- return;
+ eventDelete(peerRefreshDNS, NULL);
if (!data && 0 == stat5minClientRequests()) {
/* no recent client traffic, wait a bit */
eventAddIsh("peerRefreshDNS", peerRefreshDNS, NULL, 180.0, 1);

View file

@ -1 +0,0 @@
Post-Harvest_cached WWW proxy cache and accelerator

View file

@ -1,15 +0,0 @@
This is the Squid Internet Object Cache developed by the National
Laboratory for Applied Networking Research (NLANR) and Internet
volunteers. This software is freely available for anyone to use.
This software is based on the Harvest Object Cache developed by
the University of Colorado and the University of Southern California.
The Harvest home page is http://harvest.cs.colorado.edu/.
ARPA funding for the Harvest project has ended, the squid project has
continued development of the cache where Harvest finished.
PORTER'S NOTES. To this moment, Squid is not well documented.
But you aren't lost in space: there is a mailing list,
<squid-users@nlanr.net>, where you will find some support and help.
We also _strongly_ suggest you to examine Web pages noted above.

View file

@ -1,31 +0,0 @@
#!/bin/sh
#
# $NetBSD: INSTALL,v 1.3 1999/01/29 19:26:37 bad Exp $
#
PKGNAME=$1
DEFCONF=${PKG_PREFIX}/share/squid/squid.conf.default
case $2 in
PRE-INSTALL)
;;
POST-INSTALL)
echo ""
echo " o you DO need running nameservice to start and run ${PKGNAME}"
echo ""
echo " o use the ${PKGNAME} proxy and caching WWW Server by"
echo " configuring your WWW Navigator (Netscape, Mosaic,...)"
echo " to use it as a proxy server."
echo ""
echo " o copy \"${DEFCONF}\" to \"/etc/squid.conf\""
echo " and edit it as required. You should pay attention to"
echo " the ACTUAL locations of the cache \"spool\" logfiles"
echo " and pidfile."
echo ""
;;
*)
echo "Unexpected Argument $2!!!"
exit 1
;;
esac
exit 0

View file

@ -1,10 +0,0 @@
@comment $NetBSD: PLIST,v 1.1.1.1 1998/10/09 17:49:20 kim Exp $
etc/rc.d/squid.sh
libexec/cachemgr.cgi
libexec/dnsserver
libexec/pinger
libexec/unlinkd
sbin/RunAccel
sbin/RunCache
sbin/client
sbin/squid