php-dotclear: Update to 2.20.1

upstream changes:
-----------------
Dotclear 2.20.1 - 2021-11-19
===========================================================
* Fix: Lost of context in media popup (editor media insertion)
* Fix: Active menuitem in favorites menu
* Fix: Avoid notice on unknown namespace (dcSettings)
* Fix: New user button had disappeared since the previous version

Dotclear 2.20 - 2021-11-13
===========================================================
* 🐘 PHP 7.3+ is required, PHP 8 compliance
* Js: switch to ES2016+ syntax, up to ES2021 (was ES2015 in 2.19), will require a "modern" browser
* Template: Refine tpl:block for pagination and archive (dotty templateset)
* Template: Add ".updated" class to republished posts (dotty templateset)
* Template: The {{tpl:CommentIfMe}} template item take care of author's alternative emails and URLs
* Admin UI: Enforce visibility of last action « button » on update
* Admin UI: Remove box and text shadows from CKEditor dotclear CSS styles
* Admin UI: Slightly review the look of theme's screenshots (blog appearance page)
* Admin UI: Move drag'n'drop button to right side on dashboard
* Admin UX: Add screenshots for disabled themes
* Admin UX: Add a badge with number of updates available on dashboard icon
* Admin UX: Add password strength meter on auth page (if password change is required)
* Admin UX: Generic filter controls refactored
* Admin UX: Cope with local .mediadef file (JSON format wich superseeds insertion defaults)
* Admin UX: Add message about next required PHP version on update page
* Theme: Remove left border for (aside) sidebar of Berlin theme
* Core: Add third-party repository option for modules (plugins and themes)
* Core: Asynchronous check store update on dashboard
* Core: Add constant (DC_STORE_NOT_UPDATE) to disable DotAddict updates check
* Core: Add constant (DC_ALLOW_REPOSITORIES) to disable third party repo
* Core: Open admin search page to other type (WIP)
* Core: Remove currywurst template set (never used)
* Core: Add color, email, number types for widget settings
* Core: Fix determination of « republished » state of post
* Core: Cope with IPv6 addresses
* Core: Create DC_TPL_CACHE directory if necessary
* Core: Add IP v6 antispam filter (only enabled if GMP or BC Math library is available)
* Core: Add standard nethttp timeout constant (DC_QUERY_TIMEOUT)
* Core: Add alternatives Emails and URLs for users in My Preferences and User Profile (super-admin only)
* Core: Set repositories store cache TTL to 12 hours rather than 30 minutes
* Fix: Cope with DotAddict server not responding
* Fix: Cope with isolated figcaption for remove_html and strip_tags tpl attributes
* Fix: Allow modification of "official" themes if they are not in distributed folder (themes) of Dotclear
* Fix: RSS style, fix css responsive + fix input
* Fix: Ensure theme's settings namespace exists
* Fix: Ensure DC_VAR constant exists before using it
* Fix: Fix favicon path in auth page
* Fix: Allow https protocol for trackbacks
* Fix: Fix IPv4 antispam filter for subnet mask > 32
* Fix: Fix plugins privileges on config file
* Fix: Uses the same font in the CKEditor editor as the rest of the administration
* Fix: CKEditor sometimes add a t parameter to a request URL (background sprite image), ignore it
* Lib: Update CKEditor from 4.16.1 to 4.16.2 (with local additional fixes in CKEditor jQuery adapter)
* Lib: Update Codemirror 5.62.0 from to 5.63.3
* Lib: Update jQuery UI (custom) from 1.12.1 to 1.13.0
* ClearBricks: Allow legitimate .. in media filenames
* ClearBricks: Allow legacy forms (array of key => value) for select and optgroup components in form class
* Clearbricks: Add HTML details block support in wiki syntax
* Clearbricks: Use mysqli_get_server_version() rather than mysqli_get_server_info() to get server version
* 🛡 Security: Add SECURITY.md document
* 🐛 → Various bugs, a11y concerns and typos fixed
* 🌼 → Some locales and cosmetic adjustments
* 📣 Warning: Next major release (2.21) will require PHP 7.4+

Dotclear 2.19 - 2021-08-13
===========================================================
* 🐘 PHP 7.3+ is required, PHP 8 compliance
* jQuery: Remove old jQuery biscuit plugin and replace it by "modern JS"
* jQuery: Remove old jQuery pwstrength plugin and replace it by "modern JS"
* Js: Use dotclear global object rather than global constants, var and methods (AFAP)
* Js: No more need of global dotclear_init const as dotclear global object is initialized before (prepend.js)
* Js: Rewrite metaEditor script
* Template: Add {{tpl:CategoryID}} template
* Template: Refine granularity of tpl:Blocks in dotty template set, will simplify inheritance and overload of themes
* Template: Add dc-home-first class to body tag if it is the first page (standard mode)
* Template: {{tpl:FeedLanguage}} consider lang in post context
* Admin UI: Remove some PNG fallback image when SVG are available as every modern browsers support SVG format
* Admin UI: Bye bye responsive font size, thanks for all the fish!
* Admin UI: Blog appearance, use details HTML5 element rather than div and JS to display theme details
* Admin UI: Add system-ui (cross-platform default user interface font) in 1st position of font-family
* Admin UX: Load themes in some admin popups as some configurable theme may use a link/post/page selector
* Admin UX: Load themes in media/media-item admin pages as some configurable theme may use a media selector
* Admin UX: Disable deletion and modification of officially distributed themes
* Admin UX: Remove Google Blog Search from pings URIs (service stopped) and fix pings global settings management
* Admin UX: Check themes dependencies (with core, plugins)
* Admin UX: Management of attachments, allow using media->postmedia property
* Admin UX: Use details HTML5 element rather than div and JS for authentication additional options
* Admin UX: Add Ad-blocker detection (may be disabled) as it may interfere with CKEditor (may be other features).
* a11y: Cope with mediaquery prefers-reduced-data (experimental)
* Public UX: Fix navigation widget to cope with static mode
* Public UX: Add language information (if any) in breadcrumb
* Public UX: Use localStorage rather than cookie to store comment's author info ("remember me" checkbox)
* Public UX: Subscribe widget and feeds handling language context
* Theme: Use <link rel… rather than <style @import… for CustomCSS theme
* Theme: Align right field's labels (single line fields only) of Berlin theme
* Theme: No need to load again util.js in _public.php as it's already loaded by dotty/_head.html
* Core: Add .svg in allowed var/plugin loaded files
* Core: Add .webp in allowed var/plugin loaded files and ope with wepb thumbnails
* Core: Remove mysql driver support, obsolete in PHP 7+
* Core: Forget about URL type = lang as it cannot be set as this by the URL handler
* Core: Add publicBeforeCommentRedir behavior - useful to add parameters on redir URL
* Core: Globally disable (Google) FLoC tracking by default
* Fix: Cope with original size when storing current media insertion settings
* Lib: Update jQuery from 3.5.1 to 3.6.0
* Lib: Update Codemirror 5.58.2 from to 5.62.0
* Lib: Update CKEditor from 4.16.0 to 4.16.1 (and fix CKEditor jQuery adapter warnings)
* 🐛 → Various bugs, a11y concerns and typos fixed
* 🌼 → Some locales and cosmetic adjustments
This commit is contained in:
triaxx 2022-01-25 08:31:38 +00:00
parent ea5d59d440
commit cac0ec21c0
9 changed files with 67 additions and 80 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.3 2021/12/29 06:05:19 taca Exp $
# $NetBSD: Makefile,v 1.4 2022/01/25 08:31:38 triaxx Exp $
DISTNAME= dotclear-2.18.1
PKGREVISION= 1
DISTNAME= dotclear-2.20.1
PKGNAME= ${PHP_PKG_PREFIX}-${DISTNAME}
CATEGORIES= www
MASTER_SITES= https://download.dotclear.org/latest/ \
@ -15,7 +14,7 @@ LICENSE= gnu-gpl-v2
.include "../../lang/php/phpversion.mk"
DEPENDS+= ${PHP_PKG_PREFIX}-mbstring>=${PHP_BASE_VERS}:../../converters/php-mbstring
DEPENDS+= ${PHP_PKG_PREFIX}-iconv>=${PHP_BASE_VERS}:../../converters/php-iconv
.if ${PKG_PHP_MAJOR_VERS} < 8
.if ${PKG_PHP_MAJOR_VERS} < 8
DEPENDS+= ${PHP_PKG_PREFIX}-json>=${PHP_BASE_VERS}:../../textproc/php-json
.endif
DEPENDS+= ${PHP_PKG_PREFIX}-zlib>=${PHP_BASE_VERS}:../../archivers/php-zlib
@ -27,7 +26,7 @@ BUILD_DEFS+= PKG_SYSCONFBASE VARBASE
.include "options.mk"
PHP_VERSIONS_ACCEPTED= 74 56
PHP_VERSIONS_ACCEPTED= 81 80 74
PKG_SYSCONFSUBDIR= dotclear

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.1 2021/06/24 02:32:27 triaxx Exp $
@comment $NetBSD: PLIST,v 1.2 2022/01/25 08:31:38 triaxx Exp $
share/dotclear/admin/_charte.php
share/dotclear/admin/auth.php
share/dotclear/admin/blog.php
@ -113,7 +113,6 @@ share/dotclear/admin/images/plus.png
share/dotclear/admin/images/scheduled.png
share/dotclear/admin/images/selected.png
share/dotclear/admin/images/superadmin.png
share/dotclear/admin/images/thanks.mp3
share/dotclear/admin/images/trackbacks.png
share/dotclear/admin/images/trash.png
share/dotclear/admin/images/up.png
@ -151,6 +150,7 @@ share/dotclear/admin/js/_update.js
share/dotclear/admin/js/_user.js
share/dotclear/admin/js/_users.js
share/dotclear/admin/js/_users_actions.js
share/dotclear/admin/js/ads.js
share/dotclear/admin/js/codemirror.js
share/dotclear/admin/js/codemirror/LICENSE
share/dotclear/admin/js/codemirror/addon/display/fullscreen.css
@ -168,6 +168,7 @@ share/dotclear/admin/js/codemirror/mode/php/php.js
share/dotclear/admin/js/codemirror/mode/xml/xml.js
share/dotclear/admin/js/codemirror/theme/3024-day.css
share/dotclear/admin/js/codemirror/theme/3024-night.css
share/dotclear/admin/js/codemirror/theme/abbott.css
share/dotclear/admin/js/codemirror/theme/abcdef.css
share/dotclear/admin/js/codemirror/theme/ambiance-mobile.css
share/dotclear/admin/js/codemirror/theme/ambiance.css
@ -191,6 +192,7 @@ share/dotclear/admin/js/codemirror/theme/hopscotch.css
share/dotclear/admin/js/codemirror/theme/icecoder.css
share/dotclear/admin/js/codemirror/theme/idea.css
share/dotclear/admin/js/codemirror/theme/isotope.css
share/dotclear/admin/js/codemirror/theme/juejin.css
share/dotclear/admin/js/codemirror/theme/lesser-dark.css
share/dotclear/admin/js/codemirror/theme/liquibyte.css
share/dotclear/admin/js/codemirror/theme/lucario.css
@ -238,12 +240,10 @@ share/dotclear/admin/js/jquery-mute.js
share/dotclear/admin/js/jquery/jquery-migrate.js
share/dotclear/admin/js/jquery/jquery-ui.custom.js
share/dotclear/admin/js/jquery/jquery.autocomplete.js
share/dotclear/admin/js/jquery/jquery.biscuit.js
share/dotclear/admin/js/jquery/jquery.js
share/dotclear/admin/js/jquery/jquery.magnific-popup.js
share/dotclear/admin/js/jquery/jquery.mjs.nestedSortable.js
share/dotclear/admin/js/jquery/jquery.pageTabs.js
share/dotclear/admin/js/jquery/jquery.pwstrength.js
share/dotclear/admin/js/jquery/jquery.ui.touch-punch.js
share/dotclear/admin/js/jsUpload/jquery.fileupload-process.js
share/dotclear/admin/js/jsUpload/jquery.fileupload-resize.js
@ -258,6 +258,7 @@ share/dotclear/admin/js/meta-editor.js
share/dotclear/admin/js/page-tabs.js
share/dotclear/admin/js/prelude.js
share/dotclear/admin/js/prepend.js
share/dotclear/admin/js/pwstrength.js
share/dotclear/admin/js/services.js
share/dotclear/admin/js/toggles.js
share/dotclear/admin/langs.php
@ -360,6 +361,8 @@ share/dotclear/inc/admin/class.dc.blog_pref.php
share/dotclear/inc/admin/class.dc.favorites.php
share/dotclear/inc/admin/class.dc.menu.php
share/dotclear/inc/admin/lib.admincombos.php
share/dotclear/inc/admin/lib.adminfilters.php
share/dotclear/inc/admin/lib.adminuserpref.php
share/dotclear/inc/admin/lib.dc.adminurl.php
share/dotclear/inc/admin/lib.dc.notices.php
share/dotclear/inc/admin/lib.dc.page.php
@ -400,13 +403,13 @@ share/dotclear/inc/dbschema/db-schema.php
share/dotclear/inc/dbschema/upgrade-cli.php
share/dotclear/inc/dbschema/upgrade.php
share/dotclear/inc/digests
share/dotclear/inc/js/jquery/3.5.1/jquery.js
share/dotclear/inc/js/jquery/3.6.0/jquery.js
share/dotclear/inc/js/password.js
share/dotclear/inc/js/post.js
share/dotclear/inc/js/util.js
share/dotclear/inc/libs/clearbricks/.doxygen.conf
share/dotclear/inc/libs/clearbricks/.editorconfig
share/dotclear/inc/libs/clearbricks/.php_cs.dist
share/dotclear/inc/libs/clearbricks/.php-cs-fixer.dist.php
share/dotclear/inc/libs/clearbricks/LICENSE
share/dotclear/inc/libs/clearbricks/Makefile
share/dotclear/inc/libs/clearbricks/README.md
@ -416,14 +419,13 @@ share/dotclear/inc/libs/clearbricks/common/lib.crypt.php
share/dotclear/inc/libs/clearbricks/common/lib.date.php
share/dotclear/inc/libs/clearbricks/common/lib.files.php
share/dotclear/inc/libs/clearbricks/common/lib.form.php
share/dotclear/inc/libs/clearbricks/common/lib.forms.php
share/dotclear/inc/libs/clearbricks/common/lib.html.php
share/dotclear/inc/libs/clearbricks/common/lib.http.php
share/dotclear/inc/libs/clearbricks/common/lib.json.php
share/dotclear/inc/libs/clearbricks/common/lib.l10n.php
share/dotclear/inc/libs/clearbricks/common/lib.text.php
share/dotclear/inc/libs/clearbricks/common/tz.dat
share/dotclear/inc/libs/clearbricks/dblayer/class.cursor.php
share/dotclear/inc/libs/clearbricks/dblayer/class.mysql.php
share/dotclear/inc/libs/clearbricks/dblayer/class.mysqli.php
share/dotclear/inc/libs/clearbricks/dblayer/class.mysqlimb4.php
share/dotclear/inc/libs/clearbricks/dblayer/class.pgsql.php
@ -431,7 +433,6 @@ share/dotclear/inc/libs/clearbricks/dblayer/class.sqlite.php
share/dotclear/inc/libs/clearbricks/dblayer/dblayer.php
share/dotclear/inc/libs/clearbricks/dbschema/class.dbschema.php
share/dotclear/inc/libs/clearbricks/dbschema/class.dbstruct.php
share/dotclear/inc/libs/clearbricks/dbschema/class.mysql.dbschema.php
share/dotclear/inc/libs/clearbricks/dbschema/class.mysqli.dbschema.php
share/dotclear/inc/libs/clearbricks/dbschema/class.mysqlimb4.dbschema.php
share/dotclear/inc/libs/clearbricks/dbschema/class.pgsql.dbschema.php
@ -449,6 +450,28 @@ share/dotclear/inc/libs/clearbricks/diff/lib.tidy.diff.php
share/dotclear/inc/libs/clearbricks/ext/incutio.ixr_library.php
share/dotclear/inc/libs/clearbricks/filemanager/class.filemanager.php
share/dotclear/inc/libs/clearbricks/html.filter/class.html.filter.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.checkbox.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.color.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.component.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.date.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.datetime.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.email.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.fieldset.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.file.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.form.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.hidden.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.input.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.label.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.legend.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.number.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.optgroup.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.option.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.password.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.radio.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.select.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.textarea.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.time.php
share/dotclear/inc/libs/clearbricks/html.form/class.form.url.php
share/dotclear/inc/libs/clearbricks/html.validator/class.html.validator.php
share/dotclear/inc/libs/clearbricks/image/class.image.meta.php
share/dotclear/inc/libs/clearbricks/image/class.image.tools.php
@ -464,6 +487,7 @@ share/dotclear/inc/libs/clearbricks/net.nntp/class.nntp.message.php
share/dotclear/inc/libs/clearbricks/net.xmlrpc/class.net.xmlrpc.php
share/dotclear/inc/libs/clearbricks/net/class.net.socket.php
share/dotclear/inc/libs/clearbricks/pager/class.pager.php
share/dotclear/inc/libs/clearbricks/phpstan.neon
share/dotclear/inc/libs/clearbricks/rest/class.rest.php
share/dotclear/inc/libs/clearbricks/session.db/class.session.db.php
share/dotclear/inc/libs/clearbricks/template/class.template.php
@ -482,38 +506,6 @@ share/dotclear/inc/load_plugin_file.php
share/dotclear/inc/load_var_file.php
share/dotclear/inc/prepend.php
share/dotclear/inc/public/class.dc.template.php
share/dotclear/inc/public/default-templates/currywurst/404.html
share/dotclear/inc/public/default-templates/currywurst/README.md
share/dotclear/inc/public/default-templates/currywurst/__layout.html
share/dotclear/inc/public/default-templates/currywurst/_audio_player.html
share/dotclear/inc/public/default-templates/currywurst/_entry-content.html
share/dotclear/inc/public/default-templates/currywurst/_entry-feedback.html
share/dotclear/inc/public/default-templates/currywurst/_entry-full.html
share/dotclear/inc/public/default-templates/currywurst/_entry-short.html
share/dotclear/inc/public/default-templates/currywurst/_entry-title.html
share/dotclear/inc/public/default-templates/currywurst/_flv_player.html
share/dotclear/inc/public/default-templates/currywurst/_footer.html
share/dotclear/inc/public/default-templates/currywurst/_head.html
share/dotclear/inc/public/default-templates/currywurst/_mp3_player.html
share/dotclear/inc/public/default-templates/currywurst/_pagination.html
share/dotclear/inc/public/default-templates/currywurst/_sidebar.html
share/dotclear/inc/public/default-templates/currywurst/_simple-entry.html
share/dotclear/inc/public/default-templates/currywurst/_top.html
share/dotclear/inc/public/default-templates/currywurst/_video_player.html
share/dotclear/inc/public/default-templates/currywurst/archive.html
share/dotclear/inc/public/default-templates/currywurst/archive_month.html
share/dotclear/inc/public/default-templates/currywurst/atom-comments.xml
share/dotclear/inc/public/default-templates/currywurst/atom.xml
share/dotclear/inc/public/default-templates/currywurst/category.html
share/dotclear/inc/public/default-templates/currywurst/home.html
share/dotclear/inc/public/default-templates/currywurst/password-form.html
share/dotclear/inc/public/default-templates/currywurst/post.html
share/dotclear/inc/public/default-templates/currywurst/rss2-comments.xml
share/dotclear/inc/public/default-templates/currywurst/rss2.xml
share/dotclear/inc/public/default-templates/currywurst/rss2.xsl
share/dotclear/inc/public/default-templates/currywurst/search.html
share/dotclear/inc/public/default-templates/currywurst/static.html
share/dotclear/inc/public/default-templates/currywurst/user_head.html
share/dotclear/inc/public/default-templates/dotty/404.html
share/dotclear/inc/public/default-templates/dotty/README.md
share/dotclear/inc/public/default-templates/dotty/__layout.html
@ -662,6 +654,7 @@ share/dotclear/plugins/antispam/_services.php
share/dotclear/plugins/antispam/feed.png
share/dotclear/plugins/antispam/filters/class.dc.filter.ip.php
share/dotclear/plugins/antispam/filters/class.dc.filter.iplookup.php
share/dotclear/plugins/antispam/filters/class.dc.filter.ipv6.php
share/dotclear/plugins/antispam/filters/class.dc.filter.linkslookup.php
share/dotclear/plugins/antispam/filters/class.dc.filter.words.php
share/dotclear/plugins/antispam/icon-big.png
@ -802,6 +795,7 @@ share/dotclear/plugins/dcCKEditor/js/ckeditor/.nvmrc
share/dotclear/plugins/dcCKEditor/js/ckeditor/CHANGES.md
share/dotclear/plugins/dcCKEditor/js/ckeditor/LICENSE.md
share/dotclear/plugins/dcCKEditor/js/ckeditor/adapters/jquery.js
share/dotclear/plugins/dcCKEditor/js/ckeditor/bender-runner.config.json
share/dotclear/plugins/dcCKEditor/js/ckeditor/ckeditor.js
share/dotclear/plugins/dcCKEditor/js/ckeditor/config.js
share/dotclear/plugins/dcCKEditor/js/ckeditor/contents.css
@ -1321,19 +1315,14 @@ share/dotclear/themes/berlin/img/bg_dark.png
share/dotclear/themes/berlin/img/bg_light.png
share/dotclear/themes/berlin/img/hline.png
share/dotclear/themes/berlin/img/icon_attach.png
share/dotclear/themes/berlin/img/icon_attachments.png
share/dotclear/themes/berlin/img/icon_attachments.svg
share/dotclear/themes/berlin/img/icon_category.png
share/dotclear/themes/berlin/img/icon_close.png
share/dotclear/themes/berlin/img/icon_close.svg
share/dotclear/themes/berlin/img/icon_comments.png
share/dotclear/themes/berlin/img/icon_date.png
share/dotclear/themes/berlin/img/icon_feed.png
share/dotclear/themes/berlin/img/icon_feed.svg
share/dotclear/themes/berlin/img/icon_hamburger.png
share/dotclear/themes/berlin/img/icon_hamburger.svg
share/dotclear/themes/berlin/img/icon_next.png
share/dotclear/themes/berlin/img/icon_open-sidebar.png
share/dotclear/themes/berlin/img/icon_open-sidebar.svg
share/dotclear/themes/berlin/img/icon_permalink.png
share/dotclear/themes/berlin/img/icon_prev.png
@ -1351,7 +1340,6 @@ share/dotclear/themes/berlin/locales/es/main.po
share/dotclear/themes/berlin/locales/fr/main.lang.php
share/dotclear/themes/berlin/locales/fr/main.po
share/dotclear/themes/berlin/screenshot.jpg
share/dotclear/themes/berlin/scripts/boxsizing.htc
share/dotclear/themes/berlin/scss/init/_config.scss
share/dotclear/themes/berlin/scss/init/_mixins-functions.scss
share/dotclear/themes/berlin/scss/init/_rebase.scss

View file

@ -1,11 +1,11 @@
$NetBSD: distinfo,v 1.3 2021/10/26 11:30:23 nia Exp $
$NetBSD: distinfo,v 1.4 2022/01/25 08:31:38 triaxx Exp $
BLAKE2s (dotclear-2.18.1.tar.gz) = 443d6b69eef6b8c14c4647682d703632e0ca5a6b036e67671635fff9ef4cc0c1
SHA512 (dotclear-2.18.1.tar.gz) = 517755808873eababe8c2c441008c98519573adc648cadfec1d82d24dccccacf38857f088ecd9f8e42c26f5a858496383f918ad77eb4fabde620609814f90a58
Size (dotclear-2.18.1.tar.gz) = 3017421 bytes
SHA1 (patch-admin_install_index.php) = b93ea9add67007e720319b1ff8e3d8d95bb95fa7
SHA1 (patch-admin_install_wizard.php) = 301358bb95cd9f6f04ef891b5fcc8e3562baf712
SHA1 (patch-inc_config.php.in) = 6c0c8e9cd394ee80afe8587c71ffdfff128d77f9
SHA1 (patch-inc_core_class.dc.core.php) = ae0b34f88f566c50d90059a74f89d8013650378f
SHA1 (patch-inc_load__plugin__file.php) = a75463a2ba1fd9cd140dc3cdcd1a1ea6d52ad8ec
SHA1 (patch-inc_prepend.php) = 97f72277f2f2aba592ad1dad487e7d6187e47c9f
BLAKE2s (dotclear-2.20.1.tar.gz) = df9561e307ddf3f6e7a9aed768f0d500c406d78cf214e731cae36f2ef5f4e361
SHA512 (dotclear-2.20.1.tar.gz) = c637d464ebbf3e1ca213286f157c63136c6dfb33e710d592f4ebfc0863f2aecc9df7f5db21261e4d6d8af7b323e6791f1ff6ab7b798811e14c111da708864b1c
Size (dotclear-2.20.1.tar.gz) = 2966383 bytes
SHA1 (patch-admin_install_index.php) = b44e0fd0aefa908f70d64692ce7fcdecd710bb38
SHA1 (patch-admin_install_wizard.php) = 3709e12ee79cee399091aff0a6b0218f25554217
SHA1 (patch-inc_config.php.in) = 674dbbe66f534c3e0e5d6c21aa24e4c1eb9285ae
SHA1 (patch-inc_core_class.dc.core.php) = 045d6a2d9a629a9f9bcc098223df0f999a521f30
SHA1 (patch-inc_load__plugin__file.php) = d6fea3a2a5c1243a3d220e6813ffdfb8d1092aaa
SHA1 (patch-inc_prepend.php) = 0261d9ea250190a7bb63e0790ff1d4fb46877313

View file

@ -1,10 +1,10 @@
$NetBSD: patch-admin_install_index.php,v 1.1 2021/06/24 02:32:28 triaxx Exp $
$NetBSD: patch-admin_install_index.php,v 1.2 2022/01/25 08:31:38 triaxx Exp $
Honor PKG_SYSCONFDIR.
--- admin/install/index.php.orig 2021-02-13 10:31:06.000000000 +0000
+++ admin/install/index.php
@@ -12,7 +12,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
@@ -11,7 +11,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
} elseif (isset($_SERVER['REDIRECT_DC_RC_PATH'])) {
$rc_path = $_SERVER['REDIRECT_DC_RC_PATH'];
} else {

View file

@ -1,11 +1,11 @@
$NetBSD: patch-admin_install_wizard.php,v 1.1 2021/06/24 02:32:28 triaxx Exp $
$NetBSD: patch-admin_install_wizard.php,v 1.2 2022/01/25 08:31:38 triaxx Exp $
Honor PKG_SYSCONFDIR.
Set pkgsrc compliant directories for SQLite database.
--- admin/install/wizard.php.orig 2021-02-13 10:31:06.000000000 +0000
--- admin/install/wizard.php.orig 2021-11-19 12:51:15.000000000 +0000
+++ admin/install/wizard.php
@@ -12,7 +12,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
@@ -11,7 +11,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
} elseif (isset($_SERVER['REDIRECT_DC_RC_PATH'])) {
define('DC_RC_PATH', $_SERVER['REDIRECT_DC_RC_PATH']);
} else {
@ -14,8 +14,8 @@ Set pkgsrc compliant directories for SQLite database.
}
# ClearBricks and DotClear classes auto-loader
@@ -63,7 +63,7 @@ if (!empty($_POST)) {
{
@@ -61,7 +61,7 @@ if (!empty($_POST)) {
try {
if ($DBDRIVER == 'sqlite') {
if (strpos($DBNAME, '/') === false) {
- $sqlite_db_directory = dirname(DC_RC_PATH) . '/../db/';
@ -23,7 +23,7 @@ Set pkgsrc compliant directories for SQLite database.
files::makeDir($sqlite_db_directory, true);
# Can we write sqlite_db_directory ?
@@ -99,7 +99,7 @@ if (!empty($_POST)) {
@@ -98,7 +98,7 @@ if (!empty($_POST)) {
}
# Does config.php.in exist?

View file

@ -1,11 +1,11 @@
$NetBSD: patch-inc_config.php.in,v 1.1 2021/06/24 02:32:28 triaxx Exp $
$NetBSD: patch-inc_config.php.in,v 1.2 2022/01/25 08:31:38 triaxx Exp $
Set pkgsrc compliant directories for plugins, cache, var and logs.
Disable update checking.
--- inc/config.php.in.orig 2021-02-13 10:31:06.000000000 +0000
+++ inc/config.php.in
@@ -45,13 +45,13 @@ define('DC_SESSION_NAME', 'dcxd');
@@ -47,13 +47,13 @@ define('DC_SESSION_NAME', 'dcxd');
//define('DC_SESSION_TTL','120 seconds');
// Plugins root
@ -22,7 +22,7 @@ Disable update checking.
// Cryptographic algorithm
define('DC_CRYPT_ALGO', 'sha512');
@@ -60,7 +60,7 @@ define('DC_CRYPT_ALGO', 'sha512');
@@ -62,7 +62,7 @@ define('DC_CRYPT_ALGO', 'sha512');
//define('DC_VENDOR_NAME', 'Dotclear');
// Do not check for update
@ -31,7 +31,7 @@ Disable update checking.
// Update URL
//define('DC_UPDATE_URL','https://download.dotclear.org/versions.xml');
@@ -91,3 +91,6 @@ define('DC_CRYPT_ALGO', 'sha512');
@@ -96,3 +96,6 @@ define('DC_CRYPT_ALGO', 'sha512');
// socketMail::$smtp_relay = 'my.smtp.relay.org';
// socketMail::mail($to, $subject, $message, $headers);
//}

View file

@ -1,10 +1,10 @@
$NetBSD: patch-inc_core_class.dc.core.php,v 1.1 2021/06/24 02:32:28 triaxx Exp $
$NetBSD: patch-inc_core_class.dc.core.php,v 1.2 2022/01/25 08:31:38 triaxx Exp $
Set pkgsrc compliant directory for /public.
--- inc/core/class.dc.core.php.orig 2021-02-13 10:31:06.000000000 +0000
+++ inc/core/class.dc.core.php
@@ -1445,7 +1445,7 @@ class dcCore
@@ -1564,7 +1564,7 @@ class dcCore
'Number of comments on feeds'],
['post_url_format', 'string', '{y}/{m}/{d}/{t}',
'Post URL format. {y}: year, {m}: month, {d}: day, {id}: post id, {t}: entry title'],

View file

@ -1,10 +1,10 @@
$NetBSD: patch-inc_load__plugin__file.php,v 1.1 2021/06/24 02:32:28 triaxx Exp $
$NetBSD: patch-inc_load__plugin__file.php,v 1.2 2022/01/25 08:31:38 triaxx Exp $
Honor PKG_SYSCONFDIR.
--- inc/load_plugin_file.php.orig 2021-02-13 10:31:06.000000000 +0000
+++ inc/load_plugin_file.php
@@ -26,7 +26,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
@@ -25,7 +25,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
} elseif (isset($_SERVER['REDIRECT_DC_RC_PATH'])) {
define('DC_RC_PATH', $_SERVER['REDIRECT_DC_RC_PATH']);
} else {

View file

@ -1,10 +1,10 @@
$NetBSD: patch-inc_prepend.php,v 1.1 2021/06/24 02:32:28 triaxx Exp $
$NetBSD: patch-inc_prepend.php,v 1.2 2022/01/25 08:31:38 triaxx Exp $
Honor PKG_SYSCONFDIR.
--- inc/prepend.php.orig 2021-02-13 10:32:13.000000000 +0000
+++ inc/prepend.php
@@ -117,7 +117,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
@@ -127,7 +127,7 @@ if (isset($_SERVER['DC_RC_PATH'])) {
} elseif (isset($_SERVER['REDIRECT_DC_RC_PATH'])) {
define('DC_RC_PATH', $_SERVER['REDIRECT_DC_RC_PATH']);
} else {