Update oaf to 0.6.6, and while at it, buildlinkify. Changes include:
* fixes to avoid multiple oafd's running * error reporting fixes * build fixes * robustness improvements
This commit is contained in:
parent
52a0edf949
commit
cad317ebf2
14 changed files with 89 additions and 164 deletions
|
@ -1,22 +1,38 @@
|
|||
# $NetBSD: Makefile,v 1.10 2001/06/11 06:34:29 jlam Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2001/10/01 11:01:02 rh Exp $
|
||||
#
|
||||
|
||||
DISTNAME= oaf-0.6.5
|
||||
DISTNAME= oaf-0.6.6
|
||||
CATEGORIES= devel gnome
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=unstable/sources/oaf/}
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=stable/sources/oaf/}
|
||||
EXTRACT_SUFX= .tar.bz2
|
||||
|
||||
MAINTAINER= rh@netbsd.org
|
||||
HOMEPAGE= http://www.gnome.org/
|
||||
COMMENT= new object activation framework for GNOME
|
||||
|
||||
DEPENDS+= gnome-libs>=1.2.3:../../x11/gnome-libs
|
||||
DEPENDS+= libxml>=1.8.10:../../textproc/libxml
|
||||
|
||||
GNU_CONFIGURE= YES
|
||||
USE_BUILDLINK_ONLY= YES
|
||||
USE_X11BASE= YES
|
||||
USE_LIBTOOL= YES
|
||||
|
||||
LTCONFIG_OVERRIDE= ${WRKSRC}/ltconfig
|
||||
CPPFLAGS+= -I${X11PREFIX}/include -I${LOCALBASE}/include
|
||||
|
||||
#
|
||||
# use of orbit/buildlink.mk (pulled in via gnome-libs) causes the
|
||||
# buildlink location for orbit-config to be entered in the configure
|
||||
# scripts. Fix by replacing @ORBIT_CONFIG@ before GNU configure has
|
||||
# a chance to touch it.
|
||||
#
|
||||
pre-configure:
|
||||
.for cfg in oafConf.sh.in oaf-config.in
|
||||
cd ${WRKSRC} && \
|
||||
${CP} ${cfg} ${cfg}.old && \
|
||||
${SED} < ${cfg}.old > ${cfg} \
|
||||
-e 's|@ORBIT_CONFIG@|${LOCALBASE}/bin/orbit-config|g'
|
||||
.endfor
|
||||
|
||||
.include "../../textproc/libxml/buildlink.mk"
|
||||
.include "../../x11/gnome-libs/buildlink.mk"
|
||||
.include "../../devel/popt/buildlink.mk"
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
49
devel/oaf/buildlink.mk
Normal file
49
devel/oaf/buildlink.mk
Normal file
|
@ -0,0 +1,49 @@
|
|||
# $NetBSD: buildlink.mk,v 1.1 2001/10/01 11:01:03 rh Exp $
|
||||
#
|
||||
# This Makefile fragment is included by packages that use oaf.
|
||||
#
|
||||
# To use this Makefile fragment, simply:
|
||||
#
|
||||
# (1) Optionally define BUILDLINK_DEPENDS.oaf to the dependency patthern
|
||||
# for the version of oaf desired.
|
||||
# (2) Include this Makefile fragment in the package Makefile,
|
||||
# (3) Add ${BUILDLINK_DIR}/include to the front of the C preprocessor's header
|
||||
# search path, and
|
||||
# (4) Add ${BUILDLINK_DIR}/lib to the front of the linker's library search
|
||||
# path.
|
||||
|
||||
.if !defined(OAF_BUILDLINK_MK)
|
||||
OAF_BUILDLINK_MK= # defined
|
||||
|
||||
.include "../../mk/bsd.buildlink.mk"
|
||||
|
||||
BUILDLINK_DEPENDS.oaf?= oaf>=0.6.6
|
||||
DEPENDS+= ${BUILDLINK_DEPENDS.oaf}:../../textproc/oaf
|
||||
|
||||
EVAL_PREFIX+= BUILDLINK_PREFIX.oaf=oaf
|
||||
BUILDLINK_PREFIX.oaf_DEFAULT= ${LOCALBASE}
|
||||
BUILDLINK_FILES.oaf= include/liboaf/*
|
||||
BUILDLINK_FILES.oaf+= lib/liboaf.*
|
||||
BUILDLINK_FILES.oaf+= lib/oafConf.sh
|
||||
|
||||
.include "../../textproc/libxml/buildlink.mk"
|
||||
.include "../../x11/gnome-libs/buildlink.mk"
|
||||
|
||||
BUILDLINK_TARGETS.oaf= oaf-buildlink
|
||||
BUILDLINK_TARGETS.oaf+= oaf-buildlink-config-wrapper
|
||||
BUILDLINK_TARGETS+= ${BUILDLINK_TARGETS.oaf}
|
||||
|
||||
BUILDLINK_CONFIG.oaf= ${BUILDLINK_PREFIX.oaf}/bin/oaf-config
|
||||
BUILDLINK_CONFIG_WRAPPER.oaf=${BUILDLINK_DIR}/bin/oaf-config
|
||||
|
||||
.if defined(USE_CONFIG_WRAPPER)
|
||||
OAF_CONFIG?= ${BUILDLINK_CONFIG_WRAPPER.oaf}
|
||||
CONFIGURE_ENV+= OAF_CONFIG="${OAF_CONFIG}"
|
||||
MAKE_ENV+= OAF_CONFIG="${OAF_CONFIG}"
|
||||
.endif
|
||||
|
||||
pre-configure: ${BUILDLINK_TARGETS.oaf}
|
||||
oaf-buildlink: _BUILDLINK_USE
|
||||
oaf-buildlink-config-wrapper: _BUILDLINK_CONFIG_WRAPPER_USE
|
||||
|
||||
.endif # OAF_BUILDLINK_MK
|
|
@ -1,15 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.2 2001/04/21 00:44:33 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.3 2001/10/01 11:01:03 rh Exp $
|
||||
|
||||
SHA1 (oaf-0.6.5.tar.gz) = 50a78e04ceedb16591cb4f03ee63ee28c53a5b1c
|
||||
Size (oaf-0.6.5.tar.gz) = 454586 bytes
|
||||
SHA1 (patch-aa) = 19bd9038ffb933630c3d8040d7a34a54112814bb
|
||||
SHA1 (patch-ab) = db5966e5e649315b96f99e3aeb06a55dd2582ed5
|
||||
SHA1 (oaf-0.6.6.tar.bz2) = 7901f68362c7decc2b6c964dd319c31cddbd4096
|
||||
Size (oaf-0.6.6.tar.bz2) = 393159 bytes
|
||||
SHA1 (patch-ac) = aab19adb68c1969f7714e6ee0fe918e1905bd60d
|
||||
SHA1 (patch-ad) = f1aef87562f3c91ca91bdf342cbbb96ec3cfb369
|
||||
SHA1 (patch-ae) = c7e4ba6dad4efc1b52a4c6551a0ea925cc912d6e
|
||||
SHA1 (patch-af) = ccae84893cd2a244f921481c28cdf9874dff15bb
|
||||
SHA1 (patch-ag) = 2457347d0414293cdd36e7771daba55ea80c3c60
|
||||
SHA1 (patch-ah) = 1aff198b6e76ef78898dd94cfb34750b1fb585f0
|
||||
SHA1 (patch-ai) = 95a69011734d150c43c0c73a55d2b367e0d17491
|
||||
SHA1 (patch-aj) = 914ba4a795b47a3bea0284ff36967fc505b01878
|
||||
SHA1 (patch-ak) = c4c667324b955f3b45995c99b317a1b97af18f0b
|
||||
SHA1 (patch-ad) = ef16360bc1f0549ee75969eb6742d884220fb04d
|
||||
SHA1 (patch-ag) = b121bc495f623529080c88a95b707b2b4796e5f9
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aa,v 1.3 2000/08/31 05:39:56 rh Exp $
|
||||
|
||||
--- oafd/Makefile.in.orig Tue Aug 29 17:05:15 2000
|
||||
+++ oafd/Makefile.in
|
||||
@@ -248,7 +248,7 @@
|
||||
|
||||
oafd: $(oafd_OBJECTS) $(oafd_DEPENDENCIES)
|
||||
@rm -f oafd
|
||||
- $(LINK) $(oafd_LDFLAGS) $(oafd_OBJECTS) $(oafd_LDADD) $(LIBS)
|
||||
+ $(LINK) $(oafd_LDFLAGS) $(oafd_OBJECTS) $(oafd_LDADD) $(LIBS) ${INTLLIBS}
|
||||
|
||||
oaf-client: $(oaf_client_OBJECTS) $(oaf_client_DEPENDENCIES)
|
||||
@rm -f oaf-client
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ab,v 1.1.1.1 2000/07/16 19:44:18 rh Exp $
|
||||
|
||||
--- liboaf/oaf-mainloop.c.orig Wed May 31 14:14:53 2000
|
||||
+++ liboaf/oaf-mainloop.c Sun Jul 16 20:33:37 2000
|
||||
@@ -15,7 +15,7 @@
|
||||
#include <stdlib.h>
|
||||
|
||||
#include <glib.h>
|
||||
-#include <popt.h>
|
||||
+#include <popt-gnome.h>
|
||||
|
||||
/****************** ORBit-specific stuff ****************/
|
||||
|
|
@ -1,14 +1,12 @@
|
|||
$NetBSD: patch-ad,v 1.4 2001/04/06 21:55:40 rh Exp $
|
||||
$NetBSD: patch-ad,v 1.5 2001/10/01 11:01:03 rh Exp $
|
||||
|
||||
--- oafd/main.c.orig Wed Feb 21 10:50:43 2001
|
||||
--- oafd/main.c.orig Tue Jul 24 00:50:25 2001
|
||||
+++ oafd/main.c
|
||||
@@ -37,7 +37,8 @@
|
||||
@@ -37,6 +37,7 @@
|
||||
#include <sys/types.h>
|
||||
#include <sys/stat.h>
|
||||
#include <fcntl.h>
|
||||
-#include <popt.h>
|
||||
+#include <locale.h>
|
||||
+#include <popt-gnome.h>
|
||||
#include <popt.h>
|
||||
#include <signal.h>
|
||||
#include <stdlib.h>
|
||||
#include <unistd.h>
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ae,v 1.1.1.1 2000/07/16 19:44:18 rh Exp $
|
||||
|
||||
--- oafd/client.c.orig Tue May 30 12:29:28 2000
|
||||
+++ oafd/client.c Sun Jul 16 20:33:37 2000
|
||||
@@ -4,7 +4,7 @@
|
||||
#include "liboaf/liboaf-private.h"
|
||||
#include "oafd.h"
|
||||
#include <stdio.h>
|
||||
-#include <popt.h>
|
||||
+#include <popt-gnome.h>
|
||||
|
||||
static char *acior = NULL, *specs = NULL;
|
||||
static int do_query;
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-af,v 1.1.1.1 2000/07/16 19:44:18 rh Exp $
|
||||
|
||||
--- test/empty-server.c.orig Tue May 30 12:29:28 2000
|
||||
+++ test/empty-server.c Sun Jul 16 20:33:37 2000
|
||||
@@ -4,7 +4,7 @@
|
||||
#include <string.h>
|
||||
#include <signal.h>
|
||||
#include <orb/orbit.h>
|
||||
-#include <popt.h>
|
||||
+#include <popt-gnome.h>
|
||||
#include "empty.h"
|
||||
#include "liboaf/liboaf.h"
|
||||
|
|
@ -1,8 +1,8 @@
|
|||
$NetBSD: patch-ag,v 1.4 2001/04/06 21:55:40 rh Exp $
|
||||
$NetBSD: patch-ag,v 1.5 2001/10/01 11:01:04 rh Exp $
|
||||
|
||||
--- configure.orig Fri Mar 2 04:16:10 2001
|
||||
--- configure.orig Tue Aug 21 07:45:23 2001
|
||||
+++ configure
|
||||
@@ -3633,7 +3633,7 @@
|
||||
@@ -7215,7 +7215,7 @@
|
||||
cat conftest.$ac_ext >&5
|
||||
rm -rf conftest*
|
||||
CATOBJEXT=.mo
|
||||
|
@ -11,36 +11,7 @@ $NetBSD: patch-ag,v 1.4 2001/04/06 21:55:40 rh Exp $
|
|||
fi
|
||||
rm -f conftest*
|
||||
INSTOBJEXT=.mo
|
||||
@@ -4744,8 +4744,8 @@
|
||||
|
||||
|
||||
|
||||
-echo $ac_n "checking for poptGetContext in -lpopt""... $ac_c" 1>&6
|
||||
-echo "configure:4749: checking for poptGetContext in -lpopt" >&5
|
||||
+echo $ac_n "checking for poptGetContext in -lgnomesupport""... $ac_c" 1>&6
|
||||
+echo "configure:4749: checking for poptGetContext in -lgnomesupport" >&5
|
||||
ac_lib_var=`echo popt'_'poptGetContext | sed 'y%./+-%__p_%'`
|
||||
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
|
||||
echo $ac_n "(cached) $ac_c" 1>&6
|
||||
@@ -4764,7 +4764,7 @@
|
||||
poptGetContext()
|
||||
; return 0; }
|
||||
EOF
|
||||
-if { (eval echo configure:4768: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
|
||||
+if true; then
|
||||
rm -rf conftest*
|
||||
eval "ac_cv_lib_$ac_lib_var=yes"
|
||||
else
|
||||
@@ -4785,7 +4785,7 @@
|
||||
#define $ac_tr_lib 1
|
||||
EOF
|
||||
|
||||
- LIBS="-lpopt $LIBS"
|
||||
+LIBS="$LIBS -lgnomesupport"
|
||||
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
@@ -5238,7 +5238,6 @@
|
||||
@@ -8825,7 +8825,6 @@
|
||||
-Wall \
|
||||
-Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes \
|
||||
-Wnested-externs -Wpointer-arith \
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ah,v 1.1 2000/08/29 16:26:20 rh Exp $
|
||||
|
||||
--- utils/oaf-sysconf.c.orig Tue Aug 29 17:09:21 2000
|
||||
+++ utils/oaf-sysconf.c
|
||||
@@ -29,7 +29,7 @@
|
||||
#include <tree.h> /* gnome-xml */
|
||||
#include <parser.h> /* gnome-xml */
|
||||
#include <xmlmemory.h> /* gnome-xml */
|
||||
-#include <popt.h> /* popt :) */
|
||||
+#include <popt-gnome.h>
|
||||
#include "od-utils.h"
|
||||
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ai,v 1.1 2000/08/29 16:26:20 rh Exp $
|
||||
|
||||
--- utils/Makefile.in.orig Tue Aug 29 17:11:43 2000
|
||||
+++ utils/Makefile.in
|
||||
@@ -226,7 +226,7 @@
|
||||
|
||||
oaf-sysconf: $(oaf_sysconf_OBJECTS) $(oaf_sysconf_DEPENDENCIES)
|
||||
@rm -f oaf-sysconf
|
||||
- $(LINK) $(oaf_sysconf_LDFLAGS) $(oaf_sysconf_OBJECTS) $(oaf_sysconf_LDADD) $(LIBS)
|
||||
+ $(LINK) $(oaf_sysconf_LDFLAGS) $(oaf_sysconf_OBJECTS) $(oaf_sysconf_LDADD) $(LIBS) ${INTLLIBS}
|
||||
|
||||
tags: TAGS
|
||||
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-aj,v 1.2 2001/04/06 21:55:40 rh Exp $
|
||||
|
||||
--- test/Makefile.in.orig Fri Mar 2 04:16:48 2001
|
||||
+++ test/Makefile.in
|
||||
@@ -468,7 +468,7 @@
|
||||
touch empty_built
|
||||
|
||||
oaf-slay: $(srcdir)/oaf-slay.tmpl
|
||||
- sed 's|@oafdir@|'$(pkgdatadir)'|g' < $< > $@
|
||||
+ sed 's|@oafdir@|'$(pkgdatadir)'|g' < $(srcdir)/oaf-slay.tmpl > $@
|
||||
|
||||
check:
|
||||
OAF_INFO_PATH="$(top_srcdir)/test:$$OAF_INFO_PATH" PATH="$(top_builddir)/test:$$PATH" $(top_builddir)/test/oaf-test-client
|
|
@ -1,13 +0,0 @@
|
|||
$NetBSD: patch-ak,v 1.1 2001/04/06 21:55:40 rh Exp $
|
||||
|
||||
--- liboaf/oaf-mainloop.h.orig Thu Apr 5 16:03:39 2001
|
||||
+++ liboaf/oaf-mainloop.h
|
||||
@@ -26,7 +26,7 @@
|
||||
#ifndef OAF_MAINLOOP_H
|
||||
#define OAF_MAINLOOP_H
|
||||
|
||||
-#include <popt.h>
|
||||
+#include <popt-gnome.h>
|
||||
|
||||
CORBA_ORB oaf_orb_init (int *argc,
|
||||
char **argv);
|
|
@ -1,8 +1,9 @@
|
|||
@comment $NetBSD: PLIST,v 1.5 2001/04/06 21:55:40 rh Exp $
|
||||
@comment $NetBSD: PLIST,v 1.6 2001/10/01 11:01:04 rh Exp $
|
||||
bin/oafd
|
||||
bin/oaf-client
|
||||
bin/oaf-run-query
|
||||
bin/oaf-config
|
||||
bin/oaf-empty-server
|
||||
bin/oaf-slay
|
||||
bin/oaf-sysconf
|
||||
etc/oaf/oaf-config.xml
|
||||
|
@ -24,7 +25,6 @@ lib/liboaf.so
|
|||
lib/liboaf.so.0
|
||||
lib/liboaf.so.0.0
|
||||
lib/liboaf.la
|
||||
lib/liboaf.a
|
||||
lib/oafConf.sh
|
||||
share/aclocal/oaf.m4
|
||||
share/idl/oaf.idl
|
||||
|
@ -40,6 +40,7 @@ share/locale/hu/LC_MESSAGES/oaf.mo
|
|||
share/locale/it/LC_MESSAGES/oaf.mo
|
||||
share/locale/ja/LC_MESSAGES/oaf.mo
|
||||
share/locale/ko/LC_MESSAGES/oaf.mo
|
||||
share/locale/nn/LC_MESSAGES/oaf.mo
|
||||
share/locale/no/LC_MESSAGES/oaf.mo
|
||||
share/locale/pl/LC_MESSAGES/oaf.mo
|
||||
share/locale/pt_BR/LC_MESSAGES/oaf.mo
|
||||
|
@ -48,8 +49,10 @@ share/locale/ru/LC_MESSAGES/oaf.mo
|
|||
share/locale/sk/LC_MESSAGES/oaf.mo
|
||||
share/locale/sl/LC_MESSAGES/oaf.mo
|
||||
share/locale/sv/LC_MESSAGES/oaf.mo
|
||||
share/locale/ta/LC_MESSAGES/oaf.mo
|
||||
share/locale/tr/LC_MESSAGES/oaf.mo
|
||||
share/locale/uk/LC_MESSAGES/oaf.mo
|
||||
share/locale/zh_TW.Big5/LC_MESSAGES/oaf.mo
|
||||
share/oaf/OAF_naming-service.oaf
|
||||
share/oaf/empty.oafinfo
|
||||
@exec mkdir -p %D/share/oaf/html/liboaf
|
||||
|
|
Loading…
Reference in a new issue