Added a fix for the recent bulk build on NetBSD 3.0.

This commit is contained in:
rillig 2006-06-26 11:30:05 +00:00
parent 926954e283
commit cae1eb7cb3
2 changed files with 23 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.6 2006/05/11 17:59:57 joerg Exp $
$NetBSD: distinfo,v 1.7 2006/06/26 11:30:05 rillig Exp $
SHA1 (vls-0.5.6/vls-0.5.6.tar.gz) = f61acab2d1b9093677de516b63aef534b0cd81b7
RMD160 (vls-0.5.6/vls-0.5.6.tar.gz) = 5fdcd718db4caa624ad092c4cdddca2fc62b0d15
@ -12,3 +12,4 @@ SHA1 (patch-af) = 5cda5b979012a143345f179c9f95c4e2c709e59f
SHA1 (patch-ag) = 9c45a5be74f46c67caca043a28de7d36bfc9564c
SHA1 (patch-ah) = e3936ced3b16e97a242102f525dfb0bbfd11d33f
SHA1 (patch-ai) = 4fdebf473eb5be7937ef8e5ac7d63e474b9418b3
SHA1 (patch-aj) = 9e8255f4c45c74a241333511358ca8f14898f2da

View file

@ -0,0 +1,21 @@
$NetBSD: patch-aj,v 1.1 2006/06/26 11:30:06 rillig Exp $
libdvdread needs the definitions from <inttypes.h>.
--- src/modules/dvdreader/dvdreader.cpp.orig 2002-09-04 12:56:34.000000000 +0200
+++ src/modules/dvdreader/dvdreader.cpp 2006-06-26 13:27:52.000000000 +0200
@@ -30,6 +30,14 @@
//------------------------------------------------------------------------------
#include "../../core/defs.h"
+#define __STDC_LIMIT_MACROS
+#if defined(HAVE_INTTYPES_H)
+# include <inttypes.h>
+#endif
+#if defined(HAVE_STDINT_H)
+# include <stdint.h>
+#endif
+
#include "../../core/core.h"
#include "../../core/iso_lang.h"