Include config.h before kdemacro.h gets (indirectly) included.

Otherwise KDE_EXPORT doesn't get correctly defined, resulting in
link errors with visibility-enabled compilers.
This commit is contained in:
joerg 2006-06-28 16:04:06 +00:00
parent 1ddaeb733e
commit cae62889df
3 changed files with 33 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.5 2005/10/09 12:33:58 markd Exp $
$NetBSD: distinfo,v 1.6 2006/06/28 16:04:06 joerg Exp $
SHA1 (kmymoney2-0.8.tar.bz2) = 5e46cbf04b34a495433d9a1582a607ef2b4ef086
RMD160 (kmymoney2-0.8.tar.bz2) = 53337e1f48ea3cad74328640302348257005e148
@ -7,3 +7,5 @@ SHA1 (patch-aa) = 742f6b67c3f9de966f0441c5c5dd16fd8fcc28e3
SHA1 (patch-ab) = b5c39f7e35b70304abfc2f8c9a9d438031e16631
SHA1 (patch-ac) = 8cbc58fd79822705c7e672a5caced50ae8894c0a
SHA1 (patch-ad) = 9cf0fe5efe66e3734b5410116977f7998969025a
SHA1 (patch-ae) = 3466df88f68535549172e253ad24142ef1149360
SHA1 (patch-af) = 9228789b4d601a22d77fe7b41e04fa08a068040c

View file

@ -0,0 +1,15 @@
$NetBSD: patch-ae,v 1.3 2006/06/28 16:04:06 joerg Exp $
--- kmymoney2/mymoney/mymoneystatement.cpp.orig 2006-06-28 15:49:24.000000000 +0000
+++ kmymoney2/mymoney/mymoneystatement.cpp
@@ -21,6 +21,10 @@
* *
***************************************************************************/
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
// ----------------------------------------------------------------------------
// QT Includes

View file

@ -0,0 +1,15 @@
$NetBSD: patch-af,v 1.3 2006/06/28 16:04:06 joerg Exp $
--- kmymoney2/plugins/kmymoneyplugin.cpp.orig 2006-06-28 15:53:31.000000000 +0000
+++ kmymoney2/plugins/kmymoneyplugin.cpp
@@ -15,6 +15,10 @@
* *
***************************************************************************/
+#ifdef HAVE_CONFIG_H
+#include <config.h>
+#endif
+
// ----------------------------------------------------------------------------
// QT Includes