net/fstrm: update to version 0.6.1.
pkgsrc changes: * Remove patch integrated upstream. Upstream changes: fstrm (0.6.1) * fstrm_capture: ignore SIGPIPE, which will cause the interrupted connections to generate an EPIPE instead. * Fix truncation in snprintf calls in argument processing. * fstrm_capture: Fix output printf format.
This commit is contained in:
parent
0ac18c3d1c
commit
caf58f14d9
3 changed files with 6 additions and 32 deletions
|
@ -1,7 +1,6 @@
|
|||
# $NetBSD: Makefile,v 1.8 2020/01/18 21:50:13 jperkin Exp $
|
||||
# $NetBSD: Makefile,v 1.9 2022/09/18 12:11:28 he Exp $
|
||||
|
||||
DISTNAME= fstrm-0.6.0
|
||||
PKGREVISION= 3
|
||||
DISTNAME= fstrm-0.6.1
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ${MASTER_SITE_GITHUB:=farsightsec/}
|
||||
GITHUB_TAG= v${PKGVERSION_NOREV}
|
||||
|
|
|
@ -1,6 +1,5 @@
|
|||
$NetBSD: distinfo,v 1.6 2021/10/26 11:05:37 nia Exp $
|
||||
$NetBSD: distinfo,v 1.7 2022/09/18 12:11:28 he Exp $
|
||||
|
||||
BLAKE2s (fstrm-0.6.0.tar.gz) = dcf37fac44a1b8980eb913f45b9ef3175321cdb1d233a6fc178251f4d9d3d073
|
||||
SHA512 (fstrm-0.6.0.tar.gz) = 8e327f40fb49b36998d8bb9353b30b9924630b85adf1e4462ce4b456daa7eea727892a59f43ddd48de5bf5059a450fef54726b09af6d7f210fa182c4055d65f4
|
||||
Size (fstrm-0.6.0.tar.gz) = 135214 bytes
|
||||
SHA1 (patch-libmy_argv.c) = 1caf771043eb6648a04da402c33607744542cb04
|
||||
BLAKE2s (fstrm-0.6.1.tar.gz) = 1147d82b3f969014052d78313c20ecce31beb251884ec7515f0461a8b437c466
|
||||
SHA512 (fstrm-0.6.1.tar.gz) = 7bf2728e2d0d1fdbd4e93069ddb03a01dc56909dbac57650ed530c80f761170b257c7191a3d789d4661df1f09c15594f20ec93a4eb5e5deb7ea3a7eabe56806c
|
||||
Size (fstrm-0.6.1.tar.gz) = 135425 bytes
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
$NetBSD: patch-libmy_argv.c,v 1.1 2019/12/16 12:52:23 he Exp $
|
||||
|
||||
Include space for the terminating 0 character.
|
||||
|
||||
--- libmy/argv.c.orig 2019-10-14 16:25:11.000000000 +0000
|
||||
+++ libmy/argv.c
|
||||
@@ -482,7 +482,7 @@ static int expand_buf(const void *buf, c
|
||||
if (out_p + 2 >= max_p) {
|
||||
break;
|
||||
}
|
||||
- LOC_SNPRINTF(SNP_ARG(out_p, 2), "\\%c", *(spec_p - 1));
|
||||
+ LOC_SNPRINTF(SNP_ARG(out_p, 3), "\\%c", *(spec_p - 1));
|
||||
out_p += 2;
|
||||
continue;
|
||||
}
|
||||
@@ -499,7 +499,7 @@ static int expand_buf(const void *buf, c
|
||||
if (out_p + 4 >= max_p) {
|
||||
break;
|
||||
}
|
||||
- LOC_SNPRINTF(SNP_ARG(out_p, 4), "\\%03o", *buf_p);
|
||||
+ LOC_SNPRINTF(SNP_ARG(out_p, 5), "\\%03o", *buf_p);
|
||||
out_p += 4;
|
||||
}
|
||||
}
|
Loading…
Reference in a new issue