add some patches from FreeBSD Ports, and tidy up patching of

make.texi.
This commit is contained in:
grant 2003-02-21 12:40:54 +00:00
parent b02ca0c12d
commit caf75551b9
6 changed files with 77 additions and 7 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.42 2002/12/23 20:30:43 wiz Exp $
# $NetBSD: Makefile,v 1.43 2003/02/21 12:40:54 grant Exp $
DISTNAME= make-3.80
PKGNAME= gmake-3.80
@ -30,11 +30,6 @@ PLIST_SUBST+= GMAKE_LINK=""
PLIST_SUBST+= GMAKE_LINK="@comment "
.endif
post-extract:
${MV} ${WRKSRC}/doc/make.texi ${WRKSRC}/doc/make.texi.orig
${SED} '/@dircategory/s|.*|@dircategory Programming \& development tools|' \
< ${WRKSRC}/doc/make.texi.orig > ${WRKSRC}/doc/make.texi
post-install:
${CHMOD} g-s ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make
${CHGRP} ${BINGRP} ${PREFIX}/bin/${GNU_PROGRAM_PREFIX}make

View file

@ -1,5 +1,9 @@
$NetBSD: distinfo,v 1.7 2002/11/30 14:47:35 grant Exp $
$NetBSD: distinfo,v 1.8 2003/02/21 12:40:54 grant Exp $
SHA1 (make-3.80.tar.gz) = 12cd7822d9cd7c1f12cc50df87366ec61915a277
Size (make-3.80.tar.gz) = 1211924 bytes
SHA1 (patch-aa) = 43de674c2c3eca8f5119165c95fc1ff5a3b91b06
SHA1 (patch-ab) = 59751764c52ddf339b40fe32fe271980aa8ebf0b
SHA1 (patch-ac) = 6362dee903d013d4f1d0c3e81bd15107fe796a5b
SHA1 (patch-ad) = 7874662cb9345c4107fcc2aab7184ccd4c93090d
SHA1 (patch-ae) = 7baeabf65a5ceee682134edf90654c53bfb9ee11

View file

@ -0,0 +1,13 @@
$NetBSD: patch-aa,v 1.9 2003/02/21 12:40:54 grant Exp $
--- make.h.orig Thu Sep 12 02:55:44 2002
+++ make.h
@@ -33,7 +33,7 @@ Boston, MA 02111-1307, USA. */
# ifdef _AIX
#pragma alloca
# else
-# ifndef alloca /* predefined by HP cc +Olibcalls */
+# if !defined (alloca) && !defined (__FreeBSD__) /* predefined by HP cc +Olibcalls, part of stdlib.h on FreeBSD */
char *alloca ();
# endif
# endif

View file

@ -0,0 +1,16 @@
$NetBSD: patch-ab,v 1.8 2003/02/21 12:40:55 grant Exp $
--- doc/make.texi.orig Thu Sep 19 06:51:58 2002
+++ doc/make.texi
@@ -25,9 +25,9 @@
@c Combine the program and concept indices:
@syncodeindex pg cp
-@dircategory GNU Packages
+@dircategory Programming & development tools
@direntry
-* Make: (make). Remake files automatically.
+* GNU make: (make). Remake files automatically.
@end direntry
@ifinfo

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ac,v 1.4 2003/02/21 12:40:55 grant Exp $
--- glob/glob.c.orig Sat Jan 22 16:43:03 2000
+++ glob/glob.c
@@ -215,13 +215,13 @@ my_realloc (p, n)
# ifdef HAVE_ALLOCA_H
# include <alloca.h>
# else /* Not HAVE_ALLOCA_H. */
-# ifndef _AIX
+# if !defined (_AIX) && !defined (__FreeBSD__)
# ifdef WINDOWS32
# include <malloc.h>
# else
extern char *alloca ();
# endif /* WINDOWS32 */
-# endif /* Not _AIX. */
+# endif /* Not _AIX && not __FreeBSD__. */
# endif /* sparc or HAVE_ALLOCA_H. */
# endif /* GCC. */

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ad,v 1.4 2003/02/21 12:40:55 grant Exp $
--- glob/glob.h.orig Sat Jan 22 16:43:03 2000
+++ glob/glob.h
@@ -47,6 +47,9 @@ extern "C" {
/* We need `size_t' for the following definitions. */
#ifndef __size_t
+#if defined __FreeBSD__
+#define __size_t size_t
+#else
# if defined __GNUC__ && __GNUC__ >= 2
typedef __SIZE_TYPE__ __size_t;
# else
@@ -59,6 +62,7 @@ typedef __SIZE_TYPE__ __size_t;
*/
#if !(defined __DECC && defined __SIZE_T)
typedef unsigned long int __size_t;
+#endif
#endif
# endif
#else