Update to scmgit-1.6.0.2. In pkgsrc, in Makefile.common .include,
change ${.CURDIR}/../... to ../../devel/scmgit/...; makes a lot more sense. Fixes since v1.6.0.1 -------------------- * Installation on platforms that needs .exe suffix to git-* programs were broken in 1.6.0.1. * Installation on filesystems without symbolic links support did nto work well. * In-tree documentations and test scripts now use "git foo" form to set a better example, instead of the "git-foo" form (which is an acceptable form if you have "PATH=$(git --exec-path):$PATH" in your script) * Many commands did not use the correct working tree location when used with GIT_WORK_TREE environment settings. * Some systems needs to use compatibility fnmach and regex libraries independent from each other; the compat/ area has been reorganized to allow this. * "git apply --unidiff-zero" incorrectly applied a -U0 patch that inserts a new line before the second line. * "git blame -c" did not exactly work like "git annotate" when range boundaries are involved. * "git checkout file" when file is still unmerged checked out contents from a random high order stage, which was confusing. * "git clone $there $here/" with extra trailing slashes after explicit local directory name $here did not work as expected. * "git diff" on tracked contents with CRLF line endings did not drive "less" intelligently when showing added or removed lines. * "git diff --dirstat -M" did not add changes in subdirectories up correctly for renamed paths. * "git diff --cumulative" did not imply "--dirstat". * "git for-each-ref refs/heads/" did not work as expected. * "git gui" allowed users to feed patch without any context to be applied. * "git gui" botched parsing "diff" output when a line that begins with two dashes and a space gets removed or a line that begins with two pluses and a space gets added. * "git gui" translation updates and i18n fixes. * "git index-pack" is more careful against disk corruption while completing a thin pack. * "git log -i --grep=pattern" did not ignore case; neither "git log -E --grep=pattern" triggered extended regexp. * "git log --pretty="%ad" --date=short" did not use short format when showing the timestamp. * "git log --author=author" match incorrectly matched with the timestamp part of "author " line in commit objects. * "git log -F --author=author" did not work at all. * Build procedure for "git shell" that used stub versions of some functions and globals was not understood by linkers on some platforms. * "git stash" was fooled by a stat-dirty but otherwise unmodified paths and refused to work until the user refreshed the index. * "git svn" was broken on Perl before 5.8 with recent fixes to reduce use of temporary files. * "git verify-pack -v" did not work correctly when given more than one packfile. Also contains many documentation updates.
This commit is contained in:
parent
8748c6679e
commit
cb19d1e93d
5 changed files with 20 additions and 20 deletions
|
@ -1,7 +1,7 @@
|
|||
# $NetBSD: Makefile,v 1.10 2008/08/20 03:04:20 bjs Exp $
|
||||
# $NetBSD: Makefile,v 1.11 2008/09/17 01:18:42 bjs Exp $
|
||||
#
|
||||
|
||||
.include "${.CURDIR}/../scmgit/Makefile.common"
|
||||
.include "../../devel/scmgit/Makefile.common"
|
||||
|
||||
PKGNAME= scmgit-base-${GIT_VERSION}
|
||||
COMMENT= GIT Tree History Storage Tool (base package)
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.14 2008/09/13 00:36:37 bjs Exp $
|
||||
$NetBSD: distinfo,v 1.15 2008/09/17 01:18:42 bjs Exp $
|
||||
|
||||
SHA1 (git-1.6.0.1.tar.gz) = ea91349101ef64c881e3d7c1ab294cbbcc76fca0
|
||||
RMD160 (git-1.6.0.1.tar.gz) = e3a505121b1e67247530b22d8a3054963c65ce99
|
||||
Size (git-1.6.0.1.tar.gz) = 2232053 bytes
|
||||
SHA1 (patch-aa) = 58483a554d681c33a66a0ad43f2141e42ba87543
|
||||
SHA1 (git-1.6.0.2.tar.gz) = 7b0814374a9734b2955718c9390a4021da3110ff
|
||||
RMD160 (git-1.6.0.2.tar.gz) = 50fca8103943292194673082d70b8ce6d21aca39
|
||||
Size (git-1.6.0.2.tar.gz) = 2237730 bytes
|
||||
SHA1 (patch-aa) = 2682ea5bc248ac4cdb20728196019e4b5d920b6f
|
||||
SHA1 (patch-ab) = b8cbeacd7d44791a5151deaa97d1d283ac9296d1
|
||||
SHA1 (patch-ac) = ae75c6ca3abb5edf688e4877f3df8b6c6297f091
|
||||
SHA1 (patch-ad) = 50def978931bd72c0ad86cebcafc2dd68a06f578
|
||||
|
|
|
@ -1,10 +1,10 @@
|
|||
$NetBSD: patch-aa,v 1.4 2008/08/20 03:04:20 bjs Exp $
|
||||
$NetBSD: patch-aa,v 1.5 2008/09/17 01:18:42 bjs Exp $
|
||||
|
||||
NetBSD 3.0 needs -liconv, too.
|
||||
|
||||
AR, CC, CFLAGS, LDFLAGS and LIBS should be taken from the environment.
|
||||
|
||||
--- Makefile.orig 2008-08-17 16:43:06.000000000 -0400
|
||||
--- Makefile.orig 2008-09-12 22:29:50.000000000 -0400
|
||||
+++ Makefile
|
||||
@@ -217,12 +217,8 @@ GITWEB_SITE_FOOTER =
|
||||
|
||||
|
@ -19,8 +19,8 @@ AR, CC, CFLAGS, LDFLAGS and LIBS should be taken from the environment.
|
|||
RPMBUILD = rpmbuild
|
||||
TCL_PATH = tclsh
|
||||
TCLTK_PATH = wish
|
||||
@@ -628,9 +624,10 @@ ifeq ($(uname_S),Darwin)
|
||||
NO_MEMMEM = YesPlease
|
||||
@@ -630,9 +626,10 @@ ifeq ($(uname_S),Darwin)
|
||||
COMPAT_OBJS += compat/regex/regex.o
|
||||
endif
|
||||
ifeq ($(uname_S),SunOS)
|
||||
+ NEEDS_LIBICONV = YesPlease
|
||||
|
@ -31,7 +31,7 @@ AR, CC, CFLAGS, LDFLAGS and LIBS should be taken from the environment.
|
|||
NO_STRCASESTR = YesPlease
|
||||
NO_MEMMEM = YesPlease
|
||||
NO_HSTRERROR = YesPlease
|
||||
@@ -648,8 +645,6 @@ ifeq ($(uname_S),SunOS)
|
||||
@@ -650,8 +647,6 @@ ifeq ($(uname_S),SunOS)
|
||||
NO_C99_FORMAT = YesPlease
|
||||
NO_STRTOUMAX = YesPlease
|
||||
endif
|
||||
|
@ -40,7 +40,7 @@ AR, CC, CFLAGS, LDFLAGS and LIBS should be taken from the environment.
|
|||
BASIC_CFLAGS += -D__EXTENSIONS__
|
||||
endif
|
||||
ifeq ($(uname_O),Cygwin)
|
||||
@@ -684,9 +679,7 @@ ifeq ($(uname_S),OpenBSD)
|
||||
@@ -688,9 +683,7 @@ ifeq ($(uname_S),OpenBSD)
|
||||
BASIC_LDFLAGS += -L/usr/local/lib
|
||||
endif
|
||||
ifeq ($(uname_S),NetBSD)
|
||||
|
@ -51,7 +51,7 @@ AR, CC, CFLAGS, LDFLAGS and LIBS should be taken from the environment.
|
|||
BASIC_CFLAGS += -I/usr/pkg/include
|
||||
BASIC_LDFLAGS += -L/usr/pkg/lib
|
||||
ALL_LDFLAGS += -Wl,-rpath,/usr/pkg/lib
|
||||
@@ -1046,7 +1039,7 @@ SHELL_PATH_SQ = $(subst ','\'',$(SHELL_P
|
||||
@@ -1053,7 +1046,7 @@ SHELL_PATH_SQ = $(subst ','\'',$(SHELL_P
|
||||
PERL_PATH_SQ = $(subst ','\'',$(PERL_PATH))
|
||||
TCLTK_PATH_SQ = $(subst ','\'',$(TCLTK_PATH))
|
||||
|
||||
|
@ -60,7 +60,7 @@ AR, CC, CFLAGS, LDFLAGS and LIBS should be taken from the environment.
|
|||
|
||||
BASIC_CFLAGS += -DSHA1_HEADER='$(SHA1_HEADER_SQ)' \
|
||||
$(COMPAT_CFLAGS)
|
||||
@@ -1348,10 +1341,10 @@ gitexec_instdir_SQ = $(subst ','\'',$(gi
|
||||
@@ -1352,10 +1345,10 @@ gitexec_instdir_SQ = $(subst ','\'',$(gi
|
||||
export gitexec_instdir
|
||||
|
||||
install: all
|
||||
|
|
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.6 2008/04/21 01:09:51 bjs Exp $
|
||||
# $NetBSD: Makefile,v 1.7 2008/09/17 01:18:42 bjs Exp $
|
||||
#
|
||||
|
||||
PKGNAME= scmgit-docs-${GIT_VERSION}
|
||||
|
@ -6,7 +6,7 @@ COMMENT= GIT Tree History Storage Tool (documentation)
|
|||
|
||||
PKG_DESTDIR_SUPPORT= user-destdir
|
||||
|
||||
DISTINFO_FILE= ${.CURDIR}/../scmgit-base/distinfo
|
||||
DISTINFO_FILE= ../../devel/scmgit-base/distinfo
|
||||
|
||||
BUILD_DEPENDS+= asciidoc-[0-9]*:../../textproc/asciidoc
|
||||
BUILD_DEPENDS+= xmlto-[0-9]*:../../textproc/xmlto
|
||||
|
@ -16,6 +16,6 @@ BUILD_TARGET= doc
|
|||
USE_LANGUAGES= c
|
||||
INSTALL_TARGET= install-doc
|
||||
|
||||
.include "${.CURDIR}/../scmgit/Makefile.common"
|
||||
.include "../../devel/scmgit/Makefile.common"
|
||||
|
||||
.include "../../mk/bsd.pkg.mk"
|
||||
|
|
|
@ -1,3 +1,3 @@
|
|||
# $NetBSD: Makefile.version,v 1.5 2008/09/13 00:36:37 bjs Exp $
|
||||
# $NetBSD: Makefile.version,v 1.6 2008/09/17 01:18:42 bjs Exp $
|
||||
#
|
||||
GIT_VERSION= 1.6.0.1
|
||||
GIT_VERSION= 1.6.0.2
|
||||
|
|
Loading…
Reference in a new issue