Merge wiz's build fixes for goffice0.8. Add pcre's bl3 to Makefile
(was previously only in the bl3 file, which pkglint justifiably considers broken) and bump PKGREVISION to 16.
This commit is contained in:
parent
dbe408aab8
commit
cb431c14be
4 changed files with 36 additions and 3 deletions
|
@ -1,9 +1,9 @@
|
|||
# $NetBSD: Makefile,v 1.24 2012/03/03 00:11:52 wiz Exp $
|
||||
# $NetBSD: Makefile,v 1.25 2012/05/10 04:43:53 dholland Exp $
|
||||
#
|
||||
|
||||
DISTNAME= goffice-0.6.6
|
||||
PKGNAME= goffice0.6-0.6.6
|
||||
PKGREVISION= 15
|
||||
PKGREVISION= 16
|
||||
CATEGORIES= misc
|
||||
MASTER_SITES= ${MASTER_SITE_GNOME:=sources/goffice/0.6/}
|
||||
|
||||
|
@ -24,6 +24,7 @@ USE_TOOLS+= gmake intltool msgfmt pkg-config
|
|||
|
||||
.include "../../converters/libiconv/buildlink3.mk"
|
||||
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||
.include "../../devel/pcre/buildlink3.mk"
|
||||
BUILDLINK_API_DEPENDS.glib2+= glib2>=2.8.0
|
||||
.include "../../devel/glib2/buildlink3.mk"
|
||||
.include "../../devel/libglade/buildlink3.mk"
|
||||
|
|
|
@ -1,5 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.6 2009/01/20 20:41:23 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.7 2012/05/10 04:43:53 dholland Exp $
|
||||
|
||||
SHA1 (goffice-0.6.6.tar.gz) = fdb00804de201e057628ba5b997512ab882ca9ea
|
||||
RMD160 (goffice-0.6.6.tar.gz) = d67f6eef8ecc4e26a4ddc807e6682b08d42d86f9
|
||||
Size (goffice-0.6.6.tar.gz) = 3246559 bytes
|
||||
SHA1 (patch-configure) = 820c5696f0d158c83558020ca06b8b8d5e81e5a3
|
||||
SHA1 (patch-goffice_utils_regutf8.c) = 4e058782463cf539339c6ac2782119ae9966eb24
|
||||
|
|
15
misc/goffice0.6/patches/patch-configure
Normal file
15
misc/goffice0.6/patches/patch-configure
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-configure,v 1.1 2012/05/10 04:43:53 dholland Exp $
|
||||
|
||||
pcretest -C also reports UTF-16 support, adapt pattern.
|
||||
|
||||
--- configure~ 2008-09-02 17:35:35.000000000 +0000
|
||||
+++ configure
|
||||
@@ -27158,7 +27158,7 @@ fi
|
||||
|
||||
{ echo "$as_me:$LINENO: checking for UTF-8 support in pcre" >&5
|
||||
echo $ECHO_N "checking for UTF-8 support in pcre... $ECHO_C" >&6; }
|
||||
- if (pcretest -C 2>&1) | grep -i "^ *UTF-8 support" >/dev/null; then
|
||||
+ if (pcretest -C 2>&1) | grep -i "^ *UTF-8 .*support" >/dev/null; then
|
||||
{ echo "$as_me:$LINENO: result: yes" >&5
|
||||
echo "${ECHO_T}yes" >&6; }
|
||||
LIBS="$LIBS -lpcre"
|
15
misc/goffice0.6/patches/patch-goffice_utils_regutf8.c
Normal file
15
misc/goffice0.6/patches/patch-goffice_utils_regutf8.c
Normal file
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-goffice_utils_regutf8.c,v 1.1 2012/05/10 04:43:53 dholland Exp $
|
||||
|
||||
Replace call to obsolete function.
|
||||
|
||||
--- goffice/utils/regutf8.c~ 2008-07-08 09:54:59.000000000 +0000
|
||||
+++ goffice/utils/regutf8.c
|
||||
@@ -155,7 +155,7 @@ go_regcomp (GORegexp *gor, const char *p
|
||||
default: return REG_BADPAT;
|
||||
}
|
||||
} else {
|
||||
- gor->re_nsub = pcre_info (r, NULL, NULL);
|
||||
+ pcre_fullinfo (r, NULL, PCRE_INFO_CAPTURECOUNT, &gor->re_nsub);
|
||||
gor->nosub = (cflags & REG_NOSUB) != 0;
|
||||
return 0;
|
||||
}
|
Loading…
Reference in a new issue