Changes 1.7.9:

* gitk updates accumulated since early 2011.
* git-gui updated to 0.16.0.
* git-p4 (in contrib/) updates.
* Git uses gettext to translate its most common interface messages
  into the user's language if translations are available and the
  locale is appropriately set. Distributors can drop new PO files
  in po/ to add new translations.
* The code to handle username/password for HTTP transactions used in
  "git push" & "git fetch" learned to talk "credential API" to
  external programs to cache or store them, to allow integration with
  platform native keychain mechanisms.
* The input prompts in the terminal use our own getpass() replacement
  when possible. HTTP transactions used to ask for the username without
  echoing back what was typed, but with this change you will see it as
  you type.
* The internals of "revert/cherry-pick" have been tweaked to prepare
  building more generic "sequencer" on top of the implementation that
  drives them.
* "git rev-parse FETCH_HEAD" after "git fetch" without specifying
  what to fetch from the command line will now show the commit that
  would be merged if the command were "git pull".
* "git add" learned to stream large files directly into a packfile
  instead of writing them into individual loose object files.
* "git checkout -B <current branch> <elsewhere>" is a more intuitive
  way to spell "git reset --keep <elsewhere>".
* "git checkout" and "git merge" learned "--no-overwrite-ignore" option
  to tell Git that untracked and ignored files are not expendable.
* "git commit --amend" learned "--no-edit" option to say that the
  user is amending the tree being recorded, without updating the
  commit log message.
* "git commit" and "git reset" re-learned the optimization to prime
  the cache-tree information in the index, which makes it faster to
  write a tree object out after the index entries are updated.
* "git commit" detects and rejects an attempt to stuff NUL byte in
  the commit log message.
* "git commit" learned "-S" to GPG-sign the commit; this can be shown
  with the "--show-signature" option to "git log".
* fsck and prune are relatively lengthy operations that still go
  silent while making the end-user wait. They learned to give progress
  output like other slow operations.
* The set of built-in function-header patterns for various languages
  knows MATLAB.
* "git log --format='<format>'" learned new %g[nNeE] specifiers to
  show information from the reflog entries when walking the reflog
  (i.e. with "-g").
* "git pull" can be used to fetch and merge an annotated/signed tag,
  instead of the tip of a topic branch. The GPG signature from the
  signed tag is recorded in the resulting merge commit for later
  auditing.
* "git log" learned "--show-signature" option to show the signed tag
  that was merged that is embedded in the merge commit. It also can
  show the signature made on the commit with "git commit -S".
* "git branch --edit-description" can be used to add descriptive text
  to explain what a topic branch is about.
* "git fmt-merge-msg" learned to take the branch description into
  account when preparing a merge summary that "git merge" records
  when merging a local branch.
* "git request-pull" has been updated to convey more information
  useful for integrators to decide if a topic is worth merging and
  what is pulled is indeed what the requestor asked to pull,
  including:
  - the tip of the branch being requested to be merged;
  - the branch description describing what the topic is about;
  - the contents of the annotated tag, when requesting to pull a tag.
* "git pull" learned to notice 'pull.rebase' configuration variable,
  which serves as a global fallback for setting 'branch.<name>.rebase'
  configuration variable per branch.
* "git tag" learned "--cleanup" option to control how the whitespaces
  and empty lines in tag message are cleaned up.
* "gitweb" learned to show side-by-side diff.
This commit is contained in:
adam 2012-02-06 13:11:35 +00:00
parent 3039ebe47a
commit cb51d080d7
7 changed files with 33 additions and 24 deletions

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.27 2012/01/21 10:16:43 obache Exp $
@comment $NetBSD: PLIST,v 1.28 2012/02/06 13:11:35 adam Exp $
bin/git
bin/git-cvsserver
bin/git-receive-pack
@ -51,6 +51,9 @@ libexec/git-core/git-commit
libexec/git-core/git-commit-tree
libexec/git-core/git-config
libexec/git-core/git-count-objects
libexec/git-core/git-credential-cache
libexec/git-core/git-credential-cache--daemon
libexec/git-core/git-credential-store
libexec/git-core/git-cvsexportcommit
libexec/git-core/git-cvsimport
libexec/git-core/git-cvsserver
@ -280,3 +283,4 @@ share/gitweb/static/git-logo.png
share/gitweb/static/gitweb.css
share/gitweb/static/gitweb.js
@pkgdir share/examples/scmgit/templates/branches
share/locale/is/LC_MESSAGES/git.mo

View file

@ -1,12 +1,12 @@
$NetBSD: distinfo,v 1.46 2012/01/20 15:43:38 adam Exp $
$NetBSD: distinfo,v 1.47 2012/02/06 13:11:35 adam Exp $
SHA1 (git-1.7.8.4.tar.gz) = add7b05f26216181d1b148dde298432132552b0f
RMD160 (git-1.7.8.4.tar.gz) = ee203b3d6252c2df150ef7904c6b95672dea4aff
Size (git-1.7.8.4.tar.gz) = 3544195 bytes
SHA1 (patch-aa) = f47ff9d8b9ba8592f7bbd21d4b0ab30394e8f9a0
SHA1 (git-1.7.9.tar.gz) = ed51ef5ef250daaa6e98515cf2641820cd268d4c
RMD160 (git-1.7.9.tar.gz) = 60aa60c076d0e398f7bc07d6cfab3c5ed28fdadc
Size (git-1.7.9.tar.gz) = 3606326 bytes
SHA1 (patch-aa) = 52a8bd8aec6dcb54dafe9414a00e627a6b04e4a0
SHA1 (patch-ac) = ae75c6ca3abb5edf688e4877f3df8b6c6297f091
SHA1 (patch-ae) = 06ea26658a986dc702c1c2c04c1a27f0a01e4dce
SHA1 (patch-af) = 60029a215edf5218a76be41932afb5b9f8c4729a
SHA1 (patch-ae) = d420c0a1db0de77bd9713d066434981b20bd4299
SHA1 (patch-af) = d6c942f7d8a0fe0074ea3edb7e6d858354c85232
SHA1 (patch-ag) = 4f0b9a5745203ea7ef369c8272b3ea7c644762f0
SHA1 (patch-ah) = f22a2160631fb624e9e20616c68ad1a4aa2bebc7
SHA1 (patch-ai) = 56b63d4790a11f5eb128186ad5efdd1bcf102f2e

View file

@ -1,8 +1,8 @@
$NetBSD: patch-aa,v 1.13 2010/10/28 10:23:08 adam Exp $
$NetBSD: patch-aa,v 1.14 2012/02/06 13:11:35 adam Exp $
--- Makefile.orig 2010-10-22 03:49:16.000000000 +0000
--- Makefile.orig 2012-01-27 20:51:04.000000000 +0000
+++ Makefile
@@ -259,8 +259,6 @@ endif
@@ -303,8 +303,6 @@ endif
CFLAGS = -g -O2 -Wall
LDFLAGS =
@ -11,9 +11,9 @@ $NetBSD: patch-aa,v 1.13 2010/10/28 10:23:08 adam Exp $
STRIP ?= strip
# Among the variables below, these:
@@ -298,13 +296,9 @@ pathsep = :
@@ -339,13 +337,9 @@ pathsep = :
export prefix bindir sharedir sysconfdir gitwebdir
export prefix bindir sharedir sysconfdir gitwebdir localedir
-CC = gcc
-AR = ar
@ -25,8 +25,8 @@ $NetBSD: patch-aa,v 1.13 2010/10/28 10:23:08 adam Exp $
RPMBUILD = rpmbuild
TCL_PATH = tclsh
TCLTK_PATH = wish
@@ -834,9 +828,10 @@ ifeq ($(uname_S),Darwin)
USE_ST_TIMESPEC = YesPlease
@@ -928,9 +922,10 @@ ifeq ($(uname_S),Darwin)
HAVE_DEV_TTY = YesPlease
endif
ifeq ($(uname_S),SunOS)
+ NEED_LIBICONV = YesPlease
@ -37,7 +37,7 @@ $NetBSD: patch-aa,v 1.13 2010/10/28 10:23:08 adam Exp $
SANE_TOOL_PATH = /usr/xpg6/bin:/usr/xpg4/bin
NO_STRCASESTR = YesPlease
NO_MEMMEM = YesPlease
@@ -880,8 +875,6 @@ ifeq ($(uname_S),SunOS)
@@ -972,8 +967,6 @@ ifeq ($(uname_S),SunOS)
NO_STRTOUMAX = YesPlease
GIT_TEST_CMP = cmp
endif
@ -46,7 +46,7 @@ $NetBSD: patch-aa,v 1.13 2010/10/28 10:23:08 adam Exp $
BASIC_CFLAGS += -D__EXTENSIONS__ -D__sun__ -DHAVE_ALLOCA_H
endif
ifeq ($(uname_O),Cygwin)
@@ -1563,8 +1556,8 @@ DEFAULT_PAGER_CQ_SQ = $(subst ','\'',$(D
@@ -1814,8 +1807,8 @@ DEFAULT_PAGER_CQ_SQ = $(subst ','\'',$(D
BASIC_CFLAGS += -DDEFAULT_PAGER='$(DEFAULT_PAGER_CQ_SQ)'
endif

View file

@ -1,11 +1,11 @@
$NetBSD: patch-ae,v 1.3 2008/08/20 03:04:20 bjs Exp $
$NetBSD: patch-ae,v 1.4 2012/02/06 13:11:35 adam Exp $
In pkgsrc, all Perl modules are installed into vendor_perl, not
site_perl.
--- perl/Makefile.orig 2008-08-17 16:43:06.000000000 -0400
+++ perl/Makefile
@@ -11,7 +11,7 @@ ifndef V
@@ -12,7 +12,7 @@ ifndef V
endif
all install instlibdir: $(makfile)

View file

@ -1,8 +1,8 @@
$NetBSD: patch-af,v 1.5 2010/10/28 10:23:08 adam Exp $
$NetBSD: patch-af,v 1.6 2012/02/06 13:11:35 adam Exp $
--- Documentation/Makefile.orig 2010-10-22 03:49:16.000000000 +0000
+++ Documentation/Makefile
@@ -180,16 +180,16 @@ pdf: user-manual.pdf
@@ -177,16 +177,16 @@ pdf: user-manual.pdf
install: install-man
install-man: man

View file

@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.12 2012/01/20 15:43:38 adam Exp $
@comment $NetBSD: PLIST,v 1.13 2012/02/06 13:11:35 adam Exp $
man/man1/git-add.1
man/man1/git-am.1
man/man1/git-annotate.1
@ -23,6 +23,9 @@ man/man1/git-commit-tree.1
man/man1/git-commit.1
man/man1/git-config.1
man/man1/git-count-objects.1
man/man1/git-credential-cache--daemon.1
man/man1/git-credential-cache.1
man/man1/git-credential-store.1
man/man1/git-cvsexportcommit.1
man/man1/git-cvsimport.1
man/man1/git-cvsserver.1
@ -77,6 +80,7 @@ man/man1/git-mktree.1
man/man1/git-mv.1
man/man1/git-name-rev.1
man/man1/git-notes.1
man/man1/git-p4.1
man/man1/git-pack-objects.1
man/man1/git-pack-redundant.1
man/man1/git-pack-refs.1
@ -152,6 +156,7 @@ man/man5/gitrepository-layout.5
man/man5/gitweb.conf.5
man/man7/gitcli.7
man/man7/gitcore-tutorial.7
man/man7/gitcredentials.7
man/man7/gitcvs-migration.7
man/man7/gitdiffcore.7
man/man7/gitglossary.7

View file

@ -1,3 +1,3 @@
# $NetBSD: Makefile.version,v 1.32 2012/01/20 15:43:38 adam Exp $
# $NetBSD: Makefile.version,v 1.33 2012/02/06 13:11:35 adam Exp $
GIT_VERSION= 1.7.8.4
GIT_VERSION= 1.7.9