Remove libyahoo and gtkyahoo.

The project was declared dead on February 27th 2003, although the last version
dates from August 14th 2001.  Not to mention that the program does not work
any more due to all the changes in Yahoo's authentication mechanisms in the
meantime.
This commit is contained in:
jmmv 2005-06-12 13:03:38 +00:00
parent e9fa63e8c5
commit cb8ba3f79f
16 changed files with 4 additions and 316 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.112 2005/06/06 11:35:39 tron Exp $
# $NetBSD: Makefile,v 1.113 2005/06/12 13:03:39 jmmv Exp $
#
COMMENT= Communication programs
@ -31,7 +31,6 @@ SUBDIR+= gg2
SUBDIR+= gnomeicu
SUBDIR+= goofey
SUBDIR+= gossip
SUBDIR+= gtkyahoo
SUBDIR+= gtmess
SUBDIR+= i2cb
SUBDIR+= i2cbd
@ -53,7 +52,6 @@ SUBDIR+= kmess
SUBDIR+= libirc
SUBDIR+= libotr
SUBDIR+= libtlen
SUBDIR+= libyahoo
SUBDIR+= licq-core
SUBDIR+= licq-gui-console
SUBDIR+= licq-gui-qt

View file

@ -1,4 +0,0 @@
GTKYahoo is a GPL'd GTK+-based Yahoo! pager client for UNIX. GTKYahoo has
a number of features not available in the Windows or Java versions of the
pager, including an auto-reply (answering machine) feature and automatic
forwarding of incoming messages via email.

View file

@ -1,26 +0,0 @@
# $NetBSD: Makefile,v 1.14 2005/06/01 18:02:41 jlam Exp $
DISTNAME= gtkyahoo-0.18.2
PKGREVISION= 3
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=gtkyahoo/} \
http://www.unixtools.org/gtkyahoo/dist/
MAINTAINER= tech-pkg@NetBSD.org
HOMEPAGE= http://www.unixtools.org/gtkyahoo/
COMMENT= GTK+ client for Yahoo! Messenger
BUILD_DEPENDS+= bison-[0-9]*:../../devel/bison
USE_TOOLS+= lex
GNU_CONFIGURE= YES
CONFIGURE_ARGS+= --with-libyahoo="${BUILDLINK_PREFIX.libyahoo}"
pre-configure:
${RM} -rf ${WRKSRC}/libyahoo
.include "../../chat/libyahoo/buildlink3.mk"
.include "../../lang/perl5/buildlink3.mk"
.include "../../x11/gtk/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

View file

@ -1,12 +0,0 @@
@comment $NetBSD: PLIST,v 1.1 2001/10/31 20:06:29 zuntum Exp $
bin/gtkyahoo
libexec/gtkyahoo-sound-handler
share/gtkyahoo/sample.gtkyahoorc
share/gtkyahoo/simple.gtkyahoorc
share/gtkyahoo/sounds/beep.au
share/gtkyahoo/sounds/logoff.au
share/gtkyahoo/sounds/logon.au
share/gtkyahoo/sounds/receive.au
share/gtkyahoo/sounds/send.au
@dirrm share/gtkyahoo/sounds
@dirrm share/gtkyahoo

View file

@ -1,10 +0,0 @@
$NetBSD: distinfo,v 1.4 2005/02/23 15:59:11 agc Exp $
SHA1 (gtkyahoo-0.18.2.tar.gz) = c1aa66766049635a328e59783a7f7a2afd7b9de7
RMD160 (gtkyahoo-0.18.2.tar.gz) = 71ff9be1a3bb3fc52df0d7cd55dc55e9b01c5491
Size (gtkyahoo-0.18.2.tar.gz) = 300728 bytes
SHA1 (patch-aa) = b599a96a20e45878b4222759bd747a68dbd61ed9
SHA1 (patch-ab) = b6713fa9b89bfcd937112bd136413bcb46ca7f77
SHA1 (patch-ac) = 3725e1aec98f23fe4cc3dbc06df816c97862feac
SHA1 (patch-ad) = b7d5593c10bbbff5ba2ffdd2448890304a97c99a
SHA1 (patch-ae) = 14ce88abd723474898210a714b68427d5d6d4b12

View file

@ -1,24 +0,0 @@
$NetBSD: patch-aa,v 1.1.1.1 2001/10/23 02:04:32 jlam Exp $
--- Makefile.in.orig Fri Aug 24 05:04:09 2001
+++ Makefile.in
@@ -80,7 +80,7 @@
bin_PROGRAMS = gtkyahoo
libexec_SCRIPTS = gtkyahoo-sound-handler
-SUBDIRS = libyahoo
+SUBDIRS =
DISTCLEANFILES = gtkyahoo-sound-handler gtkyahoo.spec gtkyahoo-ximian.spec debian/changelog gtkyahoo.lsm
@@ -90,8 +90,8 @@
INCLUDES = -I$(srcdir) -I.
-gtkyahoo_LDADD = -L./libyahoo -lyahoo
-gtkyahoo_DEPENDENCIES = ./libyahoo/libyahoo.a
+gtkyahoo_LDADD = -lyahoo
+gtkyahoo_DEPENDENCIES =
SOUNDS = sounds/beep.au sounds/logoff.au sounds/logon.au sounds/send.au sounds/receive.au

View file

@ -1,103 +0,0 @@
$NetBSD: patch-ab,v 1.1 2002/03/31 14:13:46 dmcmahill Exp $
LP64 fixes
--- menus.c.orig Mon Aug 20 09:13:11 2001
+++ menus.c
@@ -269,6 +269,28 @@
}
}
+char *preset_urls[]={
+"http://msg.edit.yahoo.com/config/set_buddylist",
+"http://msg.edit.yahoo.com/config/eval_profile",
+"http://msg.edit.yahoo.com/config/edit_identity",
+"http://www.yahoo.com",
+"http://search.profiles.yahoo.com",
+"http://mail.yahoo.com",
+"http://address.yahoo.com",
+"http://calendar.yahoo.com",
+"http://finance.yahoo.com",
+"http://my.yahoo.com",
+"http://shopping.yahoo.com",
+"http://auctions.yahoo.com",
+"http://classifieds.yahoo.com",
+"http://clubs.yahoo.com",
+"http://games.yahoo.com",
+"http://chat.yahoo.com",
+"http://personals.yahoo.com",
+"http://messages.yahoo.com",
+"http://geocities.yahoo.com/home"
+};
+
static GtkItemFactoryEntry menu_items[] = {
{"/_File", NULL, 0, 0, "<Branch>"},
{"/File/About GTKYahoo...", NULL, create_about_window,
@@ -286,11 +308,11 @@
{"/_Edit", NULL, 0, 0, "<Branch>"},
{"/Edit/Friends & Groups", NULL, launch_browser_cb,
- (guint) "http://msg.edit.yahoo.com/config/set_buddylist", "<Item>"},
+ 0, "<Item>"},
{"/Edit/Account Information", NULL, launch_browser_cb,
- (guint) "http://msg.edit.yahoo.com/config/eval_profile", "<Item>"},
+ 1, "<Item>"},
{"/Edit/Profiles & Identities", NULL, launch_browser_cb,
- (guint) "http://msg.edit.yahoo.com/config/edit_identity", "<Item>"},
+ 2, "<Item>"},
{"/_Tools", NULL, 0, 0, "<Branch>"},
{"/Tools/Start Chat...", "<control>M", handle_menu_tools_startchat,
@@ -328,37 +350,37 @@
{"/_Y!", NULL, 0, 0, "<Branch>"},
{"/Y!/Yahoo! Home", NULL, launch_browser_cb,
- (guint) "http://www.yahoo.com", "<Item>"},
+ 3, "<Item>"},
{"/Y!/Find New Friends", NULL, launch_browser_cb,
- (guint) "http://search.profiles.yahoo.com", "<Item>"},
+ 4, "<Item>"},
{"/Y!/Check & Send Email", NULL, launch_browser_cb,
- (guint) "http://mail.yahoo.com", "<Item>"},
+ 5, "<Item>"},
{"/Y!/View Your Address Book", NULL, launch_browser_cb,
- (guint) "http://address.yahoo.com", "<Item>"},
+ 6, "<Item>"},
{"/Y!/View Your Calendar", NULL, launch_browser_cb,
- (guint) "http://calendar.yahoo.com", "<Item>"},
+ 7, "<Item>"},
{"/Y!/Stock Quotes", NULL, launch_browser_cb,
- (guint) "http://finance.yahoo.com", "<Item>"},
+ 8, "<Item>"},
{"/Y!/Personalize Yahoo!", NULL, launch_browser_cb,
- (guint) "http://my.yahoo.com", "<Item>"},
+ 9, "<Item>"},
{"/Y!/Shopping", NULL, launch_browser_cb,
- (guint) "http://shopping.yahoo.com", "<Item>"},
+ 10, "<Item>"},
{"/Y!/Bid on Auctions", NULL, launch_browser_cb,
- (guint) "http://auctions.yahoo.com", "<Item>"},
+ 11, "<Item>"},
{"/Y!/Classified Ads", NULL, launch_browser_cb,
- (guint) "http://classifieds.yahoo.com", "<Item>"},
+ 12, "<Item>"},
{"/Y!/Join & View Clubs", NULL, launch_browser_cb,
- (guint) "http://clubs.yahoo.com", "<Item>"},
+ 13, "<Item>"},
{"/Y!/Play Games", NULL, launch_browser_cb,
- (guint) "http://games.yahoo.com", "<Item>"},
+ 14, "<Item>"},
{"/Y!/Chat With Friends", NULL, launch_browser_cb,
- (guint) "http://chat.yahoo.com", "<Item>"},
+ 15, "<Item>"},
{"/Y!/View & Post Personals", NULL, launch_browser_cb,
- (guint) "http://personals.yahoo.com", "<Item>"},
+ 16, "<Item>"},
{"/Y!/Message Boards", NULL, launch_browser_cb,
- (guint) "http://messages.yahoo.com", "<Item>"},
+ 17, "<Item>"},
{"/Y!/Free Home Pages at GeoCities", NULL, launch_browser_cb,
- (guint) "http://geocities.yahoo.com/home", "<Item>"}
+ 18, "<Item>"}
};
static GtkItemFactoryEntry status_items[] = {

View file

@ -1,21 +0,0 @@
$NetBSD: patch-ac,v 1.1 2002/03/31 14:13:46 dmcmahill Exp $
LP64 fixes
--- gtkyahoo.c.orig Fri Aug 17 05:41:11 2001
+++ gtkyahoo.c
@@ -201,11 +201,11 @@
return (1);
}
-void launch_browser_cb(GtkWidget * w, gpointer data)
-{
- char *url = (char *) data;
- launch_browser(url);
+void launch_browser_cb(gpointer data, guint action, GtkWidget *widget)
+{
+ extern char *preset_urls[];
+ launch_browser(preset_urls[action]);
}
static int id_is_sys_id (const char *id)

View file

@ -1,14 +0,0 @@
$NetBSD: patch-ad,v 1.1 2002/03/31 14:13:46 dmcmahill Exp $
LP64 fixes
--- gtkyahoo-proto.h.orig Mon Aug 13 07:56:01 2001
+++ gtkyahoo-proto.h
@@ -65,7 +65,7 @@
void handle_button_startchat(GtkWidget * widget, gpointer * data);
void io_callback(gpointer data, gint source, GdkInputCondition condition);
int process_packets_callback(gpointer data);
-void launch_browser_cb(GtkWidget * w, gpointer data);
+void launch_browser_cb(gpointer data, guint action, GtkWidget *widget);
void process_packet_message(struct yahoo_packet *pkt);
void process_packet_ping(struct yahoo_packet *pkt);
void process_packet_filetransfer(struct yahoo_packet *pkt);

View file

@ -1,44 +0,0 @@
$NetBSD: patch-ae,v 1.1 2002/12/26 18:49:43 jschauma Exp $
--- rcfile.y.orig Thu Dec 26 13:23:25 2002
+++ rcfile.y Thu Dec 26 13:30:11 2002
@@ -253,11 +253,13 @@
| config_options idle_time_option
| config_options show_notify_messages_option
| config_options display_real_names_option
+ ;
contact_options: /* empty */
| contact_options name_option
| contact_options event_option
| contact_options email_option
+ ;
name_option: NAME QSTRING {
DBG_Print("rcfile", "[RC] Got contact name (%s)\n", $2);
@@ -278,17 +280,14 @@
if ( images.status.away )
free(images.status.away);
images.status.away = strdup($2); }
- ;
| IMAGE_STATUS_IDLE QSTRING {
if ( images.status.idle )
free(images.status.idle);
images.status.idle = strdup($2); }
- ;
| IMAGE_STATUS_HERE QSTRING {
if ( images.status.here )
free(images.status.here);
images.status.here = strdup($2); }
- ;
| IMAGE_STATUS_OFFLINE QSTRING {
if ( images.status.offline )
free(images.status.offline);
@@ -327,7 +326,6 @@
DBG_Print("rcfile", "[RC] Set proxy host to '%s'\n", $2);
proxy_host = strdup($2); }
}
- ;
| PROXY_PORT INTEGER {
if (config_match) {
proxy_port = $2;

View file

@ -1,3 +0,0 @@
Libyahoo is the Yahoo! Messenger client library used by gtkyahoo, kyahoo,
everybuddy, jabber, etc. It encapsulates routines to speak the Yahoo!
Instant Messenging protocol.

View file

@ -1,18 +0,0 @@
# $NetBSD: Makefile,v 1.8 2005/04/11 21:45:04 tv Exp $
DISTNAME= libyahoo-0.18.4
PKGREVISION= 1
CATEGORIES= chat
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=libyahoo/}
MAINTAINER= ken@246gt.com
HOMEPAGE= http://sourceforge.net/projects/libyahoo/
COMMENT= Yahoo! Messenger client library
GNU_CONFIGURE= yes
USE_LIBTOOL= yes
post-install:
${INSTALL_DATA} ${WRKSRC}/libyahoo-authors.h ${PREFIX}/include/libyahoo
.include "../../mk/bsd.pkg.mk"

View file

@ -1,8 +0,0 @@
@comment $NetBSD: PLIST,v 1.4 2004/09/22 08:09:20 jlam Exp $
bin/libyahoo-config
include/libyahoo/libyahoo-authors.h
include/libyahoo/libyahoo-debug.h
include/libyahoo/libyahoo-proto.h
include/libyahoo/libyahoo.h
lib/libyahoo.la
@dirrm include/libyahoo

View file

@ -1,20 +0,0 @@
# $NetBSD: buildlink3.mk,v 1.2 2004/10/03 00:13:15 tv Exp $
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH}+
LIBYAHOO_BUILDLINK3_MK:= ${LIBYAHOO_BUILDLINK3_MK}+
.if !empty(BUILDLINK_DEPTH:M+)
BUILDLINK_DEPENDS+= libyahoo
.endif
BUILDLINK_PACKAGES:= ${BUILDLINK_PACKAGES:Nlibyahoo}
BUILDLINK_PACKAGES+= libyahoo
.if !empty(LIBYAHOO_BUILDLINK3_MK:M+)
BUILDLINK_DEPENDS.libyahoo+= libyahoo>=0.18.4
BUILDLINK_RECOMMENDED.libyahoo+= libyahoo>=0.18.4nb1
BUILDLINK_PKGSRCDIR.libyahoo?= ../../chat/libyahoo
BUILDLINK_INCDIRS.libyahoo+= include/libyahoo
.endif # LIBYAHOO_BUILDLINK3_MK
BUILDLINK_DEPTH:= ${BUILDLINK_DEPTH:S/+$//}

View file

@ -1,5 +0,0 @@
$NetBSD: distinfo,v 1.3 2005/02/23 15:59:12 agc Exp $
SHA1 (libyahoo-0.18.4.tar.gz) = 02e8916b1c25c13bcbc3ebac5e512e6a4ea876e1
RMD160 (libyahoo-0.18.4.tar.gz) = 4e1569abbc89ada6b936511a296ea0b15cb63677
Size (libyahoo-0.18.4.tar.gz) = 187776 bytes

View file

@ -1,4 +1,4 @@
$NetBSD: CHANGES,v 1.10349 2005/06/12 10:54:59 jdolecek Exp $
$NetBSD: CHANGES,v 1.10350 2005/06/12 13:03:38 jmmv Exp $
Changes to the packages collection and infrastructure in 2005:
@ -2861,3 +2861,5 @@ Changes to the packages collection and infrastructure in 2005:
Updated devel/mantis to 0.91.1nb4 [adrianp 2005-06-10]
Updated x11/wxGTK to 2.4.2nb5 [wiz 2005-06-11]
Added www/opera7 version 7.54pl2 [jdolecek 2005-06-12]
Removed chat/gtkyahoo [jmmv 2005-06-12]
Removed chat/libyahoo [jmmv 2005-06-12]