Updated gnuradio-usrp to 3.0.4:

* Updated license to GPLv3
	* Fixed shared memory leak on NetBSD
	* Many bug fixes
This commit is contained in:
wulf 2007-08-08 03:20:06 +00:00
parent 943aa09bda
commit cb9f940c3a
4 changed files with 53 additions and 27 deletions

View file

@ -1,6 +1,7 @@
$NetBSD: distinfo,v 1.4 2006/11/13 18:12:41 wulf Exp $
$NetBSD: distinfo,v 1.5 2007/08/08 03:20:06 wulf Exp $
SHA1 (gnuradio-3.0.2.tar.gz) = 9d9a0e22c9e4fd9735f62c0145b9ceb61a33f9c2
RMD160 (gnuradio-3.0.2.tar.gz) = 3ff771c2d13d680fb76d7ca82a6a11678c7069ae
Size (gnuradio-3.0.2.tar.gz) = 3190212 bytes
SHA1 (patch-aa) = 176268067dee80a8c29f6f0b24111543d231958f
SHA1 (gnuradio-3.0.4.tar.gz) = ce2d0bd4c5217cdda8c675c80a446ca38f274121
RMD160 (gnuradio-3.0.4.tar.gz) = a1d4ae0495f51c5b7349dd8d1305b4bfb16056dc
Size (gnuradio-3.0.4.tar.gz) = 3381051 bytes
SHA1 (patch-ab) = a9853ef7d300793afb76e7958a6fcae11629315d
SHA1 (patch-ac) = f64a60f2ef14489de3823c27f0fba128faa40f0c

View file

@ -1,22 +0,0 @@
$NetBSD: patch-aa,v 1.1 2006/11/13 18:12:41 wulf Exp $
--- configure.orig 2006-11-11 19:53:29.000000000 +1030
+++ configure 2006-11-11 19:54:31.000000000 +1030
@@ -32113,17 +32113,6 @@
passed=yes
- # Don't do gr-usrp if usrp skipped
- # There *has* to be a better way to check if a value is in a string
- for dir in $skipped_dirs
- do
- if test x$dir = xusrp; then
- { echo "$as_me:$LINENO: result: Component gr-usrp requires usrp, which is not being built." >&5
-echo "${ECHO_T}Component gr-usrp requires usrp, which is not being built." >&6; }
- passed=no
- fi
- done
-
if test x$passed = xno; then
skipped_dirs="$skipped_dirs gr-usrp"

View file

@ -0,0 +1,22 @@
$NetBSD: patch-ab,v 1.1 2007/08/08 03:20:08 wulf Exp $
--- Makefile.common.orig 2007-08-08 04:40:14.000000000 +0930
+++ Makefile.common 2007-08-08 04:40:47.000000000 +0930
@@ -52,7 +52,7 @@
$(FFTW3F_CFLAGS)
# How to link in GNU Radio core library from inside the tree
-GNURADIO_CORE_LA = $(top_builddir)/gnuradio-core/src/lib/libgnuradio-core.la
+GNURADIO_CORE_LA = -lgnuradio-core
# This is a dependency for many swig operations
GNURADIO_I = $(top_srcdir)/gnuradio-core/src/lib/swig/gnuradio.i
@@ -60,7 +60,7 @@
# How to link in the USRP library from inside the tree
USRP_INCLUDES = -I$(top_srcdir)/usrp/host/lib \
-I$(top_srcdir)/usrp/firmware/include
-USRP_LA = $(top_builddir)/usrp/host/lib/libusrp.la
+USRP_LA = -libusrp
# This used to be set in configure.ac but is now defined here for all
# Makefiles when this fragment is included.

View file

@ -0,0 +1,25 @@
$NetBSD: patch-ac,v 1.1 2007/08/08 03:20:08 wulf Exp $
--- config/grc_gr_usrp.m4.orig 2007-07-29 19:01:28.000000000 +0930
+++ config/grc_gr_usrp.m4 2007-07-29 18:53:09.000000000 +0930
@@ -29,13 +29,13 @@
passed=yes
# Don't do gr-usrp if usrp skipped
# There *has* to be a better way to check if a value is in a string
- for dir in $skipped_dirs
- do
- if test x$dir = xusrp; then
- AC_MSG_RESULT([Component gr-usrp requires usrp, which is not being built.])
- passed=no
- fi
- done
+# for dir in $skipped_dirs
+# do
+# if test x$dir = xusrp; then
+# AC_MSG_RESULT([Component gr-usrp requires usrp, which is not being built.])
+# passed=no
+# fi
+# done
GRC_BUILD_CONDITIONAL([gr-usrp],[
dnl run_tests is created from run_tests.in. Make it executable.