Updated to version 1.01.
Pkgsrc changes: - Download source is now berlios.de - The package supports installation to DESTDIR. - GCC 2.95 is not enough anymore. Changes since version 0.92: =========================== Changes in Version 1.01 ======================= User-Visible changes -------------------- - 60++ new level - added easy mode to some existing levels - fixes of all levels with known shortcuts - Finnish translation - French and Russian 1.0 manuals - support of updatable cross internet level packs - return to last played level via F6 - sound damping for noisy levels - level developer inspector with developer attributes - mouse wheel enabled for many buttons like user ratings, volume,... - logo cleaned - moved backup of score and state to backup subdirectory - level menu string display optimization of level title, wr-holders,... - visualize inherited user rating in level inspector - vista compatible marble icon - windows installer reengineering to modern NSI Internal changes ---------------- - fix of various engine bugs that did not yet show up with bundled levels - fixed properties of various glass stones - sound handling reengineering - support of user sound sets - autorecovery from state / score mismatches - re-Id of Windows users Changes in Version 1.00 ======================= User-Visible changes -------------------- - 200++ new levels, fixes to all broken levels - new levelpack sorting - grouping of levelpacks - level inspector for viewing ratings and statistic information about levels - screenshot viewer - personal annotations and rating of levels - score registration and download of world records and statistic information - PAR and handicap as messures for a player - drop & play of new levels and new levelpacks - history and search of levels - composer for own levelpacks and levelpack groups - instant language change - Translations of level titles and documents - Swedish, Russian, Hungarian, Portuguese translation - German and French manuals - 100++ pages Reference manual Internal changes ---------------- - XMLification of all data files - reengineering of level and levelpack - catch many errors intenally, display messages, continue or clean shutdown - portability issues - Unix, Windows, MacOS as unified platform - switch from Lua 4.* to Lua 5.1.1, from tolua to tolua++ - switch return value of messages from void/nil to Value - added sender object as second argument to callback function - common floor attributes (gradient, mouseforce, friction) - border stones are swappable - improved fire system: eternal, secure fire, heat transformation, ... - new stones: st-chess, st-lightpassenger, st-polarswitch, st-redrock, st-firebreak[_move], st-bigbluesand-<nesw>, st-camouflage - new floors: fl-thief, fl-nomouse, fl-woven_orange - new items: it-rubberband, it-booze-broken, it-death, it-drop - removed: fl-ice_001 - it-pencil -> it-cross, it-crack - it-brush -> it-cross, it-squashed - st-scissor actions - bigbricks unswappable and unpullable - st-flash/actorimpulse*/spitter : distorted forces - small whiteballs can jump - new libraries: andreas_itemfreeze, andreas_ghosts, libpuzzle, libterrain - icons polish - sound additions, volume reduction on stone hit for details on the subjects read the reference manual, for a complete list of changes see svn commit messages at berlios.de: http://svn.berlios.de/wsvn/enigma-game/tags/1.00/?op=log&rev=0&sc=0&isdir=1)
This commit is contained in:
parent
c89826e5d5
commit
cba144e327
13 changed files with 1390 additions and 1814 deletions
|
@ -1,30 +1,40 @@
|
||||||
# $NetBSD: Makefile,v 1.16 2006/06/12 16:28:08 wiz Exp $
|
# $NetBSD: Makefile,v 1.17 2007/06/14 17:55:03 heinz Exp $
|
||||||
|
|
||||||
DISTNAME= enigma-0.92
|
DISTNAME= enigma-1.01
|
||||||
PKGREVISION= 5
|
|
||||||
CATEGORIES= games
|
CATEGORIES= games
|
||||||
MASTER_SITES= http://savannah.nongnu.org/download/enigma/
|
MASTER_SITES= http://download.berlios.de/enigma-game/
|
||||||
|
|
||||||
MAINTAINER= heinz@NetBSD.org
|
MAINTAINER= heinz@NetBSD.org
|
||||||
HOMEPAGE= http://www.nongnu.org/enigma/
|
HOMEPAGE= http://www.nongnu.org/enigma/
|
||||||
COMMENT= Puzzle game similar to Oxyd/Rock'n'Roll/Marble Madness
|
COMMENT= Puzzle game similar to Oxyd/Rock'n'Roll/Marble Madness
|
||||||
|
|
||||||
|
PKG_DESTDIR_SUPPORT= user-destdir
|
||||||
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
PKG_INSTALLATION_TYPES= overwrite pkgviews
|
||||||
|
|
||||||
GCC_REQD+= 2.95
|
DEPENDS+= gettext-tools-[0-9]*:../../devel/gettext-tools
|
||||||
|
|
||||||
|
GCC_REQD+= 3.3
|
||||||
USE_DIRS+= xdg-1.1
|
USE_DIRS+= xdg-1.1
|
||||||
USE_LANGUAGES= c c++
|
USE_LANGUAGES= c c++
|
||||||
USE_PKGLOCALEDIR= yes
|
USE_PKGLOCALEDIR= yes
|
||||||
USE_TOOLS+= gmake
|
USE_TOOLS+= gmake
|
||||||
GNU_CONFIGURE= yes
|
GNU_CONFIGURE= yes
|
||||||
|
|
||||||
SUBST_CLASSES+= enigma
|
BUILDLINK_API_DEPENDS.SDL_mixer+= SDL_mixer>=1.2.6
|
||||||
SUBST_STAGE.enigma= post-patch
|
BUILDLINK_API_DEPENDS.SDL+= SDL>=1.2.9
|
||||||
SUBST_FILES.enigma= doc/manual/enigma_1.html
|
BUILDLINK_API_DEPENDS.SDL_ttf+= SDL_ttf>=2.0.7
|
||||||
SUBST_SED.enigma= -e s!/usr/local/!${PREFIX}/!
|
BUILDLINK_API_DEPENDS.SDL_image+= SDL_image>=1.2.4
|
||||||
|
BUILDLINK_API_DEPENDS.zlib+= zlib>=1.2.3
|
||||||
|
BUILDLINK_API_DEPENDS.png+= png>=1.2.7
|
||||||
|
BUILDLINK_API_DEPENDS.xerces-c+= xerces-c>=2.7.0
|
||||||
|
|
||||||
.include "../../audio/SDL_mixer/buildlink3.mk"
|
.include "../../audio/SDL_mixer/buildlink3.mk"
|
||||||
|
.include "../../devel/SDL/buildlink3.mk"
|
||||||
.include "../../devel/SDL_ttf/buildlink3.mk"
|
.include "../../devel/SDL_ttf/buildlink3.mk"
|
||||||
|
.include "../../devel/gettext-lib/buildlink3.mk"
|
||||||
|
.include "../../devel/zlib/buildlink3.mk"
|
||||||
|
.include "../../graphics/png/buildlink3.mk"
|
||||||
.include "../../graphics/SDL_image/buildlink3.mk"
|
.include "../../graphics/SDL_image/buildlink3.mk"
|
||||||
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
|
||||||
|
.include "../../textproc/xerces-c/buildlink3.mk"
|
||||||
.include "../../mk/bsd.pkg.mk"
|
.include "../../mk/bsd.pkg.mk"
|
||||||
|
|
2988
games/enigma/PLIST
2988
games/enigma/PLIST
File diff suppressed because it is too large
Load diff
|
@ -1,14 +1,6 @@
|
||||||
$NetBSD: distinfo,v 1.6 2005/08/29 10:50:57 rillig Exp $
|
$NetBSD: distinfo,v 1.7 2007/06/14 17:55:03 heinz Exp $
|
||||||
|
|
||||||
SHA1 (enigma-0.92.tar.gz) = 39aa8f4222945d91243387b42935ca074c2f0506
|
SHA1 (enigma-1.01.tar.gz) = 93f96ddd152e7474488cbb27ce0923312a851a9c
|
||||||
RMD160 (enigma-0.92.tar.gz) = cdbe27425534792ac0199525db1d6068aefacebd
|
RMD160 (enigma-1.01.tar.gz) = 9dd91152cfced5352a669e8921fdbb270c0abc4e
|
||||||
Size (enigma-0.92.tar.gz) = 10768245 bytes
|
Size (enigma-1.01.tar.gz) = 10847953 bytes
|
||||||
SHA1 (patch-ac) = 7c6e8ba01b3a1246f075503d7edad6accbfda402
|
SHA1 (patch-aq) = 113580c3063cdfa11ee212f922edd5b40f229eea
|
||||||
SHA1 (patch-ad) = 7b1e9457423678c48a7e361f652a0d329115388e
|
|
||||||
SHA1 (patch-ae) = 34688c59131e78d3e663fc47d1d72a8644a96353
|
|
||||||
SHA1 (patch-af) = 5d79079b9bd4237d3d1c0ba08dd05cc6fade556a
|
|
||||||
SHA1 (patch-ag) = a3cdad78fde86ac21c23d66142a65088a6ba8b8f
|
|
||||||
SHA1 (patch-am) = 84c906c26702866d24fe6dc2e536932be2daf175
|
|
||||||
SHA1 (patch-an) = b434ffcf0e2623b255cd87f92c717bc7efdc0152
|
|
||||||
SHA1 (patch-ao) = b73f2de2443ecce8fa2e11bba6c69f3fbaf80a89
|
|
||||||
SHA1 (patch-ap) = 493674539e96bb4ce19599bde64d7cb922ecd82d
|
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
$NetBSD: patch-ac,v 1.2 2005/08/22 15:35:37 adam Exp $
|
|
||||||
|
|
||||||
--- doc/Makefile.in.orig 2005-05-29 22:03:37.000000000 +0000
|
|
||||||
+++ doc/Makefile.in
|
|
||||||
@@ -169,7 +169,7 @@ target_os = @target_os@
|
|
||||||
target_vendor = @target_vendor@
|
|
||||||
SUBDIRS = manual refman
|
|
||||||
|
|
||||||
-docdir = @datadir@/doc/enigma/reference
|
|
||||||
+docdir = @datadir@/doc/html/enigma/reference
|
|
||||||
doc_DATA = functions.html functions.css ant_lua.txt CREATING-LEVELS sounds.txt objects.txt sound.lua
|
|
||||||
|
|
||||||
EXTRA_DIST = enigma.6 HACKING TODO README.mingw32 $(doc_DATA)
|
|
|
@ -1,13 +0,0 @@
|
||||||
$NetBSD: patch-ad,v 1.2 2005/08/22 15:35:37 adam Exp $
|
|
||||||
|
|
||||||
--- doc/manual/Makefile.in.orig 2005-05-27 05:54:42.000000000 +0000
|
|
||||||
+++ doc/manual/Makefile.in
|
|
||||||
@@ -177,7 +177,7 @@ HTML = $(wildcard enigma_*.html) \
|
|
||||||
index.html
|
|
||||||
|
|
||||||
|
|
||||||
-htmldir = @datadir@/doc/enigma
|
|
||||||
+htmldir = @datadir@/doc/html/enigma
|
|
||||||
html_DATA = $(HTML)
|
|
||||||
|
|
||||||
EXTRA_DIST = enigma.texi $(html_DATA)
|
|
|
@ -1,13 +0,0 @@
|
||||||
$NetBSD: patch-ae,v 1.2 2005/08/22 15:35:37 adam Exp $
|
|
||||||
|
|
||||||
--- doc/manual/images/Makefile.in.orig 2005-05-27 05:54:43.000000000 +0000
|
|
||||||
+++ doc/manual/images/Makefile.in
|
|
||||||
@@ -170,7 +170,7 @@ target_vendor = @target_vendor@
|
|
||||||
PNG = $(wildcard $(srcdir)/*.png)
|
|
||||||
PDF = $(addprefix $(builddir), $(addsuffix .pdf, $(basename $(notdir $(PNG)))))
|
|
||||||
|
|
||||||
-pngdir = @datadir@/doc/enigma/images
|
|
||||||
+pngdir = @datadir@/doc/html/enigma/images
|
|
||||||
png_DATA = $(PNG)
|
|
||||||
|
|
||||||
SUFFIXES = .png .pdf
|
|
|
@ -1,13 +0,0 @@
|
||||||
$NetBSD: patch-af,v 1.2 2005/08/22 15:35:37 adam Exp $
|
|
||||||
|
|
||||||
--- doc/refman/Makefile.in.orig 2005-05-27 05:54:44.000000000 +0000
|
|
||||||
+++ doc/refman/Makefile.in
|
|
||||||
@@ -174,7 +174,7 @@ HTML = enigma-ref.html
|
|
||||||
|
|
||||||
EXTRA_DIST = enigma-ref.texi texi2html.init $(HTML)
|
|
||||||
|
|
||||||
-htmldir = @datadir@/doc/enigma/reference
|
|
||||||
+htmldir = @datadir@/doc/html/enigma/reference
|
|
||||||
html_DATA = $(HTML)
|
|
||||||
subdir = doc/refman
|
|
||||||
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
|
|
@ -1,14 +0,0 @@
|
||||||
$NetBSD: patch-ag,v 1.2 2005/08/22 15:35:37 adam Exp $
|
|
||||||
|
|
||||||
--- etc/Makefile.in.orig 2005-05-27 06:28:46.000000000 +0000
|
|
||||||
+++ etc/Makefile.in
|
|
||||||
@@ -360,7 +360,8 @@ info: info-am
|
|
||||||
|
|
||||||
info-am:
|
|
||||||
|
|
||||||
-install-data-am: install-desktopDATA install-iconDATA install-pixmapDATA
|
|
||||||
+#install-data-am: install-desktopDATA install-iconDATA install-pixmapDATA
|
|
||||||
+install-data-am: install-iconDATA install-pixmapDATA
|
|
||||||
|
|
||||||
install-exec-am:
|
|
||||||
|
|
|
@ -1,14 +0,0 @@
|
||||||
$NetBSD: patch-am,v 1.3 2005/08/22 15:35:37 adam Exp $
|
|
||||||
|
|
||||||
--- src/px/dict.hh.orig 2004-12-08 10:17:10.000000000 +0000
|
|
||||||
+++ src/px/dict.hh
|
|
||||||
@@ -131,7 +131,8 @@ namespace px
|
|
||||||
|
|
||||||
const T& lookup(const key_type &key) const {
|
|
||||||
Entry *e = find_entry(key);
|
|
||||||
- if (!e) throw XInvalidKey();
|
|
||||||
+// rational: see above + XInvalidKey is not declared anywhere
|
|
||||||
+// if (!e) throw XInvalidKey();
|
|
||||||
return e->pair.second;
|
|
||||||
}
|
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
$NetBSD: patch-an,v 1.3 2005/08/22 15:35:37 adam Exp $
|
|
||||||
|
|
||||||
--- src/px/video.cc.orig 2004-12-30 13:21:35.000000000 +0000
|
|
||||||
+++ src/px/video.cc
|
|
||||||
@@ -177,16 +177,16 @@ namespace
|
|
||||||
|
|
||||||
void set_pixels(const GS &gs, int n, const int* xlist, const int* ylist, Uint32 color) {
|
|
||||||
const int *xp = xlist, *yp = ylist;
|
|
||||||
- if (NOCLIP(gs)) {
|
|
||||||
+ if (NOCLIP(this->gs)) {
|
|
||||||
for (int i=n; i > 0; --i) {
|
|
||||||
int x = *xp++, y = *yp++;
|
|
||||||
- *pixel_pointer(x,y) = gs.pcolor;
|
|
||||||
+ *pixel_pointer(x,y) = this->gs.pcolor;
|
|
||||||
}
|
|
||||||
} else {
|
|
||||||
for (int i=n; i > 0; --i) {
|
|
||||||
int x = *xp++, y = *yp++;
|
|
||||||
- if (clip_pixel (gs, x, y))
|
|
||||||
- *pixel_pointer(x,y) = gs.pcolor;
|
|
||||||
+ if (clip_pixel (this->gs, x, y))
|
|
||||||
+ *pixel_pointer(x,y) = this->gs.pcolor;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
}
|
|
|
@ -1,14 +0,0 @@
|
||||||
$NetBSD: patch-ao,v 1.1 2005/08/29 10:50:57 rillig Exp $
|
|
||||||
|
|
||||||
LC_MESSAGES needs <clocale>.
|
|
||||||
|
|
||||||
--- src/nls.cc.orig Tue Jan 25 14:53:16 2005
|
|
||||||
+++ src/nls.cc Mon Aug 29 12:32:50 2005
|
|
||||||
@@ -5,6 +5,7 @@
|
|
||||||
#include <iostream>
|
|
||||||
#include <string>
|
|
||||||
#include <cstdlib>
|
|
||||||
+#include <clocale>
|
|
||||||
|
|
||||||
#include <config.h>
|
|
||||||
|
|
|
@ -1,37 +0,0 @@
|
||||||
$NetBSD: patch-ap,v 1.1 2005/08/29 10:50:57 rillig Exp $
|
|
||||||
|
|
||||||
ISO C90 compatibility mode.
|
|
||||||
|
|
||||||
--- src/px/IMG_SavePNG.c.orig Thu Dec 30 14:21:11 2004
|
|
||||||
+++ src/px/IMG_SavePNG.c Mon Aug 29 12:26:59 2005
|
|
||||||
@@ -63,10 +63,11 @@ int IMG_SavePNG_RW(SDL_Surface *face, SD
|
|
||||||
rmask, gmask, bmask, amask);
|
|
||||||
|
|
||||||
if (surface) {
|
|
||||||
+ png_structp png_ptr;
|
|
||||||
SDL_BlitSurface(face, NULL, surface, NULL);
|
|
||||||
SDL_LockSurface(surface);
|
|
||||||
|
|
||||||
- png_structp png_ptr = png_create_write_struct(PNG_LIBPNG_VER_STRING, NULL, png_user_error, png_user_warn);
|
|
||||||
+ png_ptr = png_create_write_struct(PNG_LIBPNG_VER_STRING, NULL, png_user_error, png_user_warn);
|
|
||||||
if (!png_ptr) {
|
|
||||||
IMG_SetError("Couldn't allocate memory for PNG file");
|
|
||||||
}
|
|
||||||
@@ -84,6 +85,8 @@ int IMG_SavePNG_RW(SDL_Surface *face, SD
|
|
||||||
IMG_SetError("Error writing the PNG file");
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
+ int colortype;
|
|
||||||
+
|
|
||||||
png_set_write_fn(png_ptr, src, png_write_data, png_io_flush);
|
|
||||||
/* Set the image information here. Width and height are up to 2^31,
|
|
||||||
* bit_depth is one of 1, 2, 4, 8, or 16, but valid values also depend on
|
|
||||||
@@ -93,7 +96,7 @@ int IMG_SavePNG_RW(SDL_Surface *face, SD
|
|
||||||
* PNG_INTERLACE_ADAM7, and the compression_type and filter_type MUST
|
|
||||||
* currently be PNG_COMPRESSION_TYPE_BASE and PNG_FILTER_TYPE_BASE. REQUIRED
|
|
||||||
*/
|
|
||||||
- int colortype = png_colortype_from_surface(surface);
|
|
||||||
+ colortype = png_colortype_from_surface(surface);
|
|
||||||
png_set_IHDR(png_ptr, info_ptr, surface->w, surface->h, 8,
|
|
||||||
colortype, PNG_INTERLACE_NONE, PNG_COMPRESSION_TYPE_BASE, PNG_FILTER_TYPE_BASE);
|
|
||||||
|
|
14
games/enigma/patches/patch-aq
Normal file
14
games/enigma/patches/patch-aq
Normal file
|
@ -0,0 +1,14 @@
|
||||||
|
$NetBSD: patch-aq,v 1.1 2007/06/14 17:55:05 heinz Exp $
|
||||||
|
|
||||||
|
--- lib-src/enet/Makefile.in.orig 2006-12-13 22:51:46.000000000 +0100
|
||||||
|
+++ lib-src/enet/Makefile.in
|
||||||
|
@@ -551,7 +551,8 @@ installdirs-am:
|
||||||
|
for dir in "$(DESTDIR)$(libdir)"; do \
|
||||||
|
test -z "$$dir" || $(mkdir_p) "$$dir"; \
|
||||||
|
done
|
||||||
|
-install: install-recursive
|
||||||
|
+# pkgsrc: do not install any part of enet
|
||||||
|
+install:
|
||||||
|
install-exec: install-exec-recursive
|
||||||
|
install-data: install-data-recursive
|
||||||
|
uninstall: uninstall-recursive
|
Loading…
Reference in a new issue