Apply a security patch to correctly drop privileges.

No vulnerability exists because of this, but I think
it is best to have this applied.  (However, no entry
in the vulnerabilities file will be added.)
This commit is contained in:
kim 2004-09-19 21:38:20 +00:00
parent ef978adb10
commit cbb7e80b2f
3 changed files with 14 additions and 5 deletions

View file

@ -1,7 +1,8 @@
# $NetBSD: Makefile,v 1.3 2004/04/25 04:13:20 snj Exp $
# $NetBSD: Makefile,v 1.4 2004/09/19 21:38:20 kim Exp $
#
DISTNAME= tcptraceroute-1.4
PKGREVISION= 1
CATEGORIES= net
MASTER_SITES= http://michael.toren.net/code/tcptraceroute/

View file

@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2003/12/28 06:33:26 kim Exp $
$NetBSD: distinfo,v 1.3 2004/09/19 21:38:21 kim Exp $
SHA1 (tcptraceroute-1.4.tar.gz) = 1dbd9a0a10b11695b0204bea460463a9dd921338
Size (tcptraceroute-1.4.tar.gz) = 31918 bytes
SHA1 (patch-aa) = 26899ae5898dcdbaa8b12a178ff6c2b362a675c9
SHA1 (patch-ab) = 0f6d5a568414163db201374ee6e81df064d4cf62
SHA1 (patch-ab) = abd5a77df099062983f4c825120d399deb3b6b16

View file

@ -1,7 +1,7 @@
$NetBSD: patch-ab,v 1.2 2003/12/28 06:33:26 kim Exp $
$NetBSD: patch-ab,v 1.3 2004/09/19 21:38:21 kim Exp $
--- tcptraceroute.c.orig 2002-07-30 17:51:27.000000000 -0400
+++ tcptraceroute.c 2003-12-28 00:58:09.000000000 -0500
+++ tcptraceroute.c 2004-09-19 17:34:05.000000000 -0400
@@ -209,7 +209,7 @@
#define AF_LINK AF_INET /* BSD defines some AF_INET network interfaces as AF_LINK */
#endif
@ -65,3 +65,11 @@ $NetBSD: patch-ab,v 1.2 2003/12/28 06:33:26 kim Exp $
#if defined (__SVR4) && defined (__sun)
o_trackport = 1; /* --track-port should be the default for Solaris */
#else
@@ -2003,6 +2007,6 @@
defaults();
initcapture();
- seteuid(getuid());
+ setuid(getuid());
return trace();
}