Fix build to Wine a bit.

It would bomb out on:
freetype.c:166: error: 'FT_MulFix' undeclared here (not in a function)
freetype.c:166: warning: type defaults to 'int' in declaration of 'pFT_MulFix'

This is due to a newer version of freetype. Patch by Shunichi Fuji. Still
fails to compile on other errors, but one more down.
This commit is contained in:
reinoud 2009-09-07 14:25:08 +00:00
parent 951981803c
commit ccb182d670
2 changed files with 29 additions and 1 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.85 2009/04/20 18:55:42 adam Exp $
$NetBSD: distinfo,v 1.86 2009/09/07 14:25:08 reinoud Exp $
SHA1 (wine-1.0.1.tar.bz2) = 0550b03bf7b314514a87b6abb2198da96ef83b22
RMD160 (wine-1.0.1.tar.bz2) = fecd2bf970c51c80fc02ca39631034f066da145e
@ -19,3 +19,4 @@ SHA1 (patch-bd) = 46a7b8cc8e0793facf78876d26f24cd40ee1d097
SHA1 (patch-be) = ce9d21a9716c79525239499c89fcf0bb3ef807a3
SHA1 (patch-bf) = d31bcc193ffe6abc57700bcb43fea6ff5886c038
SHA1 (patch-ca) = 1383c03cc83cefe6099b58340db2bc468c7524bb
SHA1 (patch-cb) = cc8c4ade538a19b817a10b31e41ea9f968845193

View file

@ -0,0 +1,27 @@
$NetBSD: patch-cb,v 1.1 2009/09/07 14:25:08 reinoud Exp $
--- dlls/gdi32/freetype.c.orig 2008-10-17 17:45:25.000000000 +0200
+++ dlls/gdi32/freetype.c
@@ -162,8 +162,12 @@ MAKE_FUNCPTR(FT_Get_Sfnt_Name_Count);
MAKE_FUNCPTR(FT_Get_Sfnt_Table);
MAKE_FUNCPTR(FT_Init_FreeType);
MAKE_FUNCPTR(FT_Load_Glyph);
MAKE_FUNCPTR(FT_Matrix_Multiply);
+#ifdef FT_MULFIX_INLINED
+#define pFT_MulFix FT_MULFIX_INLINED
+#else
MAKE_FUNCPTR(FT_MulFix);
+#endif
MAKE_FUNCPTR(FT_New_Face);
MAKE_FUNCPTR(FT_New_Memory_Face);
MAKE_FUNCPTR(FT_Outline_Get_Bitmap);
@@ -2438,7 +2441,9 @@ static BOOL init_freetype(void)
LOAD_FUNCPTR(FT_Init_FreeType)
LOAD_FUNCPTR(FT_Load_Glyph)
LOAD_FUNCPTR(FT_Matrix_Multiply)
+#ifndef FT_MULFIX_INLINED
LOAD_FUNCPTR(FT_MulFix)
+#endif
LOAD_FUNCPTR(FT_New_Face)
LOAD_FUNCPTR(FT_New_Memory_Face)
LOAD_FUNCPTR(FT_Outline_Get_Bitmap)