buildlink3.mk depends on gmp, even when includes are needed; use MAJOR/MINOR for linking libraries

This commit is contained in:
adam 2011-04-26 09:54:55 +00:00
parent 26f46192e6
commit ccb449e062
3 changed files with 13 additions and 9 deletions

View file

@ -1,4 +1,4 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/04/26 08:59:33 adam Exp $
# $NetBSD: buildlink3.mk,v 1.2 2011/04/26 09:54:55 adam Exp $
BUILDLINK_TREE+= libnettle
@ -7,6 +7,8 @@ LIBNETTLE_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.libnettle+= nettle>=2.1
BUILDLINK_PKGSRCDIR.libnettle?= ../../security/nettle
.include "../../devel/gmp/buildlink3.mk"
.endif # LIBNETTLE_BUILDLINK3_MK
BUILDLINK_TREE+= -libnettle

View file

@ -1,9 +1,9 @@
$NetBSD: distinfo,v 1.1.1.1 2011/04/26 08:59:33 adam Exp $
$NetBSD: distinfo,v 1.2 2011/04/26 09:54:55 adam Exp $
SHA1 (nettle-2.1.tar.gz) = 15f660ef6cfd62c1c3302f68055f194913de0dfb
RMD160 (nettle-2.1.tar.gz) = 56bd66654e8320abb12812d0fa1b79733bc62094
Size (nettle-2.1.tar.gz) = 965345 bytes
SHA1 (patch-Makefile.in) = 398a39012453940ab6c65307402bed71e2515069
SHA1 (patch-Makefile.in) = 15bbe1b1a33817c0d1d1db1f4510c3ebc6eb949e
SHA1 (patch-config.make.in) = 0bf3d2729b97883b41374a1ea3d5286fd2554e98
SHA1 (patch-testsuite_Makefile.in) = 38498777821eba9a5d303e6d7848addf5da06700
SHA1 (patch-tools_Makefile.in) = 262d59cb6e642e6ad4c8bec2e166fc18367d91d7

View file

@ -1,4 +1,4 @@
$NetBSD: patch-Makefile.in,v 1.1.1.1 2011/04/26 08:59:33 adam Exp $
$NetBSD: patch-Makefile.in,v 1.2 2011/04/26 09:54:55 adam Exp $
Use LIBTOOL.
@ -20,7 +20,7 @@ Use LIBTOOL.
SHLIBTARGETS = $(LIBNETTLE_FORLINK) @IF_HOGWEED@ $(LIBHOGWEED_FORLINK)
TARGETS = aesdata$(EXEEXT) desdata$(EXEEXT) shadata$(EXEEXT) \
@@ -138,19 +138,17 @@ hogweed_OBJS = $(hogweed_SOURCES:.c=.$(O
@@ -138,19 +138,19 @@ hogweed_OBJS = $(hogweed_SOURCES:.c=.$(O
hogweed_PURE_OBJS = $(hogweed_OBJS:.$(OBJEXT)=.p$(OBJEXT))
# FIXME: Do we really need to delete the archive first?
@ -30,7 +30,8 @@ Use LIBTOOL.
- $(RANLIB) $@
+libnettle.la: $(nettle_OBJS)
+ ${LIBTOOL} --mode=link ${CC} ${LDFLAGS} -o libnettle.la \
+ ${nettle_OBJS:.o=.lo} -rpath ${PREFIX}/lib -version-info 4:0
+ ${nettle_OBJS:.o=.lo} -rpath ${PREFIX}/lib \
+ -version-info ${LIBNETTLE_MAJOR}:${LIBNETTLE_MINOR}
# FIXME: Do we really need to delete the archive first?
-libhogweed.a: $(hogweed_OBJS)
@ -39,7 +40,8 @@ Use LIBTOOL.
- $(RANLIB) $@
+libhogweed.la: $(hogweed_OBJS)
+ ${LIBTOOL} --mode=link ${CC} ${LDFLAGS} -o libhogweed.la \
+ ${hogweed_OBJS:.o=.lo} -rpath ${PREFIX}/lib -version-info 4:0
+ ${hogweed_OBJS:.o=.lo} -rpath ${PREFIX}/lib \
+ -version-info ${LIBHOGWEED_MAJOR}:${LIBHOGWEED_MINOR}
.c.$(OBJEXT):
- $(COMPILE) $(CCPIC_MAYBE) -c $< \
@ -47,7 +49,7 @@ Use LIBTOOL.
&& $(DEP_PROCESS)
# Rules building shared libraries
@@ -200,7 +198,7 @@ des.$(OBJEXT): des.c des.h $(des_headers
@@ -200,7 +200,7 @@ des.$(OBJEXT): des.c des.h $(des_headers
.asm.$(OBJEXT):
$(M4) $(srcdir)/asm.m4 machine.m4 config.m4 \
$< >$*.s
@ -56,7 +58,7 @@ Use LIBTOOL.
echo "$@ : $< $(srcdir)/asm.m4 machine.m4 config.m4" >$@.d
.asm.p$(OBJEXT):
@@ -266,7 +264,7 @@ install-here: install-info install-heade
@@ -266,7 +266,7 @@ install-here: install-info install-heade
install-static: $(LIBTARGETS)
$(MKDIR_P) $(DESTDIR)$(libdir)
for f in $(LIBTARGETS); do \