Add -i option, needed when Mail(1) and mail(1) try to call us.
This commit is contained in:
parent
638c3c5063
commit
ccd2e73b27
5 changed files with 55 additions and 5 deletions
|
@ -1,4 +1,7 @@
|
||||||
# $NetBSD: Makefile,v 1.2 2003/02/15 22:34:24 wiz Exp $
|
# $NetBSD: Makefile,v 1.3 2003/02/15 22:39:50 is Exp $
|
||||||
#
|
#
|
||||||
|
|
||||||
|
PKGNAME= mini_sendmail-1.3.2
|
||||||
|
PKGREVISION= 1
|
||||||
|
|
||||||
.include "Makefile.common"
|
.include "Makefile.common"
|
||||||
|
|
|
@ -1,6 +1,8 @@
|
||||||
$NetBSD: distinfo,v 1.1 2003/02/15 22:11:25 is Exp $
|
$NetBSD: distinfo,v 1.2 2003/02/15 22:39:50 is Exp $
|
||||||
|
|
||||||
SHA1 (mini_sendmail-1.3.2.tar.gz) = 1e297ae27135f0f83f09c7be8a911ebfd9e2f966
|
SHA1 (mini_sendmail-1.3.2.tar.gz) = 1e297ae27135f0f83f09c7be8a911ebfd9e2f966
|
||||||
Size (mini_sendmail-1.3.2.tar.gz) = 7329 bytes
|
Size (mini_sendmail-1.3.2.tar.gz) = 7329 bytes
|
||||||
SHA1 (patch-aa) = 86f5d32a093194f3ccb69c6068eac8611a586962
|
SHA1 (patch-aa) = e10ba2e62295e598e6f6c38d622bc3bb6388969d
|
||||||
SHA1 (patch-ab) = f96d22be2f94445a6f8b249cdd823dcfbd1528de
|
SHA1 (patch-ab) = f96d22be2f94445a6f8b249cdd823dcfbd1528de
|
||||||
|
SHA1 (patch-ac) = d2dbafded5c05328d7f67ada0aadfeb6305efd25
|
||||||
|
SHA1 (patch-ad) = c4f2218e0531bc9cd480a04a92477220afddd836
|
||||||
|
|
|
@ -1,8 +1,17 @@
|
||||||
$NetBSD: patch-aa,v 1.1 2003/02/15 22:11:28 is Exp $
|
$NetBSD: patch-aa,v 1.2 2003/02/15 22:39:50 is Exp $
|
||||||
|
|
||||||
--- mini_sendmail.c.orig Thu Nov 21 21:27:55 2002
|
--- mini_sendmail.c.orig Thu Nov 21 21:27:55 2002
|
||||||
+++ mini_sendmail.c
|
+++ mini_sendmail.c
|
||||||
@@ -575,14 +575,16 @@
|
@@ -129,6 +129,8 @@
|
||||||
|
timeout = atoi( &(argv[argn][2]) );
|
||||||
|
else if ( strcmp( argv[argn], "-v" ) == 0 )
|
||||||
|
verbose = 1;
|
||||||
|
+ else if ( strcmp( argv[argn], "-i" ) == 0 )
|
||||||
|
+ /* do nothing */ ;
|
||||||
|
else
|
||||||
|
usage();
|
||||||
|
++argn;
|
||||||
|
@@ -575,14 +577,16 @@
|
||||||
sock_family = PF_INET6;
|
sock_family = PF_INET6;
|
||||||
|
|
||||||
#ifdef DO_MINUS_S
|
#ifdef DO_MINUS_S
|
||||||
|
|
24
mail/mini_sendmail/patches/patch-ac
Normal file
24
mail/mini_sendmail/patches/patch-ac
Normal file
|
@ -0,0 +1,24 @@
|
||||||
|
$NetBSD: patch-ac,v 1.1 2003/02/15 22:39:50 is Exp $
|
||||||
|
|
||||||
|
--- mini_sendmail.8.orig Sat Feb 15 23:16:19 2003
|
||||||
|
+++ mini_sendmail.8
|
||||||
|
@@ -4,6 +4,7 @@
|
||||||
|
.SH SYNOPSIS
|
||||||
|
.B mini_sendmail
|
||||||
|
.RB [ -f<name> ]
|
||||||
|
+.RB [ -i ]
|
||||||
|
.RB [ -t ]
|
||||||
|
.RB [ -s<server> ]
|
||||||
|
.RB [ -T<timeout> ]
|
||||||
|
@@ -24,6 +25,11 @@
|
||||||
|
.TP
|
||||||
|
.B -f
|
||||||
|
Set the name of the "from" person (i.e. the sender of the mail).
|
||||||
|
+.TP
|
||||||
|
+.B -i
|
||||||
|
+Don't parse for a dot-line, but read input up to an end-of-file.
|
||||||
|
+Currently, this is always the case, but this option is needed for
|
||||||
|
+compatibility with sendmail.
|
||||||
|
.TP
|
||||||
|
.B -t
|
||||||
|
Read message for recipients.
|
12
mail/mini_sendmail/patches/patch-ad
Normal file
12
mail/mini_sendmail/patches/patch-ad
Normal file
|
@ -0,0 +1,12 @@
|
||||||
|
$NetBSD: patch-ad,v 1.1 2003/02/15 22:39:50 is Exp $
|
||||||
|
|
||||||
|
--- version.h.orig Thu Nov 21 21:19:50 2002
|
||||||
|
+++ version.h
|
||||||
|
@@ -3,6 +3,6 @@
|
||||||
|
#ifndef _VERSION_H_
|
||||||
|
#define _VERSION_H_
|
||||||
|
|
||||||
|
-#define VERSION "mini_sendmail/1.3.2 21nov2002"
|
||||||
|
+#define VERSION "mini_sendmail/1.3.2 21nov2002 nb1 15Feb2003"
|
||||||
|
|
||||||
|
#endif /* _VERSION_H_ */
|
Loading…
Reference in a new issue