Fix building with Clang
This commit is contained in:
parent
8741b74b40
commit
ccdc6619f9
2 changed files with 32 additions and 2 deletions
|
@ -1,4 +1,4 @@
|
|||
# $NetBSD: Makefile,v 1.37 2012/09/15 10:05:39 obache Exp $
|
||||
# $NetBSD: Makefile,v 1.38 2012/09/30 13:15:03 adam Exp $
|
||||
|
||||
DISTNAME= kdepimlibs-${_KDE_VERSION}
|
||||
PKGNAME= ${DISTNAME:S/-4/4-4/}
|
||||
|
@ -12,7 +12,7 @@ CMAKE_DEPENDENCIES_REWRITE= _KDE_build/KDEPimLibsDependencies.cmake
|
|||
|
||||
REPLACE_PERL+= mailtransport/kconf_update/migrate-transports.pl
|
||||
|
||||
BUILDLINK_API_DEPENDS.akonadi+= akonadi>=1.5.52
|
||||
BUILDLINK_API_DEPENDS.akonadi+= akonadi>=1.5.52
|
||||
|
||||
.include "../../meta-pkgs/kde4/kde4.mk"
|
||||
|
||||
|
|
30
misc/kdepimlibs4/patches/patch-kldap_ber.cpp
Normal file
30
misc/kdepimlibs4/patches/patch-kldap_ber.cpp
Normal file
|
@ -0,0 +1,30 @@
|
|||
$NetBSD: patch-kldap_ber.cpp,v 1.1 2012/09/30 13:15:04 adam Exp $
|
||||
|
||||
Fix building with Clang.
|
||||
|
||||
--- kldap/ber.cpp.orig 2012-09-30 12:13:44.000000000 +0000
|
||||
+++ kldap/ber.cpp
|
||||
@@ -128,7 +128,11 @@ int Ber::printf( const QString &format,
|
||||
{
|
||||
char fmt[2];
|
||||
va_list args;
|
||||
+#ifdef __clang__
|
||||
+ va_start ( args, format.unicode() );
|
||||
+#else
|
||||
va_start ( args, format );
|
||||
+#endif
|
||||
fmt[1] = '\0';
|
||||
|
||||
int i = 0, ret = 0;
|
||||
@@ -233,7 +237,11 @@ int Ber::scanf( const QString &format, .
|
||||
{
|
||||
char fmt[2];
|
||||
va_list args;
|
||||
+#ifdef __clang__
|
||||
+ va_start ( args, format.unicode() );
|
||||
+#else
|
||||
va_start ( args, format );
|
||||
+#endif
|
||||
fmt[1] = '\0';
|
||||
|
||||
int i = 0, ret = 0;
|
Loading…
Reference in a new issue