qemu: enable iscsi initiator support

This commit is contained in:
tnn 2020-03-13 13:57:04 +00:00
parent dfc42e92b5
commit cce3408655
4 changed files with 46 additions and 6 deletions

View file

@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.235 2020/03/10 22:09:47 wiz Exp $
# $NetBSD: Makefile,v 1.236 2020/03/13 13:57:04 tnn Exp $
DISTNAME= qemu-4.2.0
PKGREVISION= 11
PKGREVISION= 12
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
EXTRACT_SUFX= .tar.xz

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.156 2020/02/06 23:23:21 kamil Exp $
$NetBSD: distinfo,v 1.157 2020/03/13 13:57:04 tnn Exp $
SHA1 (qemu-4.2.0.tar.xz) = b27aa828a8457bd8551ae3c81b80cc365e1f6bfe
RMD160 (qemu-4.2.0.tar.xz) = cab8f6d85c0c6e9c01059087ed27d1243a7004a4
@ -25,6 +25,7 @@ SHA1 (patch-include_sysemu_nvmm.h) = 3bd3da9b42ace0f806fabeb580f90ae19c273869
SHA1 (patch-net_tap-solaris.c) = cc953c9a624dd55ace4e130d0b31bbfb956c17d5
SHA1 (patch-qemu-doc.texi) = 78f926a16494c07248b9a81f39dca5b78ae542bb
SHA1 (patch-qemu-options.hx) = 17fb92e03e32402ea2c04217991a2cd01a335e02
SHA1 (patch-roms_u-boot-sam460ex_Makefile) = e43111db0c56625bc8df5e3688c242c341f3fa6a
SHA1 (patch-roms_u-boot_tools_imx8m__image.sh) = e4c452062f40569e33aa93eec4a65bd3af2e74fc
SHA1 (patch-target_i386_Makefile.objs) = be8ab2e72521ccd0a71db6b37feb9957b27ac970
SHA1 (patch-target_i386_helper.c) = 54363fe53688ea4030665b3bbb3ee7aba7ba5348

View file

@ -1,8 +1,8 @@
# $NetBSD: options.mk,v 1.8 2020/02/07 08:39:19 kamil Exp $
# $NetBSD: options.mk,v 1.9 2020/03/13 13:57:04 tnn Exp $
PKG_OPTIONS_VAR= PKG_OPTIONS.qemu
PKG_SUPPORTED_OPTIONS= gtk3 sdl spice
PKG_SUGGESTED_OPTIONS+=
PKG_SUPPORTED_OPTIONS= gtk3 iscsi sdl spice
PKG_SUGGESTED_OPTIONS+= iscsi
.include "../../mk/bsd.fast.prefs.mk"
@ -49,3 +49,10 @@ CONFIGURE_ARGS+= --enable-spice
.else
CONFIGURE_ARGS+= --disable-spice
.endif
.if !empty(PKG_OPTIONS:Miscsi)
CONFIGURE_ARGS+= --enable-libiscsi
.include "../../net/libiscsi/buildlink3.mk"
.else
CONFIGURE_ARGS+= --disable-libiscsi
.endif

View file

@ -0,0 +1,32 @@
$NetBSD: patch-roms_u-boot-sam460ex_Makefile,v 1.1 2020/03/13 13:57:04 tnn Exp $
Shell compatibility
--- roms/u-boot-sam460ex/Makefile.orig 2019-12-12 18:22:51.000000000 +0000
+++ roms/u-boot-sam460ex/Makefile
@@ -2189,10 +2189,10 @@ M5475GFE_config : unconfig
if [ "$${CODE}" != "0" ] ; then \
echo "#define CONFIG_SYS_NOR1SZ $${CODE}" >> $(obj)include/config.h ; \
fi; \
- if [ "$${VID}" == "1" ] ; then \
+ if [ "$${VID}" = "1" ] ; then \
echo "#define CONFIG_SYS_VIDEO" >> $(obj)include/config.h ; \
fi; \
- if [ "$${USB}" == "1" ] ; then \
+ if [ "$${USB}" = "1" ] ; then \
echo "#define CONFIG_SYS_USBCTRL" >> $(obj)include/config.h ; \
fi
@$(MKCONFIG) -a M5475EVB m68k mcf547x_8x m547xevb freescale
@@ -2224,10 +2224,10 @@ M5485HFE_config : unconfig
if [ "$${CODE}" != "0" ] ; then \
echo "#define CONFIG_SYS_NOR1SZ $${CODE}" >> $(obj)include/config.h ; \
fi; \
- if [ "$${VID}" == "1" ] ; then \
+ if [ "$${VID}" = "1" ] ; then \
echo "#define CONFIG_SYS_VIDEO" >> $(obj)include/config.h ; \
fi; \
- if [ "$${USB}" == "1" ] ; then \
+ if [ "$${USB}" = "1" ] ; then \
echo "#define CONFIG_SYS_USBCTRL" >> $(obj)include/config.h ; \
fi
@$(MKCONFIG) -a M5485EVB m68k mcf547x_8x m548xevb freescale