Resolve "error: 'yield' was not declared in this scope". Fixes build
on Solaris.
This commit is contained in:
parent
5fc0eaa31e
commit
ccf8eaad6c
2 changed files with 17 additions and 1 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.55 2012/10/30 12:46:30 drochner Exp $
|
||||
$NetBSD: distinfo,v 1.56 2012/11/07 12:21:46 jperkin Exp $
|
||||
|
||||
SHA1 (webkitgtk-1.10.1.tar.xz) = 3a2df2eb42ffdd7f3b39873d5461c347a6330493
|
||||
RMD160 (webkitgtk-1.10.1.tar.xz) = ea246d29a1def4993d592d8464b527b2c9ed1bdc
|
||||
|
@ -6,6 +6,7 @@ Size (webkitgtk-1.10.1.tar.xz) = 8548452 bytes
|
|||
SHA1 (patch-Source_JavaScriptCore_heap_MachineStackMarker.cpp) = c5e1efdac5f6e2a4c035b6a3ce808d0e7a076703
|
||||
SHA1 (patch-Source_JavaScriptCore_wtf_Threading.h) = f166335d829aba9051c1aaf1b950ec655deef372
|
||||
SHA1 (patch-Source_WebCore_editing_Editor.h) = 43562577dd6432a86fd8ee0a1e7bb0db31f07d2d
|
||||
SHA1 (patch-Source_WebCore_platform_sql_SQLiteDatabase.cpp) = 0f33b188b242166584d5725060c5c430a819be61
|
||||
SHA1 (patch-ai) = 8df303ffde5c4398e56601c524e9ab4aff52096c
|
||||
SHA1 (patch-aj) = 930d1b5d73028b2f2e5abb33c15f72befadc64ce
|
||||
SHA1 (patch-ak) = 64ad843164f1c12968e933080e0966a9019abfdf
|
||||
|
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-Source_WebCore_platform_sql_SQLiteDatabase.cpp,v 1.1 2012/11/07 12:21:46 jperkin Exp $
|
||||
|
||||
Fix "error: 'yield' was not declared in this scope"
|
||||
|
||||
--- Source/WebCore/platform/sql/SQLiteDatabase.cpp.orig Wed Nov 7 07:59:38 2012
|
||||
+++ Source/WebCore/platform/sql/SQLiteDatabase.cpp Wed Nov 7 07:59:58 2012
|
||||
@@ -125,7 +125,7 @@
|
||||
if (!m_db)
|
||||
return;
|
||||
sqlite3_interrupt(m_db);
|
||||
- yield();
|
||||
+ WTF::yield();
|
||||
}
|
||||
|
||||
m_lockingMutex.unlock();
|
Loading…
Reference in a new issue