Don't use -fno-defer-pop.

This commit is contained in:
joerg 2013-11-04 16:39:32 +00:00
parent f79fae94b8
commit cd05220939
2 changed files with 67 additions and 3 deletions

View file

@ -1,4 +1,4 @@
$NetBSD: distinfo,v 1.72 2013/11/01 10:47:50 jaapb Exp $
$NetBSD: distinfo,v 1.73 2013/11/04 16:39:32 joerg Exp $
SHA1 (ocaml-4.01.0.tar.bz2) = a814feca204e50f082515a3845cdd18c6d0e24b6
RMD160 (ocaml-4.01.0.tar.bz2) = eedf28f446489c6b2c1f82782f5ee852293fc0b7
@ -10,7 +10,7 @@ SHA1 (patch-asmrun_power-bsd.S) = bd52898dde14adc1dbf9cd85a7f8af4d77218e6f
SHA1 (patch-asmrun_signals_osdep.h) = cc7131ef020563ae28c1fddbe8fe634174f73826
SHA1 (patch-byterun_Makefile) = 9681ce78c78879d29d9c58f35278a14e6cb18e96
SHA1 (patch-camlp4_man_Makefile) = c3a5dc09a2cc15d969c4e074be7da98a979f7db4
SHA1 (patch-configure) = 9bd9e64a34dcdfc8565ab58d1ee0879b6c17c88e
SHA1 (patch-configure) = 4f302dd5713060eb53a2255173406d9b9017d5a1
SHA1 (patch-debugger_Makefile.shared) = 583fa88caf965164aa3b638dda4c2a6e8878bdf9
SHA1 (patch-man_Makefile) = 3f52dd1fcbde53399852a6490d5f27fc7c1c98e5
SHA1 (patch-ocamldoc_Makefile) = d09c5f779dc1da9317d1c6e5eb4b251a9af45562

View file

@ -1,8 +1,72 @@
$NetBSD: patch-configure,v 1.6 2013/11/01 10:47:50 jaapb Exp $
$NetBSD: patch-configure,v 1.7 2013/11/04 16:39:32 joerg Exp $
Several configure changes to work on and detect NetBSD (and some other OSes)
--- configure.orig 2013-07-23 14:48:47.000000000 +0000
+++ configure
@@ -271,14 +271,14 @@ iflexdir=""
case "$bytecc,$host" in
cc,*-*-nextstep*)
# GNU C extensions disabled, but __GNUC__ still defined!
- bytecccompopts="-fno-defer-pop $gcc_warnings -U__GNUC__ -posix"
+ bytecccompopts="$gcc_warnings -U__GNUC__ -posix"
bytecclinkopts="-posix";;
*,*-*-rhapsody*)
# Almost the same as NeXTStep
- bytecccompopts="-fno-defer-pop $gcc_warnings -DSHRINKED_GNUC"
+ bytecccompopts="$gcc_warnings -DSHRINKED_GNUC"
mathlib="";;
*,*-*-darwin*)
- bytecccompopts="-fno-defer-pop $gcc_warnings"
+ bytecccompopts="$gcc_warnings"
mathlib=""
mkexe="$mkexe -Wl,-no_compact_unwind"
# Tell gcc that we can use 32-bit code addresses for threaded code
@@ -287,11 +287,11 @@ case "$bytecc,$host" in
echo "# define ARCH_CODE32" >> m.h
echo "#endif" >> m.h;;
*,*-*-beos*)
- bytecccompopts="-fno-defer-pop $gcc_warnings"
+ bytecccompopts="$gcc_warnings"
# No -lm library
mathlib="";;
gcc,alpha*-*-osf*)
- bytecccompopts="-fno-defer-pop $gcc_warnings"
+ bytecccompopts="$gcc_warnings"
if cc="$bytecc" sh ./hasgot -mieee; then
bytecccompopts="-mieee $bytecccompopts";
fi
@@ -319,11 +319,11 @@ case "$bytecc,$host" in
bytecccompopts="-DUMK";;
gcc*,powerpc-*-aix*)
# Avoid name-space pollution by requiring Unix98-conformant includes
- bytecccompopts="-fno-defer-pop $gcc_warnings -D_XOPEN_SOURCE=500";;
+ bytecccompopts="$gcc_warnings -D_XOPEN_SOURCE=500";;
*,powerpc-*-aix*)
bytecccompopts="-D_XOPEN_SOURCE=500";;
gcc*,*-*-cygwin*)
- bytecccompopts="-fno-defer-pop $gcc_warnings -U_WIN32"
+ bytecccompopts="$gcc_warnings -U_WIN32"
dllccompopts="-U_WIN32 -DCAML_DLL"
if test $withsharedlibs = yes; then
flexlink="flexlink -chain cygwin -merge-manifest -stack 16777216"
@@ -340,14 +340,14 @@ case "$bytecc,$host" in
exe=".exe"
ostype="Cygwin";;
gcc*,x86_64-*-linux*)
- bytecccompopts="-fno-defer-pop $gcc_warnings"
+ bytecccompopts="$gcc_warnings"
# Tell gcc that we can use 32-bit code addresses for threaded code
# unless we are compiled for a shared library (-fPIC option)
echo "#ifndef __PIC__" >> m.h
echo "# define ARCH_CODE32" >> m.h
echo "#endif" >> m.h;;
gcc*)
- bytecccompopts="-fno-defer-pop $gcc_warnings";;
+ bytecccompopts="$gcc_warnings";;
esac
# Configure compiler to use in further tests
@@ -542,7 +542,7 @@ if test $withsharedlibs = "yes"; then
mksharedlib="$flexlink"
mkmaindll="$flexlink -maindll"