Updated json-c to 0.12.1.

0.12.1

  * Minimal changes to address compile issues.
This commit is contained in:
wiz 2016-06-12 14:37:37 +00:00
parent d326cacdfa
commit cd2a4a8287
3 changed files with 7 additions and 28 deletions

View file

@ -1,7 +1,6 @@
# $NetBSD: Makefile,v 1.10 2014/07/17 09:18:27 obache Exp $
# $NetBSD: Makefile,v 1.11 2016/06/12 14:37:37 wiz Exp $
DISTNAME= json-c-0.12
PKGREVISION= 2
DISTNAME= json-c-0.12.1
CATEGORIES= textproc
MASTER_SITES= https://s3.amazonaws.com/json-c_releases/releases/

View file

@ -1,8 +1,7 @@
$NetBSD: distinfo,v 1.6 2015/11/04 01:59:37 agc Exp $
$NetBSD: distinfo,v 1.7 2016/06/12 14:37:37 wiz Exp $
SHA1 (json-c-0.12.tar.gz) = 5580aad884076c219d41160cbd8bc12213d12c37
RMD160 (json-c-0.12.tar.gz) = dd6b6560185dddca9b072a3d07af7899bd64cc45
SHA512 (json-c-0.12.tar.gz) = c959804362386f6b77e9d04b5fedf6d6aff1fcd0ab50250edb25f759b510b402e7ad4b33d1cbadc3337b63a3145d19f310812a9ee351748348304b384dc2dc35
Size (json-c-0.12.tar.gz) = 501419 bytes
SHA1 (patch-json__tokener.c) = 9f32a54060d7569f70c6892209e749cfea5b512d
SHA1 (json-c-0.12.1.tar.gz) = e7fcdbe41f1f3307c036f4e9e04b715de533896e
RMD160 (json-c-0.12.1.tar.gz) = fe4c2a4cf45ab4a74e74512fe6c6ea365e46a66c
SHA512 (json-c-0.12.1.tar.gz) = 038676a0ce815e5174161fbd4339524feadc294d517f732fb408ad6aa7c4906423451c13386107569d9f24746a1a101564ca511e92e8276c5bf5b8c022ca42ed
Size (json-c-0.12.1.tar.gz) = 535086 bytes
SHA1 (patch-linkhash.c) = cb56e1f6eaaa58170e26a9cfb4c87dfe73730c4c

View file

@ -1,19 +0,0 @@
$NetBSD: patch-json__tokener.c,v 1.1 2014/04/20 02:29:49 ryoon Exp $
https://github.com/json-c/json-c/pull/132
--- json_tokener.c.orig 2014-04-11 00:41:08.000000000 +0000
+++ json_tokener.c
@@ -352,12 +352,10 @@ struct json_object* json_tokener_parse_e
case json_tokener_state_inf: /* aka starts with 'i' */
{
- int size;
int size_inf;
int is_negative = 0;
printbuf_memappend_fast(tok->pb, &c, 1);
- size = json_min(tok->st_pos+1, json_null_str_len);
size_inf = json_min(tok->st_pos+1, json_inf_str_len);
char *infbuf = tok->pb->buf;
if (*infbuf == '-')