games/lgogdownloader: Install manpages into ${PKGMANDIR}.
This package uses CMake to configure the software. Include the GNUInstallDirs CMake module to define CMAKE_INSTALL_<dir> macros, and use CMAKE_INSTALL_MANDIR as the location for the installed manpages. The correct environment variables are passed so that ${CMAKE_INSTALL_MANDIR} points into ${PKGMANDIR}.
This commit is contained in:
parent
f3bf1f74e9
commit
cd31b5aa1a
2 changed files with 24 additions and 1 deletions
|
@ -1,6 +1,7 @@
|
|||
$NetBSD: distinfo,v 1.23 2017/03/12 07:24:06 wiz Exp $
|
||||
$NetBSD: distinfo,v 1.24 2017/08/19 00:21:43 jlam Exp $
|
||||
|
||||
SHA1 (lgogdownloader-3.2.tar.gz) = 70f0878039cc53c4399b4b6f7676695f690b63fa
|
||||
RMD160 (lgogdownloader-3.2.tar.gz) = adcda81a02614c27e70dee5f82b331b67eb9ba83
|
||||
SHA512 (lgogdownloader-3.2.tar.gz) = b1d8d89b303c77e17601b19e09346b8d632bc049d40741442ad88646d8764e4efd3a04edcbcae5a5e098df3251ae88d15d355d06cbb03cf313a8619d3111ff35
|
||||
Size (lgogdownloader-3.2.tar.gz) = 68438 bytes
|
||||
SHA1 (patch-man_CMakeLists.txt) = 2109d1d0c4b16920c6fb22a2b47cdb5d52b0556a
|
||||
|
|
22
games/lgogdownloader/patches/patch-man_CMakeLists.txt
Normal file
22
games/lgogdownloader/patches/patch-man_CMakeLists.txt
Normal file
|
@ -0,0 +1,22 @@
|
|||
$NetBSD: patch-man_CMakeLists.txt,v 1.1 2017/08/19 00:21:43 jlam Exp $
|
||||
|
||||
--- man/CMakeLists.txt.orig 2017-03-07 05:33:24.000000000 +0000
|
||||
+++ man/CMakeLists.txt
|
||||
@@ -3,6 +3,8 @@ find_program(GZIP gzip DOC "Location of
|
||||
mark_as_advanced(HELP2MAN)
|
||||
mark_as_advanced(GZIP)
|
||||
|
||||
+include(GNUInstallDirs)
|
||||
+
|
||||
if(HELP2MAN AND GZIP)
|
||||
set(H2M_FILE ${CMAKE_CURRENT_SOURCE_DIR}/${PROJECT_NAME}.supplemental.groff)
|
||||
set(MAN_PAGE ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.1)
|
||||
@@ -16,7 +18,7 @@ if(HELP2MAN AND GZIP)
|
||||
VERBATIM
|
||||
)
|
||||
add_custom_target(manpage ALL DEPENDS ${MAN_FILE} ${PROJECT_NAME})
|
||||
- install(FILES ${MAN_FILE} DESTINATION ${INSTALL_SHARE_DIR}/man/man1)
|
||||
+ install(FILES ${MAN_FILE} DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
|
||||
else(HELP2MAN AND GZIP)
|
||||
message("WARNING: One of the following is missing: help2man, gzip; man page will not be generated")
|
||||
endif(HELP2MAN AND GZIP)
|
Loading…
Reference in a new issue