Bump PKGREVISION from ibus shlib name change, with some ibus-1.4 compatibility

fix patches.
This commit is contained in:
obache 2012-04-22 14:09:09 +00:00
parent 11642d4e56
commit cd5ba4a17f
11 changed files with 161 additions and 14 deletions

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.5 2012/03/10 10:56:13 obache Exp $
# $NetBSD: Makefile,v 1.6 2012/04/22 14:09:09 obache Exp $
#
DISTNAME= ibus-array-0.0.2
PKGREVISION= 4
PKGREVISION= 5
CATEGORIES= inputmethod chinese
MASTER_SITES= http://ibus-array.googlecode.com/files/

View file

@ -1,5 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2010/08/07 01:53:41 obache Exp $
$NetBSD: distinfo,v 1.2 2012/04/22 14:09:09 obache Exp $
SHA1 (ibus-array-0.0.2.tar.gz) = 1b2c65b0a5d45f858014d892ec9036918ce85a54
RMD160 (ibus-array-0.0.2.tar.gz) = 40dbed9c00cc83855af05350da244f668fddb751
Size (ibus-array-0.0.2.tar.gz) = 2759103 bytes
SHA1 (patch-src_engine.c) = 35c7a1783dddeea99f40d319b6584b8b4f42c36e

View file

@ -0,0 +1,79 @@
$NetBSD: patch-src_engine.c,v 1.1 2012/04/22 14:09:10 obache Exp $
* for ibus-1.4
--- src/engine.c.orig 2009-10-18 17:06:12.000000000 +0000
+++ src/engine.c
@@ -79,7 +79,7 @@ static void ibus_array_engine_show_speci
static void ibus_config_value_changed (IBusConfig *config,
const gchar *section,
const gchar *name,
- GValue *value,
+ GVariant *value,
gpointer user_data);
static IBusEngineClass *parent_class = NULL;
@@ -120,7 +120,7 @@ void
ibus_array_init (IBusBus *bus)
{
gboolean res;
- GValue value = { 0, };
+ GVariant *value = NULL;
array_context = array_create_context();
@@ -129,20 +129,22 @@ ibus_array_init (IBusBus *bus)
is_special_notify = FALSE;
is_special_only = FALSE;
- res = ibus_config_get_value (config, "engine/Array",
- "SpecialNotify", &value);
+ res = ((value = ibus_config_get_value (config, "engine/Array",
+ "SpecialNotify")) != NULL);
if (res) {
- const gchar* str = g_value_get_string(&value);
+ const gchar* str = g_variant_get_string(value, NULL);
if (g_strcmp0(str, "1") == 0)
is_special_notify = TRUE;
+ g_variant_unref(value);
}
- res = ibus_config_get_value (config, "engine/Array",
- "SpecialOnly", &value);
+ res = ((value = ibus_config_get_value (config, "engine/Array",
+ "SpecialOnly")) != NULL);
if (res) {
- const gchar* str = g_value_get_string(&value);
+ const gchar* str = g_variant_get_string(value, NULL);
if (g_strcmp0(str, "1") == 0)
is_special_only = TRUE;
+ g_variant_unref(value);
}
}
@@ -754,14 +756,14 @@ static void ibus_array_engine_property_a
static void ibus_config_value_changed (IBusConfig *config,
const gchar *section,
const gchar *name,
- GValue *value,
+ GVariant *value,
gpointer user_data)
{
IBusArrayEngine *arrayeng = (IBusArrayEngine*)user_data;
if (g_strcmp0(section, "engine/Array") == 0) {
if (g_strcmp0(name, "SpecialNotify") == 0) {
- const gchar* str = g_value_get_string(value);
+ const gchar* str = g_variant_get_string(value, NULL);
if (g_strcmp0(str, "1") == 0) {
is_special_notify = TRUE;
}
@@ -770,7 +772,7 @@ static void ibus_config_value_changed (I
}
}
else if (g_strcmp0(name, "SpecialOnly") == 0) {
- const gchar* str = g_value_get_string(value);
+ const gchar* str = g_variant_get_string(value, NULL);
if (g_strcmp0(str, "1") == 0) {
is_special_only = TRUE;
}

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.12 2012/03/03 00:13:21 wiz Exp $
# $NetBSD: Makefile,v 1.13 2012/04/22 14:09:10 obache Exp $
#
DISTNAME= ibus-chewing-1.3.10-Source
PKGNAME= ${DISTNAME:S/-Source//}
PKGREVISION= 2
PKGREVISION= 3
CATEGORIES= inputmethod chinese
MASTER_SITES= http://ibus.googlecode.com/files/
@ -35,6 +35,13 @@ CMAKE_ARGS+= -DGCONF_SCHEMAS_INSTALLED_DIR=${GCONF_SCHEMAS_DIR}
post-extract:
find ${WRKDIR} -type d -name PaxHeader | xargs rm -rf
# avoid regen files
post-patch:
touch -r ${WRKSRC}/src/IBusChewingEngine-input-events.c.orig \
${WRKSRC}/src/IBusChewingEngine-input-events.c
touch -r ${WRKSRC}/src/IBusChewingEngine.gob.orig \
${WRKSRC}/src/IBusChewingEngine.gob
.include "../../devel/GConf/schemas.mk"
.include "../../inputmethod/ibus/buildlink3.mk"
.include "../../inputmethod/libchewing/buildlink3.mk"

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.5 2011/12/04 12:40:42 obache Exp $
$NetBSD: distinfo,v 1.6 2012/04/22 14:09:10 obache Exp $
SHA1 (ibus-chewing-1.3.10-Source.tar.gz) = e9f92370c1ad99d5076b4e288704fadb759928be
RMD160 (ibus-chewing-1.3.10-Source.tar.gz) = 84d4167a0d2c4019f165280cabea2afeaaee4464
Size (ibus-chewing-1.3.10-Source.tar.gz) = 75365 bytes
SHA1 (patch-src_IBusChewingEngine-input-events.c) = 7ebb4869bee3068814bb3fa6c195a6f88e481ed3
SHA1 (patch-src_IBusChewingEngine.gob) = 5b92bbdb7e79252eb5b166f2d5eccc5c076e06e1

View file

@ -0,0 +1,28 @@
$NetBSD: patch-src_IBusChewingEngine-input-events.c,v 1.1 2012/04/22 14:09:10 obache Exp $
* for ibus-1.4
https://github.com/definite/ibus-chewing/pull/16
--- src/IBusChewingEngine-input-events.c.orig 2011-10-12 11:50:51.000000000 +0000
+++ src/IBusChewingEngine-input-events.c
@@ -291,12 +291,20 @@ void ibus_chewing_engine_property_activa
/* Toggle Full <-> Half */
chewing_set_ShapeMode(self->context, !chewing_get_ShapeMode(self->context));
}else if (strcmp(prop_name,"chewing_settings_prop")==0){
+#if IBUS_CHECK_VERSION(1, 4, 0)
+ if (ibus_property_get_state(self->settings_prop)==PROP_STATE_UNCHECKED){
+#else
if (self->settings_prop->state==PROP_STATE_UNCHECKED){
+#endif
if (gtk_dialog_run(GTK_DIALOG(self->setting_dialog))==GTK_RESPONSE_OK){
self_save_config_all(self);
}
gtk_widget_hide(self->setting_dialog);
+#if IBUS_CHECK_VERSION(1, 4, 0)
+ ibus_property_set_state(self->settings_prop,PROP_STATE_UNCHECKED);
+#else
self->settings_prop->state=PROP_STATE_UNCHECKED;
+#endif
}
}else{
G_DEBUG_MSG(3,"[I3] property_activate(-, %s, %u) not recognized",prop_name, prop_state);

View file

@ -0,0 +1,30 @@
$NetBSD: patch-src_IBusChewingEngine.gob,v 1.1 2012/04/22 14:09:10 obache Exp $
* for ibus-1.4
https://github.com/definite/ibus-chewing/pull/16
--- src/IBusChewingEngine.gob.orig 2011-10-12 11:50:51.000000000 +0000
+++ src/IBusChewingEngine.gob
@@ -1041,12 +1041,21 @@ class IBus:Chewing:Engine from IBus:Engi
/* Toggle Full <-> Half */
chewing_set_ShapeMode(self->context, !chewing_get_ShapeMode(self->context));
}else if (strcmp(prop_name,"chewing_settings_prop")==0){
- if (self->settings_prop->state==PROP_STATE_UNCHECKED){
+#if IBUS_CHECK_VERSION(1, 4, 0)
+ if (ibus_property_get_state(self->settings_prop)==PROP_STATE_UNCHECKED)
+#else
+ if (self->settings_prop->state==PROP_STATE_UNCHECKED)
+#endif
+ {
if (gtk_dialog_run(GTK_DIALOG(self->setting_dialog))==GTK_RESPONSE_OK){
self_save_config_all(self);
}
gtk_widget_hide(self->setting_dialog);
+#if IBUS_CHECK_VERSION(1, 4, 0)
+ ibus_property_set_state(self->settings_prop,PROP_STATE_UNCHECKED);
+#else
self->settings_prop->state=PROP_STATE_UNCHECKED;
+#endif
}
}else{
G_DEBUG_MSG(3,"[I3] property_activate(-, %s, %u) not recognized",prop_name, prop_state);

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.14 2012/03/03 00:13:21 wiz Exp $
# $NetBSD: Makefile,v 1.15 2012/04/22 14:09:10 obache Exp $
#
DISTNAME= ibus-handwrite-2.1.4
PKGREVISION= 4
PKGREVISION= 5
CATEGORIES= inputmethod
MASTER_SITES= http://ibus-handwrite.googlecode.com/files/
EXTRACT_SUFX= .tar.bz2

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.12 2012/03/03 00:13:21 wiz Exp $
# $NetBSD: Makefile,v 1.13 2012/04/22 14:09:10 obache Exp $
#
DISTNAME= ibus-m17n-1.3.3
PKGREVISION= 3
PKGREVISION= 4
CATEGORIES= inputmethod
MASTER_SITES= http://ibus.googlecode.com/files/

View file

@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.13 2012/03/03 00:13:21 wiz Exp $
# $NetBSD: Makefile,v 1.14 2012/04/22 14:09:10 obache Exp $
#
DISTNAME= ibus-qt-1.3.1-Source
PKGNAME= ${DISTNAME:S/-Source//}
PKGREVISION= 10
PKGREVISION= 11
CATEGORIES= inputmethod
MASTER_SITES= http://ibus.googlecode.com/files/

View file

@ -1,8 +1,8 @@
# $NetBSD: Makefile,v 1.8 2012/03/03 00:13:21 wiz Exp $
# $NetBSD: Makefile,v 1.9 2012/04/22 14:09:10 obache Exp $
#
DISTNAME= ibus-t9-2.1.0.20100601
PKGREVISION= 8
PKGREVISION= 9
CATEGORIES= inputmethod chinese
MASTER_SITES= http://ibus-t9.googlecode.com/files/