Initial import of libdmapsharing, version 2.1.9:

Libdmapsharing is a library you may use to access and share media content
using DMAP (DAAP, DPAP & DACP).  The library presently supports Linux and
other POSIX-based systems.  It is written in C using GObject and libsoup.

The DMAP family of protocols are used by products such as Apple iTunes(TM),
Apple iPhoto(TM), and the Roku SoundBridge(TM) family to share media such
as music and photos.

Possible uses for libdmapsharing include:

* Adding picture sharing capabilities to a photograph application.
* Adding music sharing capabilities to an audio application.
* Developing DPAP server software for a home networking product.
* Developing DMAP client software for a media player appliance.
This commit is contained in:
jmmv 2011-01-19 23:30:11 +00:00
parent 7b0284466d
commit cd73551ce9
6 changed files with 150 additions and 0 deletions

14
net/libdmapsharing/DESCR Normal file
View file

@ -0,0 +1,14 @@
Libdmapsharing is a library you may use to access and share media content
using DMAP (DAAP, DPAP & DACP). The library presently supports Linux and
other POSIX-based systems. It is written in C using GObject and libsoup.
The DMAP family of protocols are used by products such as Apple iTunes(TM),
Apple iPhoto(TM), and the Roku SoundBridge(TM) family to share media such
as music and photos.
Possible uses for libdmapsharing include:
* Adding picture sharing capabilities to a photograph application.
* Adding music sharing capabilities to an audio application.
* Developing DPAP server software for a home networking product.
* Developing DMAP client software for a media player appliance.

View file

@ -0,0 +1,28 @@
# $NetBSD: Makefile,v 1.1.1.1 2011/01/19 23:30:11 jmmv Exp $
DISTNAME= libdmapsharing-2.1.9
CATEGORIES= net
MASTER_SITES= http://www.flyn.org/projects/libdmapsharing/
MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= Implementation of the DMAP family of protocols
HOMEPAGE= http://www.flyn.org/projects/libdmapsharing/
PKG_DESTDIR_SUPPORT= user-destdir
GNU_CONFIGURE= yes
LICENSE= gnu-lgpl-v2.1
USE_LIBTOOL= yes
USE_TOOLS= gmake pkg-config
PKGCONFIG_OVERRIDE= libdmapsharing.pc.in
BUILDLINK_ABI_DEPENDS.gst-plugins0.10-base+= gst-plugins0.10-base>=0.10.23.2
BUILDLINK_ABI_DEPENDS.libsoup24+= libsoup24>=2.32
.include "../../devel/glib2/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../multimedia/gst-plugins0.10-base/buildlink3.mk"
.include "../../net/avahi/buildlink3.mk"
.include "../../net/libsoup24/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

56
net/libdmapsharing/PLIST Normal file
View file

@ -0,0 +1,56 @@
@comment $NetBSD: PLIST,v 1.1.1.1 2011/01/19 23:30:12 jmmv Exp $
include/libdmapsharing-2.2/libdmapsharing/daap-record.h
include/libdmapsharing-2.2/libdmapsharing/daap-share.h
include/libdmapsharing-2.2/libdmapsharing/dacp-player.h
include/libdmapsharing-2.2/libdmapsharing/dacp-share.h
include/libdmapsharing-2.2/libdmapsharing/dmap-connection.h
include/libdmapsharing-2.2/libdmapsharing/dmap-container-db.h
include/libdmapsharing-2.2/libdmapsharing/dmap-container-record.h
include/libdmapsharing-2.2/libdmapsharing/dmap-db.h
include/libdmapsharing-2.2/libdmapsharing/dmap-md5.h
include/libdmapsharing-2.2/libdmapsharing/dmap-mdns-browser.h
include/libdmapsharing-2.2/libdmapsharing/dmap-mdns-publisher.h
include/libdmapsharing-2.2/libdmapsharing/dmap-record-factory.h
include/libdmapsharing-2.2/libdmapsharing/dmap-record.h
include/libdmapsharing-2.2/libdmapsharing/dmap-share.h
include/libdmapsharing-2.2/libdmapsharing/dmap.h
include/libdmapsharing-2.2/libdmapsharing/dpap-record.h
include/libdmapsharing-2.2/libdmapsharing/dpap-share.h
lib/libdmapsharing.la
lib/pkgconfig/libdmapsharing-2.2.pc
share/gtk-doc/html/libdmapsharing/DAAPRecord.html
share/gtk-doc/html/libdmapsharing/DAAPShare.html
share/gtk-doc/html/libdmapsharing/DACPShare.html
share/gtk-doc/html/libdmapsharing/DMAPConnection.html
share/gtk-doc/html/libdmapsharing/DMAPContainerDb.html
share/gtk-doc/html/libdmapsharing/DMAPContainerRecord.html
share/gtk-doc/html/libdmapsharing/DMAPDb.html
share/gtk-doc/html/libdmapsharing/DMAPMdnsBrowser.html
share/gtk-doc/html/libdmapsharing/DMAPRecord.html
share/gtk-doc/html/libdmapsharing/DMAPRecordFactory.html
share/gtk-doc/html/libdmapsharing/DMAPShare.html
share/gtk-doc/html/libdmapsharing/DPAPRecord.html
share/gtk-doc/html/libdmapsharing/api-index-full.html
share/gtk-doc/html/libdmapsharing/browserapi.html
share/gtk-doc/html/libdmapsharing/ch01.html
share/gtk-doc/html/libdmapsharing/ch02.html
share/gtk-doc/html/libdmapsharing/ch03.html
share/gtk-doc/html/libdmapsharing/ch04.html
share/gtk-doc/html/libdmapsharing/client-internals.html
share/gtk-doc/html/libdmapsharing/connectedcb.html
share/gtk-doc/html/libdmapsharing/containerdb.html
share/gtk-doc/html/libdmapsharing/home.png
share/gtk-doc/html/libdmapsharing/index.html
share/gtk-doc/html/libdmapsharing/index.sgml
share/gtk-doc/html/libdmapsharing/left.png
share/gtk-doc/html/libdmapsharing/libdmapsharing-DPAPShare.html
share/gtk-doc/html/libdmapsharing/libdmapsharing.devhelp
share/gtk-doc/html/libdmapsharing/libdmapsharing.devhelp2
share/gtk-doc/html/libdmapsharing/mediadb.html
share/gtk-doc/html/libdmapsharing/object-tree.html
share/gtk-doc/html/libdmapsharing/right.png
share/gtk-doc/html/libdmapsharing/server-internals.html
share/gtk-doc/html/libdmapsharing/serviceaddedcb.html
share/gtk-doc/html/libdmapsharing/shareapi.html
share/gtk-doc/html/libdmapsharing/style.css
share/gtk-doc/html/libdmapsharing/up.png

View file

@ -0,0 +1,13 @@
# $NetBSD: buildlink3.mk,v 1.1.1.1 2011/01/19 23:30:12 jmmv Exp $
BUILDLINK_TREE+= libdmapsharing
.if !defined(LIBDMAPSHARING_BUILDLINK3_MK)
LIBDMAPSHARING_BUILDLINK3_MK:=
BUILDLINK_API_DEPENDS.libdmapsharing+= libdmapsharing>=2.1.9
BUILDLINK_PKGSRCDIR.libdmapsharing?= ../../net/libdmapsharing
.endif # LIBDMAPSHARING_BUILDLINK3_MK
BUILDLINK_TREE+= -libdmapsharing

View file

@ -0,0 +1,6 @@
$NetBSD: distinfo,v 1.1.1.1 2011/01/19 23:30:12 jmmv Exp $
SHA1 (libdmapsharing-2.1.9.tar.gz) = d31a41e5ce296896e68ae854d60a84d7ac463d52
RMD160 (libdmapsharing-2.1.9.tar.gz) = 089870d145355ad9f5552b10d5c9d0dda1596db9
Size (libdmapsharing-2.1.9.tar.gz) = 644796 bytes
SHA1 (patch-aa) = 91697ea045dc2487ef683e4f7a268ff929d67beb

View file

@ -0,0 +1,33 @@
$NetBSD: patch-aa,v 1.1.1.1 2011/01/19 23:30:12 jmmv Exp $
https://bugzilla.gnome.org/show_bug.cgi?id=640004
--- configure.orig 2011-01-19 02:06:38.000000000 +0000
+++ configure
@@ -12503,7 +12503,7 @@ $as_echo "yes" >&6; }
HAVE_AVAHI_05=yes
fi
fi
-if test x$HAVE_AVAHI_06 == xyes || test x$HAVE_AVAHI_05 == xyes; then
+if test x$HAVE_AVAHI_06 = xyes || test x$HAVE_AVAHI_05 = xyes; then
HAVE_AVAHI=yes
else
HAVE_AVAHI=no
@@ -12652,7 +12652,7 @@ $as_echo "#define WITH_AVAHI 1" >>confde
USE_AVAHI=yes
{ $as_echo "$as_me:${as_lineno-$LINENO}: Detected Avahi, using it for mDNS/DNS-SD" >&5
$as_echo "$as_me: Detected Avahi, using it for mDNS/DNS-SD" >&6;}
- if test x$HAVE_AVAHI_06 == xyes; then
+ if test x$HAVE_AVAHI_06 = xyes; then
$as_echo "#define HAVE_AVAHI_0_6 1" >>confdefs.h
@@ -12859,7 +12859,7 @@ $as_echo "#define WITH_AVAHI 1" >>confde
{ $as_echo "$as_me:${as_lineno-$LINENO}: Using Avahi for mDNS/DNS-SD" >&5
$as_echo "$as_me: Using Avahi for mDNS/DNS-SD" >&6;}
- if test x$HAVE_AVAHI_06 == xyes; then
+ if test x$HAVE_AVAHI_06 = xyes; then
$as_echo "#define HAVE_AVAHI_0_6 1" >>confdefs.h