Make package build using Sun Studio.

This commit is contained in:
sketch 2009-01-26 20:09:48 +00:00
parent 5c3fc716c7
commit cd89d087fd
3 changed files with 38 additions and 1 deletions

View file

@ -1,5 +1,7 @@
$NetBSD: distinfo,v 1.2 2008/04/14 09:39:00 wiz Exp $
$NetBSD: distinfo,v 1.3 2009/01/26 20:09:48 sketch Exp $
SHA1 (hunspell-1.2.2.tar.gz) = 521063ff64b2182e92e92f5355ae2cf396f39420
RMD160 (hunspell-1.2.2.tar.gz) = 110c428f2b6734afefb8865dc3d63a4492594552
Size (hunspell-1.2.2.tar.gz) = 752046 bytes
SHA1 (patch-aa) = 47dbec62c0ffe972275cc7e554a35d8acdbf495a
SHA1 (patch-ab) = 01ff90fc2ebf1049d791a0669ddcc3f5495729c0

View file

@ -0,0 +1,15 @@
$NetBSD: patch-aa,v 1.1 2009/01/26 20:09:48 sketch Exp $
--- src/hunspell/hunzip.hxx.orig Mon Jan 26 19:52:29 2009
+++ src/hunspell/hunzip.hxx Mon Jan 26 19:59:16 2009
@@ -4,6 +4,10 @@
#ifndef _HUNZIP_HXX_
#define _HUNZIP_HXX_
+#ifdef __SUNPRO_CC
+#include <iostream>
+#endif
+
#define BUFSIZE 65536
#define HZIP_EXTENSION ".hz"

View file

@ -0,0 +1,20 @@
$NetBSD: patch-ab,v 1.1 2009/01/26 20:09:48 sketch Exp $
--- src/hunspell/phonet.cxx.orig Mon Jan 26 19:59:48 2009
+++ src/hunspell/phonet.cxx Mon Jan 26 20:05:39 2009
@@ -42,6 +42,15 @@
#include "csutil.hxx"
#include "phonet.hxx"
+#ifdef __SUNPRO_CC
+using std::isalpha;
+using std::isdigit;
+using std::strchr;
+using std::strcpy;
+using std::strlen;
+using std::strstr;
+#endif
+
void init_phonet_hash(phonetable & parms)
{
int i, k;