Fix build by using the new thunar library.
This commit is contained in:
parent
3320ca28b1
commit
cd9cb3d8bc
5 changed files with 113 additions and 3 deletions
|
@ -1,5 +1,5 @@
|
|||
@comment $NetBSD: PLIST,v 1.2 2017/06/20 12:20:39 youri Exp $
|
||||
lib/thunarx-2/thunar-vcs-plugin.la
|
||||
@comment $NetBSD: PLIST,v 1.3 2018/05/19 11:47:11 youri Exp $
|
||||
lib/thunarx-3/thunar-vcs-plugin.la
|
||||
libexec/tvp-git-helper
|
||||
libexec/tvp-svn-helper
|
||||
share/icons/hicolor/24x24/apps/git.png
|
||||
|
|
|
@ -1,6 +1,9 @@
|
|||
$NetBSD: distinfo,v 1.3 2017/06/20 12:20:39 youri Exp $
|
||||
$NetBSD: distinfo,v 1.4 2018/05/19 11:47:11 youri Exp $
|
||||
|
||||
SHA1 (thunar-vcs-plugin-0.1.5.tar.bz2) = e1139bf900a8b68027c770ad4b1e11a0060e5d28
|
||||
RMD160 (thunar-vcs-plugin-0.1.5.tar.bz2) = 69df1ce992a5327c16fd309ee343afd7585a43a8
|
||||
SHA512 (thunar-vcs-plugin-0.1.5.tar.bz2) = 0315613fe97d5cb2fa9589af49bdb5074f20c83b52d5f7d4a151091839679b4617e8e0b20df85914b7bcef2464173dc1bd2bc182312364c7d5a94171aba28983
|
||||
Size (thunar-vcs-plugin-0.1.5.tar.bz2) = 478866 bytes
|
||||
SHA1 (patch-configure) = 61eea462574a3f39e40f0bfd13c3a957d6ce6bd2
|
||||
SHA1 (patch-thunar-vcs-plugin_Makefile.in) = 87b1f940741b0225d465be668f09064328fa8c8d
|
||||
SHA1 (patch-thunar-vcs-plugin_tvp-provider.c) = 3aac15ab3256f584263d3a2ad9b34a62f517c5da
|
||||
|
|
75
sysutils/xfce4-thunar-vcs/patches/patch-configure
Normal file
75
sysutils/xfce4-thunar-vcs/patches/patch-configure
Normal file
|
@ -0,0 +1,75 @@
|
|||
$NetBSD: patch-configure,v 1.1 2018/05/19 11:47:11 youri Exp $
|
||||
|
||||
Use thunarx-3.
|
||||
|
||||
--- configure.orig 2018-05-19 11:34:57.000000000 +0000
|
||||
+++ configure
|
||||
@@ -597,7 +597,7 @@ PACKAGE_STRING='thunar-vcs-plugin 0.1.5'
|
||||
PACKAGE_BUGREPORT='thunar-dev@xfce.org'
|
||||
PACKAGE_URL=''
|
||||
|
||||
-ac_default_prefix=$(pkg-config --variable prefix thunarx-2 || echo /usr/local)
|
||||
+ac_default_prefix=$(pkg-config --variable prefix thunarx-3 || echo /usr/local)
|
||||
# Factoring default headers for most tests.
|
||||
ac_includes_default="\
|
||||
#include <stdio.h>
|
||||
@@ -14049,22 +14049,22 @@ fi
|
||||
|
||||
|
||||
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for thunarx-2 >= 1.2.0" >&5
|
||||
-$as_echo_n "checking for thunarx-2 >= 1.2.0... " >&6; }
|
||||
- if $PKG_CONFIG "--atleast-version=1.2.0" "thunarx-2" >/dev/null 2>&1; then
|
||||
- THUNARX_VERSION=`$PKG_CONFIG --modversion "thunarx-2"`
|
||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for thunarx-3 >= 1.2.0" >&5
|
||||
+$as_echo_n "checking for thunarx-3 >= 1.2.0... " >&6; }
|
||||
+ if $PKG_CONFIG "--atleast-version=1.2.0" "thunarx-3" >/dev/null 2>&1; then
|
||||
+ THUNARX_VERSION=`$PKG_CONFIG --modversion "thunarx-3"`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $THUNARX_VERSION" >&5
|
||||
$as_echo "$THUNARX_VERSION" >&6; }
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking THUNARX_CFLAGS" >&5
|
||||
$as_echo_n "checking THUNARX_CFLAGS... " >&6; }
|
||||
- THUNARX_CFLAGS=`$PKG_CONFIG --cflags "thunarx-2"`
|
||||
+ THUNARX_CFLAGS=`$PKG_CONFIG --cflags "thunarx-3"`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $THUNARX_CFLAGS" >&5
|
||||
$as_echo "$THUNARX_CFLAGS" >&6; }
|
||||
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking THUNARX_LIBS" >&5
|
||||
$as_echo_n "checking THUNARX_LIBS... " >&6; }
|
||||
- THUNARX_LIBS=`$PKG_CONFIG --libs "thunarx-2"`
|
||||
+ THUNARX_LIBS=`$PKG_CONFIG --libs "thunarx-3"`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $THUNARX_LIBS" >&5
|
||||
$as_echo "$THUNARX_LIBS" >&6; }
|
||||
|
||||
@@ -14076,15 +14076,15 @@ $as_echo "$THUNARX_LIBS" >&6; }
|
||||
|
||||
|
||||
|
||||
- elif $PKG_CONFIG --exists "thunarx-2" >/dev/null 2>&1; then
|
||||
- xdt_cv_version=`$PKG_CONFIG --modversion "thunarx-2"`
|
||||
+ elif $PKG_CONFIG --exists "thunarx-3" >/dev/null 2>&1; then
|
||||
+ xdt_cv_version=`$PKG_CONFIG --modversion "thunarx-3"`
|
||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: found, but $xdt_cv_version" >&5
|
||||
$as_echo "found, but $xdt_cv_version" >&6; }
|
||||
|
||||
|
||||
- echo "*** The required package thunarx-2 was found on your system,"
|
||||
+ echo "*** The required package thunarx-3 was found on your system,"
|
||||
echo "*** but the installed version ($xdt_cv_version) is too old."
|
||||
- echo "*** Please upgrade thunarx-2 to atleast version 1.2.0, or adjust"
|
||||
+ echo "*** Please upgrade thunarx-3 to atleast version 1.2.0, or adjust"
|
||||
echo "*** the PKG_CONFIG_PATH environment variable if you installed"
|
||||
echo "*** the new version of the package in a nonstandard prefix so"
|
||||
echo "*** pkg-config is able to find it."
|
||||
@@ -14095,8 +14095,8 @@ $as_echo "found, but $xdt_cv_version" >&
|
||||
$as_echo "not found" >&6; }
|
||||
|
||||
|
||||
- echo "*** The required package thunarx-2 was not found on your system."
|
||||
- echo "*** Please install thunarx-2 (atleast version 1.2.0) or adjust"
|
||||
+ echo "*** The required package thunarx-3 was not found on your system."
|
||||
+ echo "*** Please install thunarx-3 (atleast version 1.2.0) or adjust"
|
||||
echo "*** the PKG_CONFIG_PATH environment variable if you"
|
||||
echo "*** installed the package in a nonstandard prefix so that"
|
||||
echo "*** pkg-config is able to find it."
|
|
@ -0,0 +1,15 @@
|
|||
$NetBSD: patch-thunar-vcs-plugin_Makefile.in,v 1.1 2018/05/19 11:47:11 youri Exp $
|
||||
|
||||
Install to the new thunar plugin path.
|
||||
|
||||
--- thunar-vcs-plugin/Makefile.in.orig 2018-05-19 11:21:58.000000000 +0000
|
||||
+++ thunar-vcs-plugin/Makefile.in
|
||||
@@ -440,7 +440,7 @@ AM_CPPFLAGS = \
|
||||
-DPACKAGE_LOCALE_DIR=\"$(localedir)\" \
|
||||
$(PLATFORM_CPPFLAGS)
|
||||
|
||||
-extensionsdir = $(libdir)/thunarx-2
|
||||
+extensionsdir = $(libdir)/thunarx-3
|
||||
extensions_LTLIBRARIES = \
|
||||
thunar-vcs-plugin.la
|
||||
|
|
@ -0,0 +1,17 @@
|
|||
$NetBSD: patch-thunar-vcs-plugin_tvp-provider.c,v 1.1 2018/05/19 11:47:11 youri Exp $
|
||||
|
||||
Update to reflect new thunarx API.
|
||||
|
||||
--- thunar-vcs-plugin/tvp-provider.c.orig 2016-06-29 20:09:32.000000000 +0000
|
||||
+++ thunar-vcs-plugin/tvp-provider.c
|
||||
@@ -134,8 +134,8 @@ tvp_provider_class_init (TvpProviderClas
|
||||
static void
|
||||
tvp_provider_menu_provider_init (ThunarxMenuProviderIface *iface)
|
||||
{
|
||||
- iface->get_file_actions = tvp_provider_get_file_actions;
|
||||
- iface->get_folder_actions = tvp_provider_get_folder_actions;
|
||||
+ iface->get_file_menu_items = tvp_provider_get_file_actions;
|
||||
+ iface->get_folder_menu_items = tvp_provider_get_folder_actions;
|
||||
}
|
||||
|
||||
|
Loading…
Reference in a new issue