Update john to 1.7.3.1. Add license. Update patch-aa.

Changelog:
The following changes have been made between John 1.7.3 and 1.7.3.1:

* Corrected the x86 assembly files for building on Mac OS X.
* Merged in some generic changes from JtR Pro.

The following changes have been made between John 1.7.2 and 1.7.3:

* Two Blowfish-based crypt(3) hashes may now be computed in parallel for much
better performance on modern multi-issue CPUs with a sufficient number of
registers (e.g., x86-64).
* Bitslice DES assembly code for x86-64 has been converted to use
instruction pointer relative addressing (needed for Mac OS X support).
* New make targets: macosx-universal, macosx-x86-64, solaris-x86-64-cc,
solaris-x86-64-gcc, solaris-x86-sse2-cc, solaris-x86-sse2-gcc,
solaris-x86-mmx-cc, solaris-x86-mmx-gcc, solaris-x86-any-cc, linux-ia64;
other changes to the Makefile.
* Minor bug fixes.
* "DumbForce" and "KnownForce" external mode samples have been added to the
default john.conf.
This commit is contained in:
zafer 2009-08-06 19:14:52 +00:00
parent dc4ee19bc7
commit cdcc298e59
3 changed files with 15 additions and 30 deletions

View file

@ -1,14 +1,14 @@
# $NetBSD: Makefile,v 1.16 2009/02/10 16:39:40 joerg Exp $
# $NetBSD: Makefile,v 1.17 2009/08/06 19:14:52 zafer Exp $
#
DISTNAME= john-1.7.2
DISTNAME= john-1.7.3.1
CATEGORIES= security textproc
MASTER_SITES= http://www.openwall.com/john/f/
EXTRACT_SUFX= .tar.bz2
MASTER_SITES= http://www.openwall.com/john/g/
MAINTAINER= DawS@irc.pl
MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= http://www.openwall.com/john/
COMMENT= Unix Password Cracker
LICENSE= gnu-gpl-v2
PKG_DESTDIR_SUPPORT= user-destdir

View file

@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.9 2007/02/03 17:09:20 sborrill Exp $
$NetBSD: distinfo,v 1.10 2009/08/06 19:14:52 zafer Exp $
SHA1 (john-1.7.2.tar.bz2) = 7cc994f9cbd1582b46cbdeb1d5f318891ea8b411
RMD160 (john-1.7.2.tar.bz2) = 3754da88a98f1c120e28de1eb10b214bf7dd3baf
Size (john-1.7.2.tar.bz2) = 691706 bytes
SHA1 (patch-aa) = e458b6c2423f625ef30a36a96e79bac69fae297f
SHA1 (john-1.7.3.1.tar.gz) = 29a283933219dabe0f363618a0c8a083e79e6748
RMD160 (john-1.7.3.1.tar.gz) = c810466241889f307c0e7096bcdd4fb39d8638ca
Size (john-1.7.3.1.tar.gz) = 814903 bytes
SHA1 (patch-aa) = 8becb91335178bfeec8f1f0f31753fea116c74c7
SHA1 (patch-ab) = 331fa2333860879edabdbf1beeb3323d303406ec

View file

@ -1,28 +1,13 @@
$NetBSD: patch-aa,v 1.5 2007/02/03 17:09:21 sborrill Exp $
$NetBSD: patch-aa,v 1.6 2009/08/06 19:14:52 zafer Exp $
--- src/Makefile.orig 2006-05-15 17:38:00.000000000 +0100
+++ src/Makefile 2007-02-03 16:13:58.000000000 +0000
@@ -3,10 +3,10 @@
# Copyright (c) 1996-2006 by Solar Designer
#
-CPP = gcc
-CC = gcc
-AS = gcc
-LD = gcc
+#CPP = gcc
+#CC = gcc
+AS = $(CC)
+LD = $(CC)
CP = cp
LN = ln -sf
RM = rm -f
@@ -15,11 +15,11 @@
--- src/Makefile.orig 2009-08-06 20:58:11.000000000 +0200
+++ src/Makefile
@@ -15,11 +15,11 @@ SED = sed
PERL = perl
NULL = /dev/null
CPPFLAGS = -E
-CFLAGS = -c -Wall -O2 -fomit-frame-pointer
+CFLAGS += -c
+CFLAGS = -c
ASFLAGS = -c
-LDFLAGS = -s
-OPT_NORMAL = -funroll-loops