Linux doesn't define PPP_FCS() in <net/ppp_defs.h> for userland. pppdump.c
expects PPP_FCS() to be defined however, and compilation therefore breaks in the presence of the previous version of this patch. This version of the patch reverts back to the behaviour of the distribution code for non-NetBSD systems, but retains the Pkgsrc patched behaviour of pulling in the system copy of the header file for NetBSD and DragonFly. This should only affect success or failure of the package build, so no PKGREVISION bump.
This commit is contained in:
parent
6de948e3aa
commit
ce101fe9af
2 changed files with 14 additions and 11 deletions
|
@ -1,4 +1,4 @@
|
|||
$NetBSD: distinfo,v 1.8 2008/12/30 12:03:02 hasso Exp $
|
||||
$NetBSD: distinfo,v 1.9 2009/08/06 15:41:54 dsainty Exp $
|
||||
|
||||
SHA1 (ppp-2.4.3.tar.gz) = 5e2789f4dedc81943fa9f94c840cccc2407056f7
|
||||
RMD160 (ppp-2.4.3.tar.gz) = 845821496bacb07d93bb7572a171854853ef722b
|
||||
|
@ -37,7 +37,7 @@ SHA1 (patch-be) = e216f70f5fd2d6f5ad44a3c3ebc6146557a2deb9
|
|||
SHA1 (patch-bf) = 16788a1508cd981ff8967915a86a1fb02e55330c
|
||||
SHA1 (patch-bg) = 66b7d5a1ac2816f36a656c7c16a4862f313633f0
|
||||
SHA1 (patch-bh) = 8136e968fadbc2cc08006651772b943313cb6641
|
||||
SHA1 (patch-bi) = 75a3260bc8ddb7abf21e21656d95c5a47931c493
|
||||
SHA1 (patch-bi) = b7580e06651386da79b2c0eedc8a1b7c25e96cde
|
||||
SHA1 (patch-bj) = ad5618b6243414ce2649b200096a53194f48c735
|
||||
SHA1 (patch-bk) = 2ebb4e4133c22775e374990a6e05390f826d3e91
|
||||
SHA1 (patch-bl) = 31525cf95919a534804c95121f7e69289c4220cb
|
||||
|
|
|
@ -1,17 +1,20 @@
|
|||
$NetBSD: patch-bi,v 1.2 2008/12/26 21:41:40 hasso Exp $
|
||||
$NetBSD: patch-bi,v 1.3 2009/08/06 15:41:54 dsainty Exp $
|
||||
|
||||
--- pppdump/pppdump.c.orig 2004-02-01 19:36:46 -0800
|
||||
+++ pppdump/pppdump.c 2008-12-10 03:22:59 -0800
|
||||
@@ -38,8 +38,17 @@
|
||||
@@ -38,8 +38,21 @@
|
||||
#include <stdlib.h>
|
||||
#include <time.h>
|
||||
#include <sys/types.h>
|
||||
-#include "ppp_defs.h"
|
||||
+#include "pppdump.h"
|
||||
+#ifdef __DragonFly__
|
||||
+#include <net/ppp_layer/ppp_defs.h>
|
||||
+#else
|
||||
+#ifdef __NetBSD__
|
||||
+#include <net/ppp_defs.h>
|
||||
+#else
|
||||
#include "ppp_defs.h"
|
||||
+#endif
|
||||
+#endif
|
||||
+#ifdef __NetBSD__
|
||||
+#include <net/ppp-comp.h>
|
||||
|
@ -21,7 +24,7 @@ $NetBSD: patch-bi,v 1.2 2008/12/26 21:41:40 hasso Exp $
|
|||
|
||||
int hexmode;
|
||||
int pppmode;
|
||||
@@ -51,6 +60,15 @@
|
||||
@@ -51,6 +64,15 @@
|
||||
int start_time_tenths;
|
||||
int tot_sent, tot_rcvd;
|
||||
|
||||
|
@ -37,7 +40,7 @@ $NetBSD: patch-bi,v 1.2 2008/12/26 21:41:40 hasso Exp $
|
|||
extern int optind;
|
||||
extern char *optarg;
|
||||
|
||||
@@ -191,7 +209,7 @@
|
||||
@@ -191,7 +213,7 @@
|
||||
show_time(f, c);
|
||||
break;
|
||||
default:
|
||||
|
@ -46,7 +49,7 @@ $NetBSD: patch-bi,v 1.2 2008/12/26 21:41:40 hasso Exp $
|
|||
}
|
||||
}
|
||||
}
|
||||
@@ -234,15 +252,6 @@
|
||||
@@ -234,15 +256,6 @@
|
||||
0x7bc7, 0x6a4e, 0x58d5, 0x495c, 0x3de3, 0x2c6a, 0x1ef1, 0x0f78
|
||||
};
|
||||
|
||||
|
@ -62,7 +65,7 @@ $NetBSD: patch-bi,v 1.2 2008/12/26 21:41:40 hasso Exp $
|
|||
/* Values for flags */
|
||||
#define CCP_ISUP 1
|
||||
#define CCP_ERROR 2
|
||||
@@ -321,7 +330,7 @@
|
||||
@@ -321,7 +334,7 @@
|
||||
++r;
|
||||
if (endp - r > mru)
|
||||
printf(" ERROR: length (%d) > MRU (%d)\n",
|
||||
|
@ -71,7 +74,7 @@ $NetBSD: patch-bi,v 1.2 2008/12/26 21:41:40 hasso Exp $
|
|||
if (decompress && fcs == PPP_GOODFCS) {
|
||||
/* See if this is a CCP or compressed packet */
|
||||
d = dbuf;
|
||||
@@ -340,8 +349,15 @@
|
||||
@@ -340,8 +353,15 @@
|
||||
&& (pkt->flags & CCP_DECOMP_RUN)
|
||||
&& pkt->state
|
||||
&& (pkt->flags & CCP_ERR) == 0) {
|
||||
|
@ -89,7 +92,7 @@ $NetBSD: patch-bi,v 1.2 2008/12/26 21:41:40 hasso Exp $
|
|||
switch (rv) {
|
||||
case DECOMP_OK:
|
||||
p = dbuf;
|
||||
@@ -364,7 +380,10 @@
|
||||
@@ -364,7 +384,10 @@
|
||||
}
|
||||
} else if (pkt->state
|
||||
&& (pkt->flags & CCP_DECOMP_RUN)) {
|
||||
|
|
Loading…
Reference in a new issue